Page 11 of 13 [185 Posts]   Goto page: Previous 1, 2, 3, ..., 9, 10, 11, 12, 13 Next
Author Message
edoc
PostPosted: Sun 30 Nov 2008, 10:08    Post subject:

ttuuxxx wrote:

Sorry edoc my search engine is google based and works better than any other puppy based search engine. If you have another client which is better than google for search results please give me a link and I'll alter them Smile
ttuuxxx


http://clusty.com is an excellent search engine without the politics of google. I use it as my default Seamonkey search engine on all 4 installs here.

I don't know how you call google so I don't know if it is as simple as changing the URL or more complex.

I know that google is following the MS model of trying to embed it's proprietary search features everywhere to reinforce their monopoly - which is why I believe that using an alternative search engine is a good keep-the-market-free market strategy - even if it may be slightly less easy.

IMHO, YMMV ...
dejan555
PostPosted: Sun 30 Nov 2008, 08:10    Post subject:  

Here there are 3 games that I compiled on puppy 4.1 and packed as sfs modules:
Block Attack
Block Rage
ViTetris
http://softver1.freehostia.com/puppy4/games/
Screenshots:
http://blockattack.sourceforge.net/images/screenshot11.jpg
http://linux.softpedia.com/screenshots/Block-Rage_1.jpg
http://victornils.net/tetris/#screenshots

Load sfs then type in terminal:
blockattack
blockrage
vitetris
or just tetris if you play it in bare terminal with no X
ttuuxxx
PostPosted: Sun 30 Nov 2008, 07:03    Post subject:

edoc wrote:
Your search engine looks great! I have downloaded and loaded it - I presume that I will need to either close and re-open Seamonkey or reboot to see it?

Also, it appears from your image that it is based on Google - would it require major or minor code changes to switch the engine behind your engine to Clusty?

I have some philosophical problems with Google which they seem to exacerbate regularly. Smile

Quote:
SDL and SDL_mixer are needed. If you installed Barrage, you have them. You may also need xorg_OPENGL and xorg_DRI_MODULES from petget. Installs to my-roxapp


I wonder if this description of the dependencies for SuperTux may not be correct for 4.11? Perhaps more than xorg_OPENGL is required to meet the openGL requirements of SuperTux?


Sorry edoc my search engine is google based and works better than any other puppy based search engine. If you have another client which is better than google for search results please give me a link and I'll alter them Smile
ttuuxxx
ttuuxxx
PostPosted: Sat 29 Nov 2008, 23:13    Post subject:

edoc wrote:
WARNING WILL ROBINSON!!!

I did not realize that your app would replace Seamonkey as my default Web browser ... I was thinking it was just to add the little search window to Seamonkey.

If I run the PetGet uninstall will it restore Seamonkey, please?

Is there a way to just add the search window? I like the integration of Seamonkey.

Yes just install this little pet package and seamonkey will be default Smile
ttuuxxx
edoc
PostPosted: Sat 29 Nov 2008, 22:33    Post subject:

"DANGER WILL ROBINSON!"

I did not realize that your app would replace Seamonkey as my default Web browser ... I was thinking it was just to add the little search window to Seamonkey.

I ran the PetGet uninstall and after removing your custom browser and rebooting it restored Seamonkey.

Is there a way to just add the search window? I like the integration of Seamonkey.
edoc
PostPosted: Sat 29 Nov 2008, 22:14    Post subject:

Your search engine looks great! I have downloaded and loaded it - I presume that I will need to either close and re-open Seamonkey or reboot to see it?

Also, it appears from your image that it is based on Google - would it require major or minor code changes to switch the engine behind your engine to Clusty?

I have some philosophical problems with Google which they seem to exacerbate regularly. Smile

Quote:
SDL and SDL_mixer are needed. If you installed Barrage, you have them. You may also need xorg_OPENGL and xorg_DRI_MODULES from petget. Installs to my-roxapp


I wonder if this description of the dependencies for SuperTux may not be correct for 4.11? Perhaps more than xorg_OPENGL is required to meet the openGL requirements of SuperTux?
ttuuxxx
PostPosted: Sat 29 Nov 2008, 21:04    Post subject:

edoc wrote:
The SuperTux PET text needs to be edited to specify these three SDL dependencies rather than the libSDL nomenclature which is confusing and will not lead one to a functional solution.

I have no idea who would do that but thought I'd put it out here in hopes that it will pop up when someone is reviewing posts re. SuperTux.

Meanwhile what you posted solved the dependency problem - SuperTux is working on my ancient CF-27 laptop!

New Challenge: I had no sound and when I opened Options it says "openGL not supported" - is that something I can fix or is it a hardware limitation, please?


Ok I haven't ever compiled or installed Supertux but I did find out a lot of links on the forum to it.
http://www.google.com/search?q=SuperTux&sitesearch=http://www.murga-linux.com/puppy/

Oh by the way are you using FirePup 4.3 ? the latest version with a Murga-Linux search engine That I built into it, It was easy to make a search engine after I learned the first one, So I made 5 of them for FirePup Wink ? You just type a name like SuperTux in the right hand corner and it gives you all the search results for this forum. It works way better than the built in phpBB search on the top of this page.
http://www.elmirachristianacademy.com/ChurchPup_dotpets/FirePup-0.04.3.pet
ttuuxxx

Ps below is the actual search results Smile

0.05 seconds for that many results, Its way quicker also Smile
edoc
PostPosted: Sat 29 Nov 2008, 20:31    Post subject:

The SuperTux PET text needs to be edited to specify these three SDL dependencies rather than the libSDL nomenclature which is confusing and will not lead one to a functional solution.

I have no idea who would do that but thought I'd put it out here in hopes that it will pop up when someone is reviewing posts re. SuperTux.

Meanwhile what you posted solved the dependency problem - SuperTux is working on my ancient CF-27 laptop!

New Challenge: I had no sound and when I opened Options it says "openGL not supported" - is that something I can fix or is it a hardware limitation, please?
ttuuxxx
PostPosted: Sat 29 Nov 2008, 20:02    Post subject:

edoc wrote:
Ha! I did a lengthy search and found this:

http://www.puppylinux.ca/tpp/ttuuxxx/Libs/

Went to download and the specific ones I need are all 0kb Sad

libSDL_image-1.2.so.0
libSDL_mixer-1.2.so.0
libSDL-1.2.so.0

Why would that be, please?

Anyhow, I will run the ones you have provided here and hopefully that will solve the problem. Thanks! Smile


Those would be the system links to actual files, Thats why they are 0kb, also there is more to the code of SDL than just the libs, Unlike most libs you can get away with the main libs.
ttuuxxx
Ps if you need anymore sdl files just ask, I have a few others.
ttuuxxx
edoc
PostPosted: Sat 29 Nov 2008, 19:57    Post subject:

Ha! I did a lengthy search and found this:

http://www.puppylinux.ca/tpp/ttuuxxx/Libs/

Went to download and the specific ones I need are all 0kb Sad

libSDL_image-1.2.so.0
libSDL_mixer-1.2.so.0
libSDL-1.2.so.0

Why would that be, please?

Anyhow, I will run the ones you have provided here and hopefully that will solve the problem. Thanks! Smile
ttuuxxx
PostPosted: Sat 29 Nov 2008, 19:43    Post subject:

edoc wrote:
I receive an error that it is missing dependencies: libSDL_image-1.2.so.0, libSDL_mixer-1.2.so.0, and libSDL-1.2.so.o -- Where might these be located, please?

right here Smile
usually they are linked to erics server but its out of bandwidth for the month. Looking forward to next month Smile
anyways here ya go.
ttuuxxx
edoc
PostPosted: Sat 29 Nov 2008, 11:06    Post subject:

ttuuxxx wrote:
sideburns wrote:
If I don't want to install Barrage just to get the SDL files (It's not a game that looks like I'd be interested in it.) how do I know which ones to download, or should I just take them all?

most sdl games only need
http://www.puppylinux.ca/tpp/ttuuxxx/programs/SDL-Programs/SDL-1.2.13-i386.pet
but when you install a game it should tell you which sdl is missing and just download from my post on page 1 near the bottom
ttuuxxx


Is it still correct that for SuperTux one needs the 7.36MB .PET plus your SDL .PET and xorg_OPENGL and xorg_DRI_MODULE?

(I read that the latter two are acquired from PetGet and they install to my-roxapps. Is that also correct?)

I am running 4.11-Normal in a Frugal install with xorg managing the video.

EDIT 1: I used PetGet and loaded the xorg_ package. Then I downloaded dotpuphandler-0.0.4-2 and loaded it. Then I downloaded and loaded Barrage (which is supposed to contain the only remaining dependencies - SDL and SDL_mixer -- though it seems odd that the dependencies may not be loaded without a game attached to them). Then I ran SuperTux. I receive an error that it is missing dependencies: libSDL_image-1.2.so.0, libSDL_mixer-1.2.so.0, and libSDL-1.2.so.o -- Where might these be located, please?
battleshooter
PostPosted: Sun 12 Oct 2008, 04:57    Post subject:

Just came back from up north the island. Good to be back in the forums. Smile

Quote:
Would it be possible, particularly for the larger games to load them as a SFs file which you could include or exclude on boot up


Interesting idea JohnB. Were you thinking of a collection of games on a SFS or jut one game per SFS?

Quote:
Is there a pup2sfs?


Had a brief glance around the forum. Doesn't seem to be one as far as I know, but I haven't really looked.

Battleshooter
JohnB
PostPosted: Mon 06 Oct 2008, 14:58    Post subject: Sfs Games

Great selection of games. Would it be possible, particularly for the larger games to load them as a SFs file which you could include or exclude on boot up. Will it work and will it avoid stretching pupsave files? There is pet2sfs to do a conversion. Is there a pup2sfs?
droope
PostPosted: Mon 06 Oct 2008, 11:55    Post subject:

Thanks a lot!

Really nice games, I was just missing civilization from my old XP Smile
Display posts from previous:   Sort by:   
Page 11 of 13 [185 Posts]   Goto page: Previous 1, 2, 3, ..., 9, 10, 11, 12, 13 Next

Powered by phpBB © 2001, 2005 phpBB Group