Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 22 Oct 2018, 22:45
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Avidemux video editor
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 3 [35 Posts]   Goto page: Previous 1, 2, 3
Author Message
mikeslr


Joined: 16 Jun 2008
Posts: 2700
Location: 500 seconds from Sol

PostPosted: Thu 20 Sep 2018, 21:31    Post subject: Avidemux 2.71 for BionicPup64  

Hi All,

Not having found a video editing tool readily available for BionicPup64, I put one together thanks to ITSMERSH's PaDS 1.1.4. Available as a pet or SFS from here: http://www.mediafire.com/?13c9khbba4s0q

It's audio defaults to PulseAudio. Not having found that on my system, it complained. Easily fixed: From the Top Menu select Edit>Preferences, Click the Audio Tab, and change AudioDevice to AlsaHw0. [Edited per norgo's post next following].

Other than the above don't expect any advice from me. I build things by assembling packages --sort of like a 8 year old with an erector set-- then test to see if they run, and use ldd (list dynamic dependencies) to determine if anything is missing. Haven't the foggiest as to what goes into making a package. Sad If you need to know the 'nuts & bolts' because something you thought should work didn't, I suggest you post to the "Users" SubForum.

Happy computing.

Last edited by mikeslr on Fri 21 Sep 2018, 19:51; edited 1 time in total
Back to top
View user's profile Send private message 
norgo


Joined: 13 Nov 2015
Posts: 276
Location: Germany

PostPosted: Fri 21 Sep 2018, 11:44    Post subject: Re: Avidemux 2.71 for BionicPup64  

mikeslr wrote:
... Click the Audio Tab, and change AudioDevice to AlsaDefault....

a really bad advise !

norgo wrote:
Please note !
in version 2.6.20 mentioned "AlsaDefault - bug" is still existing,
that's why don't use this setting.

Please select AlsaHw0 instead.


Tried avidemux 2.7.0 qt5 from here.
Worked OOTB without sound problems.
Back to top
View user's profile Send private message Visit poster's website 
mikeslr


Joined: 16 Jun 2008
Posts: 2700
Location: 500 seconds from Sol

PostPosted: Fri 21 Sep 2018, 20:11    Post subject: select AlsaHw0 instead  

Thanks norgo for the report. I was unaware of the AlsaDefault - bug. So, I changed preferences to AlsaHw0 and it handled sound properly. [While exploring BionicPup64 shutdown problems, I'm using an essentially bare SaveFile. So the above was done after loading the Avidemux.sfs].

Unfortunately, my experience with the Slacko64 avidemux 2.7.0 qt5 wasn't anywhere as good. After unloading the SFS and installing avidemux-2.7.0-qt5-x86_64.pet, it wouldn't run and ldd showed a lot of missing Qt dependencies. So I went back and carefully read the post linked to and realized that that avidemux has a dependency: libQt5Base-5.6.1-1-slk700-x86_64.pet. I installed that as well. Both a restart-x and a Save and Reboot continued to reveal via ldd what show missing Qt-libs, and significantly other libs. See attached -- change false zip to txt.

A quick visual scan of /usr/lib showed that they were actually present. That ldd isn't finding libgcc_s.so.1 suggests some fundamental differs between Slacko64 and BionicPup64. Moreover, BionicPup64 has some core qt5 libs builtin. Installing the libQt5Base-5.6.1-1-slk700-x86_64.pet may overwrite them with similarly named, but structurally, different versions.

I would have loved to have been able to withdraw the avidemux packages I published. I appreciate that mediafire offers a significant amount of webspace for free [well, it's a marketing tactic, but still] and feel obliged not to misuse that courtesy. Under the circumstances, however, I'll continue to make the packages available.
avidemux-Slacko64.zip
Description  Change false zip to txt
zip

 Download 
Filename  avidemux-Slacko64.zip 
Filesize  5.76 KB 
Downloaded  12 Time(s) 
Back to top
View user's profile Send private message 
norgo


Joined: 13 Nov 2015
Posts: 276
Location: Germany

PostPosted: Fri 21 Sep 2018, 21:27    Post subject:  

Hello Mike,
thank you for feedback,

Of course the application should become compiled for the desired OS and version because of dependencies.

The needed qt5 libs are already installed by default at Bionicpup64.
There is something wrong with your installation ! please check this
Attached the ldd check I did today for comparison.
Nevertheless thank you very much for your work.

I was surprised that volume slider worked in bionicpup.
Now I know the answer, libjson-c isn't contained by default in Slacko.
avidemux_ldd_bionic.zip
Description  replace zip by txt
zip

 Download 
Filename  avidemux_ldd_bionic.zip 
Filesize  4.21 KB 
Downloaded  8 Time(s) 
Back to top
View user's profile Send private message Visit poster's website 
mikeslr


Joined: 16 Jun 2008
Posts: 2700
Location: 500 seconds from Sol

PostPosted: Sat 22 Sep 2018, 09:47    Post subject:  

Thanks norgo,

Will check my BionicPup64 installation.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 3 of 3 [35 Posts]   Goto page: Previous 1, 2, 3
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0502s ][ Queries: 13 (0.0180s) ][ GZIP on ]