Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 16 Oct 2018, 03:32
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » System
YaPI (yet another Puppy Installer) install any Puppy iso
Post new topic   Reply to topic View previous topic :: View next topic
Page 4 of 5 [67 Posts]   Goto page: Previous 1, 2, 3, 4, 5 Next
Author Message
bigpup


Joined: 11 Oct 2009
Posts: 11124
Location: Charleston S.C. USA

PostPosted: Fri 21 Sep 2018, 22:32    Post subject:  

sheldonisaac,

What Puppy version are you using?
What install were you doing using Yapi?
Did it do the selected install OK?

I assume what you posted was displayed by running Yapi in a terminal.

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
sheldonisaac

Joined: 21 Jun 2009
Posts: 749
Location: Philadelphia, PA

PostPosted: Sat 22 Sep 2018, 20:56    Post subject:  

bigpup wrote:
sheldonisaac,

What Puppy version are you using?
What install were you doing using Yapi?
Did it do the selected install OK?
I assume what you posted was displayed by running Yapi in a terminal.

Not sure, probably the new 64-bit Bionic Pup
I just typed yapi in a terminal. Now think that was not how to use it. Will go back and read the thread. Please excuse me.

_________________
Dell E6410: Xenial, Bionicpup64, etc
Dell Mini 9, Acer Aspire One, EeePC 1018P, PowerBook G4
Intel D865GBF, Intel DQ35JOE
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 11124
Location: Charleston S.C. USA

PostPosted: Sat 22 Sep 2018, 22:28    Post subject:  

sheldonisaac,

I just re-posted the pet for YaPI 180921
http://www.murga-linux.com/puppy/viewtopic.php?mode=attach&id=119199
Could you delete the one you have and replace it with this one. Fixed a minor problem with the pet package.

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
sheldonisaac

Joined: 21 Jun 2009
Posts: 749
Location: Philadelphia, PA

PostPosted: Sun 23 Sep 2018, 09:25    Post subject:  

bigpup wrote:
sheldonisaac,

I just re-posted the pet for YaPI 180921
http://www.murga-linux.com/puppy/viewtopic.php?mode=attach&id=119199
Could you delete the one you have and replace it with this one. Fixed a minor problem with the pet package.
I hope this is it?
Code:
-rw-r--r-- 1 root root 27841 Sep 22 22:34 yapi-180921.pet
1f2bda8b2dae6147fdd33a72f692e53f  yapi-180921.pet
Thanks a lot, bigpup; I managed to put a lucid puppy on a 16GB USB flash drive.
Using musher0's 32-bit Xenial puppy.
Code:

Linux puppypc2261 4.1.2-EmSee-32-pae #1 SMP Wed Jul 15 12:39:34 BST 2015 i686 i686 i686 GNU/Linux
Sheldon
_________________
Dell E6410: Xenial, Bionicpup64, etc
Dell Mini 9, Acer Aspire One, EeePC 1018P, PowerBook G4
Intel D865GBF, Intel DQ35JOE
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 3410
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Sat 06 Oct 2018, 10:27    Post subject:  

Bonjour,
Be aware!
I just tested another program than yapi on puppy_tahr_6.0.5 and I noticed that the yaf-splash/gtkdialog-splash of previous Puppy versions has been replaced by /usr/lib/gtkdialog/box_splash, presented as "compatible" with the ancestor but which in reality is not quite Confused. In some cases, the display is erratic (huge window that occupies almost the entire desktop!).
The old yaf-splash is not affected by the box_splash options. It simply does not "see" them. However, these options seem essential (such as the width of the icon for example), so they have to be set.
To be investigated further...

Cordialement.

_________________

Back to top
View user's profile Send private message Visit poster's website 
kiramm


Joined: 06 May 2016
Posts: 503
Location: http://murga-linux.com/puppy/viewtopic.php?p=988393#988393

PostPosted: Sun 07 Oct 2018, 22:16    Post subject:  

i wanted to get puppy on usb

on usb was already xenial done with unetin..

and nothing happened xenial still there at boot up

see pics


what i do understand wrong?

i used the 1st and last version 2 differe usb
always same result



scaning takes verry lot time maybe would be good extra option one can look
alone faster to right place for iso...



i use slackouefi632

which are other usb installers to try?
yops1.jpg
 Description   
 Filesize   113.46 KB
 Viewed   121 Time(s)

yops1.jpg

yaps2.jpg
 Description   
 Filesize   18.77 KB
 Viewed   122 Time(s)

yaps2.jpg

yaps3.jpg
 Description   
 Filesize   14.07 KB
 Viewed   122 Time(s)

yaps3.jpg

yaps4.jpg
 Description   
 Filesize   160.6 KB
 Viewed   120 Time(s)

yaps4.jpg

Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 11124
Location: Charleston S.C. USA

PostPosted: Sun 07 Oct 2018, 22:48    Post subject:  

Quote:
on usb was already xenial done with unetin..

If Unetbootin did the install of Xenialpup the USB flash drive is setup by Unetbootin.

YaPI can not change that.
YaPi is made to do installs to a USB flash drive that has not been used by another installer program.
Start with a freshly partitioned and formatted flash drive that has nothing on it.
Fat32 is OK for format
(the way new USB flash drives come pre- formatted)

Quote:
scaning takes verry lot time maybe would be good extra option one can look
alone faster to right place for iso...

Already does it.

Do not start YaPI.
In Rox file manager.
Navigate to the iso you want to install.
Right click on it.
From right click menu select YaPI or select open with... YaPI.
YaPI will start at selection Window asking where to install the iso.

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
kiramm


Joined: 06 May 2016
Posts: 503
Location: http://murga-linux.com/puppy/viewtopic.php?p=988393#988393

PostPosted: Mon 08 Oct 2018, 09:06    Post subject:  

it s written in yapi that ... it will be formated


anyway i formated king.. usb with king..format tool in windows


i tried this time other pc where xthar

to put slacko on usb

i used right click to open yapi
worked:)

end result was same Sad

the format didn t help:(

what is to do?


came that print out



which format program for fat32 i should use ?

Last edited by kiramm on Mon 08 Oct 2018, 14:18; edited 1 time in total
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 11124
Location: Charleston S.C. USA

PostPosted: Mon 08 Oct 2018, 09:38    Post subject:  

At the final step of using YaPI.
Did you run Grub4dos config and put this boot loader on the USB flash drive?
Tell it to search only on the USB flash drive?

This should setup the USB flash drive to boot using Grub4dos boot loader and make a menu to select from at boot-up.

To partition and format.
I always use Gparted running in a Puppy version.
I do not think how you formatted is your problem.
Fat 32 is a very basic format any program should do OK.

Example of what should be on USB flash drive after using YaPI.
This is an install of Bionicpup64 7.9.5
capture17042.png
 Description   
 Filesize   18.49 KB
 Viewed   96 Time(s)

capture17042.png


_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 11124
Location: Charleston S.C. USA

PostPosted: Mon 08 Oct 2018, 09:48    Post subject:  

Quote:
end result was same.

came that print out

If you are talking about what you show in posted image yaps4.
I have no idea why you would get that.
Nothing in YaPI should make that window output.

Quote:
i tried this time other pc where xthar


yapi is coded to work in Official Puppies.
xthar being a derivative of Tahrpup 6.0.5.
Maybe something needed is not in xtahr Idea

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 3410
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Mon 08 Oct 2018, 10:41    Post subject:  

Bonjour,
Today, I wanted to test "yaf-splash" because of the strange behavior reported above. I installed successfully and very quickly slacko-6.3.0, xenialpup-7.5, stretch-7.5, tahr-6.0.5 from iso files with YaPi ("Open with" right click menu), and all went right, provided that I adapt the menu.lst accordingly:
Code:
# menu.lst produced by grub4dosconfig-v1.9.3
color blue/cyan yellow/blue white/black cyan/black
#splashimage=/splash.xpm
timeout 10
default 0

# Frugal installed Puppy

title Puppy tahr 6.0.5
  find --set-root --ignore-floppies --ignore-cd /tahr605_PAE/initrd.gz
  kernel /tahr605_PAE/vmlinuz   psubdir=tahr605_PAE pmedia=usbflash pfix=fsck
  initrd /tahr605_PAE/initrd.gz

title Puppy Stretch 7.5
  find --set-root --ignore-floppies --ignore-cd /stretch75_k4148/initrd.gz
  kernel /stretch75_k4148/vmlinuz   psubdir=stretch75_k4148 pmedia=usbflash pfix=fsck
  initrd /stretch75_k4148/initrd.gz

title Puppy Slacko 6.3.0
  find --set-root --ignore-floppies --ignore-cd /slacko630/initrd.gz
  kernel /slacko630/vmlinuz   psubdir=slacko630 pmedia=usbflash pfix=fsck
  initrd /slacko630/initrd.gz

title Puppy Xenialpup 7.5
  find --set-root --ignore-floppies --ignore-cd /xenialpup75uefi/initrd.gz
  kernel /xenialpup75uefi/vmlinuz   psubdir=xenialpup75uefi pmedia=usbflash pfix=fsck
  initrd /xenialpup75uefi/initrd.gz

# Advanced Menu
title Advanced menu
  configfile /menu-advanced.lst
  commandline

Now, and this is the reason of this post: I noticed (and confirm) something very annoying. None of these Puppy versions that have /usr/lib/gtkdialog/box_splash instead of the previous /usr/bin/gtkdialog-splash support animated gif icons.

I don't know exactly where to report the issue but I think it is important that this be done!

[EDIT]: Done! Arrow /usr/lib/gtkdialog/box_splash and animated gif icons?

Cordialement.

_________________


Last edited by Argolance on Mon 08 Oct 2018, 17:14; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
kiramm


Joined: 06 May 2016
Posts: 503
Location: http://murga-linux.com/puppy/viewtopic.php?p=988393#988393

PostPosted: Mon 08 Oct 2018, 14:29    Post subject:  

I always use Gparted running in a Puppy version.
..............


i havent seen any gparted puppy

what is this?


--------------------


i dont understand:


it s written :

yapi is puppy installer...


so this is not full program ?


beacaus if its full program i just have to press th buttons which are in program


but this evidently not work


so


1) i have to go to shop to buy a fresh usb for yapi?

2) pleaseeee where is the link with windows or puppy program to make old usb back to fresh with clicking and not assembler ms dos like programing;)?


i amreally keen on yapi!


-----------------------------------------------

appendix

i produced with puppy installer

see pic but this also not start

pc sais put bootable.... then pres key
----------------------------------------------------------

-----------------------gparted try same 0 result see pics



--------------------------------
-------------------------------


last try yaps came to end

reboot showed menue of usb instaled uefithat

but after pressing start

came out see link:


https://photos.app.goo.gl/GBg4FQxsKCZkKtqK8


here all photos: of all tries:

https://photos.app.goo.gl/rVi8QHSkGDFoxY4n6

---> 2) pleaseeee where is the link with windows or puppy program to make old usb back to fresh with clicking and not assembler ms dos like programing;)?



help:(
yapi-cant-usethe -iso if it s in win8can this be improved..jpg
 Description   
 Filesize   63.31 KB
 Viewed   47 Time(s)

yapi-cant-usethe -iso if it s in win8can this be improved..jpg

YAPS LASTTRY.png
 Description   THIS YAPI NEEDS NO WOMEN GET THIS READY
 Filesize   19.79 KB
 Viewed   53 Time(s)

YAPS LASTTRY.png

YAPI COMES ON AFTER FARTED FORMAT BOOT FLAG .png
 Description   WITH THIS IT COMES TO END i thik yapi spould do this terrible job
by himself otherwise one should write yapi ONLY FOR MEN ;)
 Filesize   25.9 KB
 Viewed   54 Time(s)

YAPI COMES ON AFTER FARTED FORMAT BOOT FLAG .png

fart5.png
 Description   
 Filesize   67.85 KB
 Viewed   57 Time(s)

fart5.png

fart4.png
 Description   
 Filesize   28.19 KB
 Viewed   56 Time(s)

fart4.png

fart3.png
 Description   
 Filesize   16.91 KB
 Viewed   58 Time(s)

fart3.png

fart2.png
 Description   
 Filesize   46.28 KB
 Viewed   57 Time(s)

fart2.png

y.png
 Description   
 Filesize   71.46 KB
 Viewed   61 Time(s)

y.png

Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 11124
Location: Charleston S.C. USA

PostPosted: Mon 08 Oct 2018, 20:45    Post subject:  

I just did a frugal install of Xtahr 2.0 using Yapi running in Tahrpup 6.0.5
Installed Xtahr 2.0 to a USB flash drive.
USB flash drive formatted fat 32.

Booted OK to the desktop. No problems.
Posting this message from this working Xtahr 2.0

I am not sure why this is giving you so much trouble.

Those boot error messages you got, I have seen before, if the USB flash drive partitioning, formatting, and file allocation table are bad.

Start over fresh with the USB flash drive.
Using some Puppy you can boot with.
Have the usb flash drive unmounted.

Use Gparted.
Make a new partition table. Make it msdos
Make a partition.
Format the partition to fat 32.

Try a new install of a Puppy iso using YaPI.

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
kiramm


Joined: 06 May 2016
Posts: 503
Location: http://murga-linux.com/puppy/viewtopic.php?p=988393#988393

PostPosted: Mon 08 Oct 2018, 22:20    Post subject:  

is there really no link for this in all it world?


---> 2) pleaseeee where is the link with windows or puppy program to make old usb back to fresh with clicking and not assembler ms dos like programing;)?



on pic was not xthar but thar 606

https://photos.app.goo.gl/rVi8QHSkGDFoxY4n6

[url] https://photos.app.goo.gl/rVi8QHSkGDFoxY4n6 [/url]

https://photos.google.com/share/AF1QipPWq9ANkpeQFRIHRfWv6WUbAPD10e5753TAWeL6GzjiqjfBbyscy55fjrgVheyEpg?key=WmR3YVdQbmtRUHNURTBsc0lvVFk0dDFMMzNUcGJB




i got xthar also meantime to run on old usb

but the new scandisc nottt


there is an real need for strong fffformat program u know alink for this link for this?


why on iso dvd less problems ?



........ur advice not possible : there is no msdos choice in gparted

and yapi wants also boot flag u didnt say

any way also with flag this 30giga new usb in not willing what to do ?
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 11124
Location: Charleston S.C. USA

PostPosted: Mon 08 Oct 2018, 23:24    Post subject:  

Quote:
yapi wants also boot flag u didnt say

Sorry, Embarassed I thought you knew about flagging the partition boot.

Quote:
ur advice not possible : there is no msdos choice in gparted

Do you know how to use Gparted?

Gparted>Device>Create Partition Table
capture11177.png
 Description   
 Filesize   16.62 KB
 Viewed   25 Time(s)

capture11177.png


_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked

Last edited by bigpup on Mon 08 Oct 2018, 23:36; edited 1 time in total
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 4 of 5 [67 Posts]   Goto page: Previous 1, 2, 3, 4, 5 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » System
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0758s ][ Queries: 13 (0.0182s) ][ GZIP on ]