Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 16 Dec 2018, 04:16
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
XenialDog (Ubuntu 16.04 'Xenial Xerus' LTS, 32-bit)
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 66 of 67 [998 Posts]   Goto page: Previous 1, 2, 3, ..., 64, 65, 66, 67 Next
Author Message
fredx181


Joined: 11 Dec 2013
Posts: 3585
Location: holland

PostPosted: Tue 04 Sep 2018, 05:08    Post subject:  

johnywhy wrote:
Workspaces: Can't adjust number of workspaces. Workspace switcher properties gives error on click "Workspace settings"
Quote:
Unable to open the workspace settings. Failed to execute child process "xfwm4-workspace-settings" (No such file or directory.


Yes, that doesn't work, but you can set it in the "Openbox Configuration manager" in Menu > Settings
(Tab "Desktops")

Fred

_________________
Dog Linux website
Back to top
View user's profile Send private message 
zagreb999

Joined: 11 Apr 2014
Posts: 406
Location: Yugoslavija

PostPosted: Mon 10 Sep 2018, 15:55    Post subject: slimjet, chromium last  

regards

is there latest slimjet, chromium
for xenialdog and dd 32 bit?
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 3585
Location: holland

PostPosted: Tue 11 Sep 2018, 03:53    Post subject:  

@zagreb,
Try the slimjet deb perhaps ?
https://www.slimjet.com/en/postdl.php?version=lnx32&type=deb
Chromium is in the repository AFAIK.

_________________
Dog Linux website
Back to top
View user's profile Send private message 
zagreb999

Joined: 11 Apr 2014
Posts: 406
Location: Yugoslavija

PostPosted: Sun 23 Sep 2018, 14:13    Post subject: djview4  

fred,
is it possible to kreate sfs (or install)
djview4?

thanks.
Back to top
View user's profile Send private message 
dancytron

Joined: 18 Jul 2012
Posts: 1163

PostPosted: Sun 23 Sep 2018, 15:08    Post subject: Re: djview4  

zagreb999 wrote:
fred,
is it possible to kreate sfs (or install)
djview4?

thanks.


You should be able to use apt-get. It is in the repositories.
[url]
https://packages.ubuntu.com/search?searchon=sourcenames&keywords=djview4[/url]
Back to top
View user's profile Send private message 
zagreb999

Joined: 11 Apr 2014
Posts: 406
Location: Yugoslavija

PostPosted: Mon 24 Sep 2018, 04:15    Post subject: djview4  

... it is impossible to install
djview4 on xd!!!
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 3585
Location: holland

PostPosted: Mon 24 Sep 2018, 11:35    Post subject: Re: djview4  

zagreb999 wrote:
... it is impossible to install
djview4 on xd!!!


For me it works, why not for you, what does it say ?

Code:
root@xenial:~# apt-get install djview4
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  libdjvulibre-text libdjvulibre21 libgudev-1.0-0 libinput-bin libinput10 libpcre16-3
  libqt5core5a libqt5dbus5 libqt5gui5 libqt5network5 libqt5opengl5 libqt5printsupport5
  libqt5widgets5 libwacom-common libwacom2 libxcb-icccm4 libxcb-image0 libxcb-keysyms1
  libxcb-randr0 libxcb-render-util0 libxcb-xkb1 libxkbcommon-x11-0
Suggested packages:
  djvulibre-bin djview-plugin libqt5libqgtk2 qt5-image-formats-plugins qtwayland5
Recommended packages:
  djvulibre-desktop qttranslations5-l10n libqt5svg5 libwacom-bin
The following NEW packages will be installed:
  djview4 libdjvulibre-text libdjvulibre21 libgudev-1.0-0 libinput-bin libinput10
  libpcre16-3 libqt5core5a libqt5dbus5 libqt5gui5 libqt5network5 libqt5opengl5
  libqt5printsupport5 libqt5widgets5 libwacom-common libwacom2 libxcb-icccm4
  libxcb-image0 libxcb-keysyms1 libxcb-randr0 libxcb-render-util0 libxcb-xkb1
  libxkbcommon-x11-0
0 upgraded, 23 newly installed, 0 to remove and 234 not upgraded.
Need to get 11.6 MB of archives.
After this operation, 44.2 MB of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 http://nl.archive.ubuntu.com/ubuntu xenial/main i386 libxcb-icccm4 i386 0.4.1-1ubuntu1 [10.8 kB]
Get:2 http://nl.archive.ubuntu.com/ubuntu xenial/main i386 libxcb-keysyms1 i386 0.4.0-1 [8562 B
.....
.....]

_________________
Dog Linux website
Back to top
View user's profile Send private message 
zagreb999

Joined: 11 Apr 2014
Posts: 406
Location: Yugoslavija

PostPosted: Mon 24 Sep 2018, 11:44    Post subject:  

thanks fred

i already resolved...

great app is djview4!
Back to top
View user's profile Send private message 
zagreb999

Joined: 11 Apr 2014
Posts: 406
Location: Yugoslavija

PostPosted: Thu 11 Oct 2018, 08:42    Post subject: slimjet 20  

any help?
slimjet 20
on xenialdog?

thanks!
Back to top
View user's profile Send private message 
mikeslr


Joined: 16 Jun 2008
Posts: 2845
Location: 500 seconds from Sol

PostPosted: Thu 11 Oct 2018, 11:09    Post subject:  

Hi zagreb999,

OscarTalks just published slimjet 20 as both a pet and an SFS, http://murga-linux.com/puppy/viewtopic.php?p=1006708#1006708. Perhaps the SFS could be loaded in XenialDog? May require installing some libs. To figure out which, I've been advised that ldd works under the Dogs. But see the above post regarding what OscarTalks did.

Note, OscarTalks versions run as spot. Could probably be edited to run as whatever limited user XenialDog employs. Alternatively as OscarTalks post reveals what libraries were required --libgtk-3 and, as I understand it, the nss files otherwise provided by palemoon-- perhaps you could build your own starting with a slimjet 20 deb.
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 3585
Location: holland

PostPosted: Thu 11 Oct 2018, 13:14    Post subject:  

zagreb999 wrote:
any help?
slimjet 20
on xenialdog?


Assuming you downloaded and installed slimjet .deb from here:
https://www.slimjet.com/en/dlpage.php

Probably the problem is that it won't run as root.
Eerlier adding --no-sandbox worked to run Chromiium based browsers as root, but now it seems not working anymore.
So you need to run it as unprivileged user, if you have user "puppy" on your system, then this script should work to run Slimjet running as user puppy:

Code:
#!/bin/bash

xhost +local:puppy

su puppy -c "/usr/bin/flashpeak-slimjet "$@" --user-data-dir=/home/puppy/slimjet/user --disk-cache-dir=/home/puppy/slimjet/cache --disk-cache-size=10000000 --media-cache-size=10000000 "$@""


Fred

_________________
Dog Linux website
Back to top
View user's profile Send private message 
dancytron

Joined: 18 Jul 2012
Posts: 1163

PostPosted: Thu 11 Oct 2018, 13:59    Post subject:  

fredx181 wrote:
zagreb999 wrote:
any help?
slimjet 20
on xenialdog?


Assuming you downloaded and installed slimjet .deb from here:
https://www.slimjet.com/en/dlpage.php

Probably the problem is that it won't run as root.
Eerlier adding --no-sandbox worked to run Chromiium based browsers as root, but now it seems not working anymore.
So you need to run it as unprivileged user, if you have user "puppy" on your system, then this script should work to run Slimjet running as user puppy:

Code:
#!/bin/bash

xhost +local:puppy

su puppy -c "/usr/bin/flashpeak-slimjet "$@" --user-data-dir=/home/puppy/slimjet/user --disk-cache-dir=/home/puppy/slimjet/cache --disk-cache-size=10000000 --media-cache-size=10000000 "$@""


Fred


--no-sandbox still works on Chrome latest version. (Google Chrome
Version 69.0.3497.100 (Official Build) (64-bit)).

Quote:
#!/bin/sh

/usr/bin/google-chrome-stable --user-data-dir=/live/image/ChromeSettings/google-chrome/config --disk-cache-dir=/live/image/ChromeSettings/google-chrome/cache --disk-cache-size=10000000 --media-cache-size=10000000 --no-sandbox --disable-infobars "$@"
Back to top
View user's profile Send private message 
zagreb999

Joined: 11 Apr 2014
Posts: 406
Location: Yugoslavija

PostPosted: Thu 11 Oct 2018, 14:47    Post subject:  

thanks to all!

who knows to ran slimjet20
as root as squashfs module?
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 3585
Location: holland

PostPosted: Thu 11 Oct 2018, 17:09    Post subject:  

dancytron wrote:
--no-sandbox still works on Chrome latest version. (Google Chrome
Version 69.0.3497.100 (Official Build) (64-bit)).


Ah, ok, then probably Slimjet is an exception (only tried 32-bit, btw).

zagreb999 wrote:
who knows to ran slimjet20
as root as squashfs module?


I don't think it's possible, I tried the slimjet v20 32-bit a few times again on different systems, cannot run as root.

Fred

_________________
Dog Linux website
Back to top
View user's profile Send private message 
rufwoof

Joined: 24 Feb 2014
Posts: 2712

PostPosted: Thu 11 Oct 2018, 17:42    Post subject:  

fredx181 wrote:
Eerlier adding --no-sandbox worked to run Chromium based browsers as root, but now it seems not working anymore.
So you need to run it as unprivileged user, if you have user "puppy" on your system, then this script should work to run Slimjet running as user puppy:
Code:
#!/bin/bash
xhost +local:puppy
su puppy -c "/usr/bin/flashpeak-slimjet "$@" --user-data-dir=/home/puppy/slimjet/user --disk-cache-dir=/home/puppy/slimjet/cache --disk-cache-size=10000000 --media-cache-size=10000000 "$@""

--no-sandbox cripples Chrome's security measures. Opening up xhost + is as good as opening up running as root (user puppy can stuff things into any other window that might be running as root, such as a rox/thunar/pcmanfm window - perhaps issuing a file manager's open terminal window command and then stuffing rm -rf / or whatever into that (root) terminal window.

_________________
( ͡° ͜ʖ ͡°) :wq
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 66 of 67 [998 Posts]   Goto page: Previous 1, 2, 3, ..., 64, 65, 66, 67 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.3072s ][ Queries: 13 (0.2066s) ][ GZIP on ]