Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 18 Nov 2018, 14:34
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking
How to connect with Huawei E3372 USB modem?
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [7 Posts]  
Author Message
nick21

Joined: 24 May 2018
Posts: 23

PostPosted: Mon 22 Oct 2018, 04:12    Post subject:  How to connect with Huawei E3372 USB modem?  

Hello,

I have a Huawei E3372 stick usb modem in Orange and I can't connect on the internet. My usb stick modem work very well if i plug it into my D-Link router (eth0), but don't work if i plug it directly into my laptop. Because I will need my laptop at school, my usb stick modem must work on internet without router, I must plug it directly into my laptop.

I plug into my laptop usb stick modem and test it with "lsusb" command and my system can see it : "ID 12d1:14fe Huawei Technologies co., LTD modem"

I try to connect it on internet, but without any success. On "dialup analog or wireless modem" box press "choose" and "Test" button but my system can't see usb modem stick even if I plug it in my laptop until I restart my system.

Please, can somebody help me step by step what can I do to connect my laptop on internet with my Usb stick modem without router?

-Usb stick modem Huawei E3372 / Orange 4G prepay
-laptop Aspire E15, i5-7200U 2.5GHz---3.1GHz, USB 3.1, 8GB DDR4
-Quirky Xerus64 operation system.

Thank you very much.
Back to top
View user's profile Send private message 
ITSMERSH


Joined: 02 May 2018
Posts: 465

PostPosted: Mon 22 Oct 2018, 04:30    Post subject:  

You'll probably need to install usb-modeswitch package and libpipeline. This has worked for me in all Puppies beyond tahr.
_________________
RSH
Back to top
View user's profile Send private message 
nick21

Joined: 24 May 2018
Posts: 23

PostPosted: Tue 23 Oct 2018, 16:29    Post subject:  

I search but both drivers already were installed by system, and I can't install over again, a think there is a solution!
Back to top
View user's profile Send private message 
zagreb999

Joined: 11 Apr 2014
Posts: 406
Location: Yugoslavija

PostPosted: Wed 24 Oct 2018, 09:25    Post subject:  

this one works
pupjibaro_jessie_B3_synaptic_k-4.5.1-pae-08072016.iso

and this one
http://murga-linux.com/puppy/viewtopic.php?p=946854&sid=2da20fb2298dff9808ca2cce4bfa4fdb
Back to top
View user's profile Send private message 
nick21

Joined: 24 May 2018
Posts: 23

PostPosted: Wed 24 Oct 2018, 11:17    Post subject:  

Hy zagreb999,

I can't understand your post,
where is this "pupjibaro_jessie_B3_synaptic_k-4.5.1-pae-08072016.iso" and how can I install it? I can install every think from ubuntu repositories, give me the name of package and I'll install it if I find it with "search" on repositories.

About your "experimental 1.3 GB ISO" I did understand nothing.

I hope that my problem is moor simpler and I must not install nothing.
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 11278
Location: Charleston S.C. USA

PostPosted: Wed 24 Oct 2018, 14:04    Post subject:  

See if this info helps you.
http://murga-linux.com/puppy/viewtopic.php?p=747421#747421
There is more info in this topic, but this seemed to be the post to start with.

Be careful to follow steps exactly as stated!

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
ITSMERSH


Joined: 02 May 2018
Posts: 465

PostPosted: Thu 25 Oct 2018, 14:28    Post subject:  

nick21 wrote:
I search but both drivers already were installed by system, and I can't install over again, a think there is a solution!

Sorry, seems I just missed one info: Quirky Xerus64 operation system

Could be a little different to Puppy.

However, if usb-modeswitch and libpipeline was already installed, you should have a program called pgprs-connect and/or frisbee to connect to the web. If the modem is NOT recognized in pgprs-setup and/or frisbee then there's something wrong with the installed usb-modeswitch.

I had this problem in all Puppies above tahr and installing usb-modeswitch and libpipeline from ubuntu repository fixed it in all cases. Probably trying to uninstall the installed version first. And after uninstalling trying to install the versions from ubuntu repository.

_________________
RSH
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [7 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Networking
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0435s ][ Queries: 12 (0.0099s) ][ GZIP on ]