Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 22 Aug 2019, 07:08
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
gtk-youtube-viewer (for lots of pups)
Post new topic   Reply to topic View previous topic :: View next topic
Page 25 of 28 [411 Posts]   Goto page: Previous 1, 2, 3, ..., 23, 24, 25, 26, 27, 28 Next
Author Message
icosahedron


Joined: 28 Nov 2011
Posts: 93
Location: UK

PostPosted: Wed 31 Oct 2018, 02:36    Post subject:  

Hi Fred thanks for that update. I’ve deleted the entire folder where I placed the March package and installed 3.5.0 instead, and again it functions. Smile

But... it’s still not playing most of the videos. Does this version need the dl updating from the outset?

I found the readme informative, and from that, I decided to poke about.

From the desktop, I found the icon labelled Console or Terminal.
Opened it.
Typed into the window at the cursor, the term:
yt-viewer-3.5.0_youtube-dl
and got:
bash: yt-viewer-3.5.0_youtube-dl: command not found

So I tried:
./yt-viewer-3.5.0_youtube-dl
and got:
bash: yt-viewer-3.5.0_youtube-dl: no such file or directory

Then I tried just:
./youtube-dl.cde -U
and got:
bash: ./youtube-dl.cde: no such file or directory.

Obviously I haven’t understood the instructions.
What can I try next?

_________________
Computers: - I just ride 'em, I dunno what makes 'em work.
Console/Terminal? What's that?
I visit the Internet to OBTAIN information, not to PROVIDE it!
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 4030
Location: holland

PostPosted: Wed 31 Oct 2018, 06:28    Post subject:  

roadkill13 wrote:
In UpupBB18.05 I am getting this:

Quote:
Can't locate WWW/YoutubeViewer/ParseXML.pm in @INC (you may need to install the WWW::YoutubeViewer::ParseXML module) (@INC contains: /etc/perl /usr/local/lib/i386-linux-gnu/perl/5.20.2 /usr/local/share/perl/5.20.2 /usr/lib/i386-linux-gnu/perl5/5.20 /usr/share/perl5 /usr/lib/i386-linux-gnu/perl/5.20 /usr/share/perl/5.20 /usr/local/lib/site_perl .) at /usr/share/perl5/WWW/YoutubeViewer/GetCaption.pm line 149.

The module WWW::YoutubeViewer::ParseXML is required!

To install it, just type in terminal:
sudo cpan WWW::YoutubeViewer::ParseXML

=>> Previous warnings:


Thanks, re-uploaded, should be fixed now, see above EDIT.

@icosahedron

Also made another mistake: youtube-dl update didn't work, should be fixed now also.
http://murga-linux.com/puppy/viewtopic.php?p=1008585#1008585
Quote:
But... it’s still not playing most of the videos. Does this version need the dl updating from the outset?


Strange... although youtube-dl update didn't work, the version included was rather new and for me all video's play.
I always test with "Vevo" video's (they can be problematic).
Can you give example of video that doesn't play, so I can try to reproduce ?

For to update youtube-dl you need to open terminal in the extracted directory and:
Code:
./youtube-dl.cde -U

(see pic)

Fred
run_from_terminal_inside_folder.jpg
 Description   Terminal Here
 Filesize   62.75 KB
 Viewed   420 Time(s)

run_from_terminal_inside_folder.jpg


_________________
Dog Linux website
Tinylinux blog by wiak
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 3648
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Wed 31 Oct 2018, 08:19    Post subject:  

Bonjour,
Works fine running Puppy Precise.
Thanks a lot!
Though...
fredx181 wrote:
For to update youtube-dl you need to open terminal in the extracted directory and:
Code:
./youtube-dl.cde -U

Code:
# ./youtube-dl.cde -U
WARNING: Assuming --restrict-filenames since file system encoding cannot encode all characters. Set the LC_ALL environment variable to fix this.
ERROR: can't find the current version. Please try again later.
root@puppypc20694 /usr/local/gtk-youtube-viewer

Question: is there a way to get gtk youtube viewer in an other language than English?
Code:
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
   LANGUAGE = (unset),
   LC_ALL = (unset),
   LANG = "fr_FR.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").

roadkill13 wrote:
In UpupBB18.05 I am getting this:
Quote:
Can't locate WWW/YoutubeViewer/ParseXML.pm in @INC (you may need to install the WWW::YoutubeViewer::ParseXML module) (@INC contains: /etc/perl /usr/local/lib/i386-linux-gnu/perl/5.20.2 /usr/local/share/perl/5.20.2 /usr/lib/i386-linux-gnu/perl5/5.20 /usr/share/perl5 /usr/lib/i386-linux-gnu/perl/5.20 /usr/share/perl/5.20 /usr/local/lib/site_perl .) at /usr/share/perl5/WWW/YoutubeViewer/GetCaption.pm line 149.

The module WWW::YoutubeViewer::ParseXML is required!

To install it, just type in terminal:
sudo cpan WWW::YoutubeViewer::ParseXML

=>> Previous warnings:

ditto with some videos...

Cordialement.
181031_160454_731x584_easyshot.jpg
 Description   
 Filesize   59.24 KB
 Viewed   392 Time(s)

181031_160454_731x584_easyshot.jpg


_________________

Back to top
View user's profile Send private message Visit poster's website 
fredx181


Joined: 11 Dec 2013
Posts: 4030
Location: holland

PostPosted: Wed 31 Oct 2018, 13:55    Post subject:  

@Argolance Thanks for testing thoroughly !

Added the missing perl modules, re-uploaded, hopefully it's okay now.
Included youtube-dl is latest version and updating (in the future) should work now.
EDIT: Link removed, see here:
http://murga-linux.com/puppy/viewtopic.php?p=1008723#1008723

EDIT:
Quote:
Question: is there a way to get gtk youtube viewer in an other language than English?


Not sure if possible, anyway I have no idea how.

Fred

_________________
Dog Linux website
Tinylinux blog by wiak

Last edited by fredx181 on Thu 01 Nov 2018, 07:32; edited 1 time in total
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 3648
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Wed 31 Oct 2018, 15:57    Post subject:  

Thank you! Smile
This is what I get know:
Code:
Something went wrong...
Can't locate loadable object for module HTML::Parser in @INC (@INC contains: /etc/perl /usr/local/lib/i386-linux-gnu/perl/5.20.2 /usr/local/share/perl/5.20.2 /usr/lib/i386-linux-gnu/perl5/5.20 /usr/share/perl5 /usr/lib/i386-linux-gnu/perl/5.20 /usr/share/perl/5.20 /usr/local/lib/site_perl .) at /usr/lib/i386-linux-gnu/perl5/5.20/HTML/Entities.pm line 152.
Compilation failed in require at /usr/lib/i386-linux-gnu/perl5/5.20/HTML/Entities.pm line 152.
Compilation failed in require at /usr/share/perl5/WWW/YoutubeViewer/GetCaption.pm line 163.

The module loadable object for module HTML::Parser in @INC (@INC contains: ::etc::perl ::usr::local::lib::i386-linux-gnu::perl::5.20.2 ::usr::local::share::perl::5.20.2 ::usr::lib::i386-linux-gnu::perl5::5.20 ::usr::share::perl5 ::usr::lib::i386-linux-gnu::perl::5.20 ::usr::share::perl::5.20 ::usr::local::lib::site_perl .) at ::usr::lib::i386-linux-gnu::perl5::5.20::HTML::Entities is required!

To install it, just type in terminal:
   sudo cpan loadable object for module HTML::Parser in @INC (@INC contains: ::etc::perl ::usr::local::lib::i386-linux-gnu::perl::5.20.2 ::usr::local::share::perl::5.20.2 ::usr::lib::i386-linux-gnu::perl5::5.20 ::usr::share::perl5 ::usr::lib::i386-linux-gnu::perl::5.20 ::usr::share::perl::5.20 ::usr::local::lib::site_perl .) at ::usr::lib::i386-linux-gnu::perl5::5.20::HTML::Entities

Could you please add the date to the title of the gz file to make the difference between downloaded files?

Cordialement.

_________________

Back to top
View user's profile Send private message Visit poster's website 
fredx181


Joined: 11 Dec 2013
Posts: 4030
Location: holland

PostPosted: Wed 31 Oct 2018, 16:23    Post subject:  

Hi Argolance,

Mmm.. more missing...
To be able to reproduce, a question:
What you did exactly ?
e.g. you get the error message at start of gtk-youtube-viewer or only when playing a specific video.

Fred

_________________
Dog Linux website
Tinylinux blog by wiak
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 3648
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Wed 31 Oct 2018, 16:51    Post subject:  

Quote:
What you did exactly ?
e.g. you get the error message at start of gtk-youtube-viewer or only when playing a specific video.

This happens while trying to watch some videos, not all. For example, the first one listed in the "Film & Animation" category, called "Monsters You didn't Know..."
181031_214923_661x490_easyshot.jpg
 Description   The 4th works normally!
 Filesize   49.57 KB
 Viewed   349 Time(s)

181031_214923_661x490_easyshot.jpg

181031_214534_703x458_easyshot.jpg
 Description   The first doesn't...
 Filesize   55.47 KB
 Viewed   353 Time(s)

181031_214534_703x458_easyshot.jpg


_________________

Back to top
View user's profile Send private message Visit poster's website 
fredx181


Joined: 11 Dec 2013
Posts: 4030
Location: holland

PostPosted: Thu 01 Nov 2018, 04:10    Post subject:  

Argolance wrote:

This happens while trying to watch some videos, not all. For example, the first one listed in the "Film & Animation" category, called "Monsters You didn't Know..."


Merci beaucoup ! Now I could trace the problem better and fix it (date appended to download link now Wink ).
EDIT: Link removed, see here:
http://murga-linux.com/puppy/viewtopic.php?p=1008723#1008723

Post edited here (EDIT 2018-11-01):
http://murga-linux.com/puppy/viewtopic.php?p=1008585#1008585

Fred

Last edited by fredx181 on Thu 01 Nov 2018, 07:32; edited 1 time in total
Back to top
View user's profile Send private message 
icosahedron


Joined: 28 Nov 2011
Posts: 93
Location: UK

PostPosted: Thu 01 Nov 2018, 04:38    Post subject:  

Hi Fred, thanks again. I’ve now replaced 3.5.0 with the latest 3.5.0 2018-11-01 and still can’t play many vids.

I’ve run through the -U in the right place (I think - at least it seemed to do something this time)

I got:
Warning: Assuming --restrict-filenames since filesystem encoding cannot encode all characters. Set the LC_ALL environment variable to fix this.
ERROR: Can’t find the current version. Please try again later.

I tried again later and got the same message. No surprise there. Rolling Eyes

FYI, I’m trying to play tracks by the band ‘Forever Still’.
There are only two on the first page of ten that will play - ‘The Last Day’, and ‘Fight’ (neither of which are ‘single’ material, btw). The other eight don’t play. This is typical of ratios I’m finding on other pages. And yeah, anything that says VEVO on it doesn’t play either.

As another example, none of the first ten offerings from the band ‘Beyond the Black’ will play for me, VEVO or not.

Maybe I should change my musical tastes, or just play funny cat videos instead? Smile

_________________
Computers: - I just ride 'em, I dunno what makes 'em work.
Console/Terminal? What's that?
I visit the Internet to OBTAIN information, not to PROVIDE it!
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 4030
Location: holland

PostPosted: Thu 01 Nov 2018, 05:23    Post subject:  

Hi icosahedron,

Quote:
I’ve now replaced 3.5.0 with the latest 3.5.0 2018-11-01 and still can’t play many vids.


I cannot reproduce, sorry, tested on some old pups (Lupu, Wary, Tahr) and all video's from "Forever Still" play for me.
Any message you get when a video doesn't play ?

Quote:
I’ve run through the -U in the right place (I think - at least it seemed to do something this time)

I got:
Warning: Assuming --restrict-filenames since filesystem encoding cannot encode all characters. Set the LC_ALL environment variable to fix this.
ERROR: Can’t find the current version. Please try again later.


The first is just a warning, I think it can be ignored.
The error I also can't reproduce, I get:
Code:
youtube-dl is up-to-date (2018.10.29)

But the problem you have isn't caused by a too old version of youtube-dl (latest included)

EDIT: @all Can anyone else try to play video's from "Forever Still" ?

Fred

_________________
Dog Linux website
Tinylinux blog by wiak
Back to top
View user's profile Send private message 
Smithy


Joined: 12 Dec 2011
Posts: 1042

PostPosted: Thu 01 Nov 2018, 05:56    Post subject:  

Forever Still Vids Playing ok for me, BUT all stopped working a few days ago.
Had to do the curl code in the artful pet, the one that puts the new youtube dl py file in usr/local/bin. The other code youtube-dl says bash command not found or something.
I've made a clickable .sh update file for it, but would be cool if it was in the main script Fred. Not a biggie, just glad to be able to watch an occasional youtube vid, since every bugger seems tied to it now. Are google custodians of everyone's life now.
Back to top
View user's profile Send private message 
icosahedron


Joined: 28 Nov 2011
Posts: 93
Location: UK

PostPosted: Thu 01 Nov 2018, 06:07    Post subject:  

Yeah, my problems started a few days ago.

Firefox 37 was playing everything just fine until this weekend, I gather Youtube has switched to something called HTML5, and Firefox 37 won't read the new formats.

Any Firefox newer than 37 crashes in my Lupu 525, so I was looking for alternatives, and stumbled across this thread.

Unfortunately, although the gtk viewer seems to work for you guys, It's not providing me with significantly better access than FF37.

There's no error message, just nothing happens. Maybe the inability to play videos, that you can't reproduce, is linked to the error message that you can't reproduce?

Does it matter where the viewer is installed? I dropped mine in usr-lib, where FF37 is.

_________________
Computers: - I just ride 'em, I dunno what makes 'em work.
Console/Terminal? What's that?
I visit the Internet to OBTAIN information, not to PROVIDE it!
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 3648
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Thu 01 Nov 2018, 06:18    Post subject:  

Bonjour,
Quote:
The error I also can't reproduce, I get:

I got the same and couldn't update youtube-dlI until I found the reason for this error. Running the script youtube-dl.cde in console shows that youtube-dl is searched in the /cde-root/sbin directory:
Code:
root@puppypc28983 /usr/local/gtk-youtube-viewer
# HERE="$(dirname "$(readlink -f "${0}")")"
root@puppypc28983 /usr/local/gtk-youtube-viewer
# cd "$HERE/cde-root" && ../cde-exec 'youtube-dl -U
> '
../cde-exec: youtube-dl -U
: command not found (path_to_search=/usr/local/gtk-youtube-viewer/cde-root/sbin/youtube-dl -U
)
root@puppypc28983 /usr/local/gtk-youtube-viewer/cde-root

... while it is in /cde-root/usr/local/bin
Code:
root@puppypc28983 /usr/local/gtk-youtube-viewer/cde-root/usr/local/bin
# ./youtube-dl -U
youtube-dl is up-to-date (2018.10.29)
root@puppypc28983 /usr/local/gtk-youtube-viewer/cde-root/usr/local/bin

Run from /cde-root/usr/local/bin, youtube-dl is correctly updated.

The videos I couldn't play work now.
Thanks.

But, concerning "Forever Still":
Code:
2018.10.29
ERROR: Unable to download webpage: <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:581)> (caused by URLError(SSLError(1, u'[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:581)'),))

[EDIT]:
@Smithy
Our messages crossed paths...

Cordialement.

_________________

Back to top
View user's profile Send private message Visit poster's website 
fredx181


Joined: 11 Dec 2013
Posts: 4030
Location: holland

PostPosted: Thu 01 Nov 2018, 07:06    Post subject:  

Hi All, thanks for the replies Very Happy

Good news and bad news.
The good news is that I found the problem, the bad news is that Xarchiver cannot be trusted.
Ughh... should have known earlier. Evil or Very Mad
It was a mystery that I couldn't reproduce some problems until I downloaded and extracted the tar.gz.
Then I could reproduce the problem that the videos from "Forever Still didn't play and also the youtube-dl update didn't work.
All because of some broken symlinks.
Lesson for me: Never use Xarchiver again !
Now I used command line:
Code:
tar cvzf yt-viewer-3.5.0_youtube-dl-2018-11-01-fixed-symlinks.tar.gz yt-viewer-3.5.0_youtube-dl

And no broken symlinks. (and all working fine for me)
I'm not sure why Xarchiver works the way it does, I noticed that it doesn't include empty folders.

https://dl.dropboxusercontent.com/s/sxo20ipo88m0gp7/yt-viewer-3.5.0_youtube-dl-2018-11-01-fixed-symlinks.tar.gz?dl=1

@Smithy I will try to fix the pet packages in the next days, some perl stuff missing (see earlier posts, HTML etc...)

Fred

_________________
Dog Linux website
Tinylinux blog by wiak
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 3648
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Thu 01 Nov 2018, 07:32    Post subject:  

Thank you.
Everything is perfect now, except I don't have the sound anymore! Confused

Something else: just for test and not essential: I tried unsuccessfully to make links in /cde-root/usr/bin to /usr/bin/vlc, mplayer etc. already installed on my Puppy and even replacing the /cde-root/usr/bin/mpv with a link to /usr/bin/mpv but all complain about their missing libs...
Too bad!
Isn't there some way around that?

Question: wouldn't it be interesting to integrate the update command directly into the script gtk-youtube-viewer.cde, quietly or with a small yad window that warns of a new update available?

_________________

Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 25 of 28 [411 Posts]   Goto page: Previous 1, 2, 3, ..., 23, 24, 25, 26, 27, 28 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1631s ][ Queries: 13 (0.0982s) ][ GZIP on ]