Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 20 Sep 2019, 14:05
All times are UTC - 4
 Forum index » Advanced Topics » Cutting edge
TazPuppy Beta 33
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 51 of 63 [937 Posts]   Goto page: Previous 1, 2, 3, ..., 49, 50, 51, 52, 53, ..., 61, 62, 63 Next
Author Message
Terry H

Joined: 29 Mar 2009
Posts: 652
Location: The Heart of Muskoka, ON Canada

PostPosted: Sat 12 Jan 2019, 19:51    Post subject:  

Result of running from terminal:

Code:

sh-4.4$ cd /mnt/home
sh-4.4$ pwd
/mnt/home
sh-4.4$ tazpet inxi-2.3.8-noarch_all.pet
tar: invalid magic
tar: short read
sh-4.4$ tazpet /mnt/home/inxi-2.3.8-noarch_all.pet
tar: invalid magic
tar: short read
sh-4.4$
Back to top
View user's profile Send private message 
Terry H

Joined: 29 Mar 2009
Posts: 652
Location: The Heart of Muskoka, ON Canada

PostPosted: Sat 12 Jan 2019, 20:27    Post subject:  

I converted the pet to a tazpkg, which appeared to install correctly, however when I attempted run from terminal I got not found. TazPanel has it as Installed package, however it says 0 installed files. Doing a search finds the /var/lib entries and the script that is installed in another puppy, but not in this tazpuppy. Not sure what is happening here.



Edit: I uninstalled the converted tazpkg and installed slitaz inxi package which also installed some dependencies. So it appears that installing the converted pet/tazpkg did not do any dependcy checking.

screenshot below is after attempting to install converted package:
Screenshot-TazPanel.png
 Description   
 Filesize   83.01 KB
 Viewed   665 Time(s)

Screenshot-TazPanel.png

Back to top
View user's profile Send private message 
mistfire

Joined: 04 Nov 2008
Posts: 1198
Location: PH

PostPosted: Mon 14 Jan 2019, 00:03    Post subject:  

don570 wrote:
I tested version 15 -- frugal install went well - booted fast

Observations : Opening log-in window doesn't support tab key.
Instead I had to press ENTER to move to next field.

_________________________________

Request ptmtimer 2.5 be included.
http://murga-linux.com/puppy/viewtopic.php?t=112410
_______________________________


@don570 thats the problem of slim login manager. It cant support tab

@Terry H can you please gave me the download link of that pet package?
Back to top
View user's profile Send private message 
Terry H

Joined: 29 Mar 2009
Posts: 652
Location: The Heart of Muskoka, ON Canada

PostPosted: Mon 14 Jan 2019, 00:29    Post subject:  

@misfire, sorry I don't remember where I got it from. I could upload it if you want to check it.
Back to top
View user's profile Send private message 
mistfire

Joined: 04 Nov 2008
Posts: 1198
Location: PH

PostPosted: Mon 14 Jan 2019, 02:13    Post subject:  

@Terry H I finally found the problem. TazPet installer extracts only gzip compressed pet packages. I revise the script and it now extracts xz or bzip compressed pet packages. Also an error message shown in tazpet-box if there is any error on extracting pet packages
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 5346
Location: Ontario

PostPosted: Tue 15 Jan 2019, 14:20    Post subject:  

uextract does a good job of extracting packages
http://murga-linux.com/puppy/viewtopic.php?t=87864
___________________________________________
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 5346
Location: Ontario

PostPosted: Tue 15 Jan 2019, 14:26    Post subject:  

I found that ptmtimer will work if mpg321 or mpg123 is installed
I compiled mpg321 using devx file in first post.
mpg321-tazpup.tar.gz
Description  Used by ptmtimer
gz

 Download 
Filename  mpg321-tazpup.tar.gz 
Filesize  33.06 KB 
Downloaded  57 Time(s) 

Last edited by don570 on Tue 15 Jan 2019, 14:54; edited 1 time in total
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 5346
Location: Ontario

PostPosted: Tue 15 Jan 2019, 14:43    Post subject:  

I installed devx and tried to compile mpg123 from sourceforge
https://sourceforge.net/projects/mpg123/files/latest/download

However I got this error
Code:
/bin/grep: /usr/lib/libstdc++.la: No such file or directory
sed: /usr/lib/libstdc++.la: No such file or directory
libtool:   error: '/usr/lib/libstdc++.la' is not a valid libtool archive
make: *** [src/libout123/modules/output_esd.la] Error 1



The compile of mpg321 went smoothly with only
./configuration --prefix=/usr

_____________________________________________________

Also I have a suggestion...

There needs to be a right click menu for SFS files.
'Load_SFS' is used by some puppy distros.
It is useful for the devx sfs.
_______________________________________
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 5346
Location: Ontario

PostPosted: Tue 15 Jan 2019, 14:50    Post subject:  

Also I noticed a strange problem with gtkdialog...

The launching from a button didn't work.
Try this example in tazpup. I couldn't get it to launch DIALOG.
Code:
#!/bin/sh

#
# Some action function types are still missing.
# See execute_action() for more information.
#

GTKDIALOG=gtkdialog

DIALOG='
<window>
   <vbox>
      <text>
         <label>This is another dialog window.</label>
      </text>
      <button>
         <label>Close</label>
         <action function="closewindow">DIALOG</action>
      </button>
   </vbox>
   <variable>DIALOG</variable>
</window>
'
export DIALOG

MAIN_DIALOG='
<window>
   <vbox>
      <frame Widgets>
         <checkbox>
            <label>This is a checkbox</label>
            <variable>CHECKBOX</variable>
         </checkbox>
         <entry>
            <input>date</input>
            <variable>ENTRY</variable>
         </entry>
      </frame>
      <frame Button actions>
         <hbox>
            <button>
               <label>exit</label>
               <action>echo You pressed the exit button</action>
               <action function="exit">Exit by button</action>
            </button>
         </hbox>
         <hbox>
            <button>
               <label>launch</label>
               <action function="launch">DIALOG</action>
            </button>
            <button>
               <label>closewindow</label>
               <action function="closewindow">DIALOG</action>
            </button>
         </hbox>
         <hbox>
            <button>
               <label>enable</label>
               <action function="enable">ENTRY</action>
               <action function="enable">CHECKBOX</action>
            </button>
            <button>
               <label>disable</label>
               <action function="disable">ENTRY</action>
               <action function="disable">CHECKBOX</action>
            </button>
         </hbox>
         <hbox>
            <button>
               <label>refresh</label>
               <action function="refresh">ENTRY</action>
            </button>
            <button>
               <label>clear</label>
               <action function="clear">ENTRY</action>
            </button>
            <button>
               <label>fileselect</label>
               <action function="fileselect">ENTRY</action>
            </button>
         </hbox>
      </frame>
      <hbox>
         <button ok></button>
         <button cancel></button>
      </hbox>
   </vbox>
</window>
'
export MAIN_DIALOG

case $1 in
   -d | --dump) echo "$DIALOG" "$MAIN_DIALOG" ;;
   *) $GTKDIALOG --program=MAIN_DIALOG ;;
esac

________________________________________________
Back to top
View user's profile Send private message 
mistfire

Joined: 04 Nov 2008
Posts: 1198
Location: PH

PostPosted: Tue 15 Jan 2019, 21:22    Post subject:  

@don570
Try to change #!/bin/sh to #!/bin/bash on your script

If you want to sfs modules just double click the sfs files and click Load modules

load_sfs of tazpuppy can also load slax and porteus modules
Back to top
View user's profile Send private message 
Rodney Byne

Joined: 31 Jan 2014
Posts: 220

PostPosted: Thu 17 Jan 2019, 01:27    Post subject: Testing version 16  

My first-time user comments.

While testing version 16 installed to a USB Sandisk Cruzer Edge,
I noted that booting after the savefile process;
"Keyboard Layout Handler Settings"
country flags have disappeared, leaving in my case GB text only.

Midori is hopeless, TazWeb browser isn't much better and has
best described as, unrefined sticky page issues with bookmarks.

So from the on-demand features, I downloaded Firefox 17.0.11 esr
and VLC which run ok.
Just a pity being an elderly Firefox, due to lack of feature-support, U-Tube can't run.

I run world radio-station playlists and VLC makes a good job
of handling those lists to a stereo hi-fi system.
IceCast stations works ok too.

Otherwise overall, a nice tidy small distro - well done,
but needs consistent work to keep it modern and up to date.
Best regards.
Back to top
View user's profile Send private message 
mistfire

Joined: 04 Nov 2008
Posts: 1198
Location: PH

PostPosted: Thu 17 Jan 2019, 05:47    Post subject:  

TazPuppy beta 17 released

Changes:
* A CRITICAL BUG in tazpet installer where xz compressed pet packages failed to extract IS FIXED.
* Some tweaks

Download: https://drive.google.com/file/d/1yvtxIF2y20q2YaFiqTeXNY1iJJbQM3gW/view?usp=sharing
MD5 Checksum: fcc5113a775110b63c09a6a4231b688c

Build kit: https://drive.google.com/file/d/11oQLbokl1-aG7Gawql5PidKgk1Se0gaj/view?usp=sharing
Back to top
View user's profile Send private message 
mistfire

Joined: 04 Nov 2008
Posts: 1198
Location: PH

PostPosted: Mon 21 Jan 2019, 22:13    Post subject:  

TazPuppy Beta 18 released

Changes:
* Dynamic Machine ID and Dynamic MAC address (Both enable by default but it can toggle ON and OFF (under Network Privacy Settings. Reboot required to apply the settings)

Download: https://drive.google.com/file/d/1kBw600TaWjm5wuT992flCtD_MJRi_rnJ/view?usp=sharing
MD5 Checksum: c9a120c4f8f353d5f89f340f4f21c691

Build kit: https://drive.google.com/file/d/1dchNmFuVxE8xjE7lLuFSgpT_RGDeFTNH/view?usp=sharing
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 5346
Location: Ontario

PostPosted: Tue 22 Jan 2019, 21:32    Post subject:  

to Mistfire

Would you check this script...

https://fossies.org/linux/gtkdialog/examples/button/button_action_functions to see if DIALOG will appear.


The previous script I listed didn't copy correctly in the windows clipboard I guess. Crying or Very sad
Back to top
View user's profile Send private message 
mistfire

Joined: 04 Nov 2008
Posts: 1198
Location: PH

PostPosted: Wed 23 Jan 2019, 02:58    Post subject:  

@don570

replace this line
Code:
*) $GTKDIALOG --program=MAIN_DIALOG ;;


with this one

Code:
*) $GTKDIALOG --center --program=MAIN_DIALOG ;;
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 51 of 63 [937 Posts]   Goto page: Previous 1, 2, 3, ..., 49, 50, 51, 52, 53, ..., 61, 62, 63 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Cutting edge
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1229s ][ Queries: 13 (0.0423s) ][ GZIP on ]