Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 22 Mar 2019, 04:47
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
First-Run's Outgrown its Home - Solved
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [10 Posts]  
Author Message
mikeslr


Joined: 16 Jun 2008
Posts: 3036
Location: 500 seconds from Sol

PostPosted: Sat 12 Jan 2019, 11:23    Post subject:  First-Run's Outgrown its Home - Solved  

Hi All,

Sometime during one of a series of remasters the Quicksetup first-run setting appears to have eaten one of Alice's magic mushrooms. See attached.

This went unnoticed thru several subsequent remasters, involving many hours of changes, and I'm not sure I kept the OS version before the change. Starting from scratch is not an option. I have other ways of accessing those parts of first-run which no longer appear. But it is annoying that first-run no longer functions properly.

In an effort to bring first-run back to size, I've (a) built a pet using all components from a pristine ISO and installed it; and (b) replaced the entire /etc/X11 folder and its contents. Neither solution helped.

I have a suspicion that first-run is reading font sizes wrong. That is (for example and not meant to be exact) where the application says to use a font size 8 it is using a font size 12. If that suspicion is right, I don't know how to correct it.

Any ideas?
Gigantic First-Run Dialog.png
 Description   Oversized First-Run Dialog
 Filesize   138.63 KB
 Viewed   271 Time(s)

Gigantic First-Run Dialog.png


Last edited by mikeslr on Tue 15 Jan 2019, 19:06; edited 1 time in total
Back to top
View user's profile Send private message 
musher0

Joined: 04 Jan 2009
Posts: 13740
Location: Gatineau (Qc), Canada

PostPosted: Sat 12 Jan 2019, 14:23    Post subject:  

Hello mikeslr

Perhaps refresh it by typing, in console:
Code:
cd /initrd/pup_ro2/usr/sbin
cp -f quicksetup /usr/sbin
The one I have on this slacko-06.9.9.9 weighs 84K.
The weight should be pretty much the same across Pups.

IHTH.

_________________
musher0
~~~~~~~~~~
Je suis né pour aimer et non pas pour haïr. (Sophocle) /
I was born to love and not to hate. (Sophocles)
Back to top
View user's profile Send private message 
mikeslr


Joined: 16 Jun 2008
Posts: 3036
Location: 500 seconds from Sol

PostPosted: Sat 12 Jan 2019, 20:15    Post subject:  

Thanks, musher0, for responding. Been out all day. [But they caught me and brought me back in. Laughing Oh, yah. It's the real World which is crazy. Crying or Very sad ]

Joking aside, while driving I had an idea as to what was wrong. On returning, its seems to have born-out. Whether I'll be able to implement it without "starting from scratch" will take a little while.

I'll post about it probably tomorrow. In the meantime, if you all were racking your brains for a solution, give them a rest.
Back to top
View user's profile Send private message 
mikeslr


Joined: 16 Jun 2008
Posts: 3036
Location: 500 seconds from Sol

PostPosted: Tue 15 Jan 2019, 13:21    Post subject: "Internal Info" displayed and repeated  

Hi musher0 & All,

Neither your suggestion nor anything I've tried cured the problem. What I did realize, after comparing the malfunctioning shown in the above screenshot with the display providing by a properly functioning quicksetup is that what appears to be information which is supposed to be processed internally --not displayed-- is displayed, over and over again.

You can easily see the difference by opening Menu>Setup>QuickSetup on probably any recent Puppy. All the text shown on the right side of the screenshot is missing.

Replacing Quicksetup, either as you suggested by copying it quicksetup from /initrd/pup_ro2/usr/sbin or from another Puppy does not resolve that problem as the display remains the same gargantuan one extending beyond the desktop.

I wonder if something I installed changed 'bash' or 'yad' or whatever translates the code in quicksetup into a screen display.

Menu>Setup>Screen/Graphics wizard, itself, displays properly. And there are other functioning applications to access the modules which are presented by quicksetup's Screen/Graphics components. The easiest work-around might be to remove --with ###-- that part of the code in quicksetup which generates that part of the display. But, figuring out which lines --and how to do only that safely-- is beyond my knowledge of the code quicksetup uses.
Back to top
View user's profile Send private message 
williams2

Joined: 14 Dec 2018
Posts: 50

PostPosted: Tue 15 Jan 2019, 14:48    Post subject:  

What do you get if you type
Code:
report-video driver


If report-video isn't working you could try copying the original file.

gettext may be the problem.

You could edit /usr/sbin/quicksetup and put in some debug code after line 944. Something like
Code:
echo $XMSGX > /tmp/xmsgx.debug

then run quicksetup and check what is in /tmp/xmsgx.debug

If gettext is getting another language it may be corrupting one of those variables, maybe its choking on an accented letter. You could try running
Code:
LANG=C quicksetup
Back to top
View user's profile Send private message 
mikeslr


Joined: 16 Jun 2008
Posts: 3036
Location: 500 seconds from Sol

PostPosted: Tue 15 Jan 2019, 19:13    Post subject: The Culpret was Right-Click-6.9.9.pet  

Hi William2,

Your first two suggestions didn't reveal anything unusual. But your mention of gettext made me wonder about what pet did I install that might have caused changed how it functioned. Reviewing PPM>Uninstall revealed that I had installed Right-Click-6.9.9.pet. It's removal returned Quicksetup to normal.

Thanks for the help.
Back to top
View user's profile Send private message 
williams2

Joined: 14 Dec 2018
Posts: 50

PostPosted: Tue 15 Jan 2019, 20:30    Post subject:  

gettext can cause problems in scripts. It shouldn't be a problem with en_US

Maybe your bash options were changed from the defaults. That can cause scripts to break.
Code:
echo $BASHOPTS


Anyway, glad I could help.
Back to top
View user's profile Send private message 
musher0

Joined: 04 Jan 2009
Posts: 13740
Location: Gatineau (Qc), Canada

PostPosted: Wed 16 Jan 2019, 20:41    Post subject:  

Hello mikeslr and all.

Speaking of quicksetup, what is the name of the flag file it creates so it does not pop up again at every boot? If not through a flag file, then how?

I read the quicksetup script and could not find any hint about that.

Thank you in advance.

_________________
musher0
~~~~~~~~~~
Je suis né pour aimer et non pas pour haïr. (Sophocle) /
I was born to love and not to hate. (Sophocles)
Back to top
View user's profile Send private message 
ITSMERSH

Joined: 02 May 2018
Posts: 911

PostPosted: Thu 17 Jan 2019, 07:45    Post subject:  

Hi musher0.

It is: /etc/personal_settings_popup_disabled

For the Welcome1stBoot edit /usr/sbin/delayedrun (search: welcome1stboot)

_________________
RSH

Beware of the Dog ähem nic007! Wink
Back to top
View user's profile Send private message 
musher0

Joined: 04 Jan 2009
Posts: 13740
Location: Gatineau (Qc), Canada

PostPosted: Fri 18 Jan 2019, 21:59    Post subject:  

Many thanks, RSH. You are of great help.
There are also a few "flags" in var/local.

BFN.

_________________
musher0
~~~~~~~~~~
Je suis né pour aimer et non pas pour haïr. (Sophocle) /
I was born to love and not to hate. (Sophocles)
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [10 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0637s ][ Queries: 13 (0.0086s) ][ GZIP on ]