Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 19 Sep 2019, 10:58
All times are UTC - 4
 Forum index » Advanced Topics » Cutting edge
TazPuppy Beta 33
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 52 of 63 [935 Posts]   Goto page: Previous 1, 2, 3, ..., 50, 51, 52, 53, 54, ..., 61, 62, 63 Next
Author Message
don570


Joined: 10 Mar 2010
Posts: 5345
Location: Ontario

PostPosted: Thu 24 Jan 2019, 15:55    Post subject:  

I discovered what is wrong....

You need to get the more recent version of gtkdialog

Code:
root@TazPuppy:~# gtkdialog -v

(process:16323): Gtk-WARNING **: Locale not supported by C library.
        Using the fallback 'C' locale.
gtkdialog version 0.8.2 release (C) 2003-2007 Laszlo Pere, 2011-2012 Thunor
Built with additional support for: Glade, VTE.



I dragged over the version from the recent dpup stretch 7.5 32 bit
version and that upgraded tazpup to gtkdialog version 8.4.
http://www.murga-linux.com/puppy/viewtopic.php?t=112125

Then I checked the launch button and it works now.
By the way DIALOG is the function that the button launches.
Thunor wrote the script.
____________________________________________________

I assume radky got gtkdialog from HERE


Now ptmtimer log feature works.
Code:

root@TazPuppy:~# gtkdialog -v

(process:16722): Gtk-WARNING **: Locale not supported by C library.
        Using the fallback 'C' locale.
gtkdialog version 0.8.4 release (C) 2003-2007 Laszlo Pere, 2011-2012 Thunor
Built with support for: GTK+ 2, Glade, VTE.


___________________________________________
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 5345
Location: Ontario

PostPosted: Thu 24 Jan 2019, 16:02    Post subject:  

Would you check if either mpg123 or mpg321 will compile???

I installed newest beta 18
I couldn't run 'configure' but 'make' command does work.

_________________________________________
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 5345
Location: Ontario

PostPosted: Thu 24 Jan 2019, 16:17    Post subject:  

Also various default apps that BarryK supports need to be setup.

Code:
defaultaudioplayer
-sh: defaultaudioplayer: command not found
root@TazPuppy:~# defaulttexteditor
/usr/local/bin/defaulttexteditor: line 2: exec: beaver: not found
Back to top
View user's profile Send private message 
mistfire

Joined: 04 Nov 2008
Posts: 1191
Location: PH

PostPosted: Sat 26 Jan 2019, 03:28    Post subject:  

@don570 yes it is, but you must load 32-bit devx sfs module from any puppy.
Back to top
View user's profile Send private message 
mistfire

Joined: 04 Nov 2008
Posts: 1191
Location: PH

PostPosted: Sun 27 Jan 2019, 22:07    Post subject:  

TazPuppy beta 19 released

Changes:
* Added support for older pet packages. (Pre-woof era packages dated 2009 below)
* gtkdialog 0.8.4 is now used.
* defaulttextviewer and defaulttexteditor is fixed

Download: https://drive.google.com/file/d/1WRe-YzRzqrWyzmqQNdflRcQwLgPjJxIj/view?usp=sharing
MD5 Checksum: ded2abcd7f5005ce6924d7c86beb9704

Build kit: https://drive.google.com/file/d/1sgE-_uRklxDZqpZIH59a7wjZ_aTa5u5q/view?usp=sharing
Back to top
View user's profile Send private message 
Volhout

Joined: 28 Dec 2008
Posts: 547

PostPosted: Tue 29 Jan 2019, 14:44    Post subject: Quick test Tazpuppy R19  

Hi Mistfire,

First of all : congratulations to you (and Wiak) for this new puppy.
It is a puppy in all it's glory: small at 100Mbyte, a lot of functionality that works. This is amazing. As to my knowledge ThinSlacko was the last puppy under 100Mbyte. There where some barebones that where smaller, but as soon as you added the browser...holalala...

In absence of my formidable EEEpc, I tested TazPuppy on a patched Chromebook (Acer C720).

The amazing things are:
- WIFI works (ath9)
- Touchpad works (that is super).

Most of the apps in the menu work, but the menu is not very structured (i.e. the spreadsheet is not under Office, but under Utilities).

I have one hardware issue though: I do not seem to have audio. (Intel Audio).
Besides that, the backlight cannot be controlled. But that one is easy to fix, done that before.

Congratulations on this miraculous puppy.....

Regards,

Volhout
Back to top
View user's profile Send private message 
Terry H

Joined: 29 Mar 2009
Posts: 652
Location: The Heart of Muskoka, ON Canada

PostPosted: Tue 29 Jan 2019, 23:10    Post subject:  

My Dell laptop is dead at the moment, so I've had to resurrect my wife's 10 year old retired laptop to use temporarily. I had increased the RAM to 4GB when my wife used to use it, so with puppy it is quite snappy. I found a bootable USB flash drive that had Legacy Grub installed, so decided to install tazpuppy beta 19 on it. This is a new manual frugal install, to 8GB Kingston DataTraveller USB Flash drive. I've manually installed palemoon in /opt. Running very smoothly on this old laptop.

So, thanks mistfire, this is once again excellent work.

Code:

sh-4.4$ inxi -Fxz
System:    Host: TazPuppy Kernel: 4.9.124-slim32 i686 (32 bit gcc: 5.3.0)
           Desktop: N/A Distro: 5.0
Machine:   System: Acer (portable) product: Extensa 4630Z v: V1.23
           Mobo: Acer model: Extensa 4630Z v: V1.23
           Bios: Acer v: V1.23 date: 03/11/2009
Battery    BAT0: charge: 0.7 Wh 2.0% condition: 34.5/44.0 Wh (79%)
           
           model: Simplo GARDA71 status: N/A
CPU:       Dual core Pentium T4200 (-MCP-) cache: 1024 KB
           flags: (lm nx pae sse sse2 sse3 ssse3) bmips: 7980
           clock speeds: max: 2000 MHz 1: 2000 MHz
           2: 1600 MHz
Graphics:  Card: Intel Mobile 4 Series Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: X.org 1.12.4 drivers: (unloaded: fbdev,vesa)
           Resolution: 80x24
Audio:     Card Intel 82801I (ICH9 Family) HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: ALSA v: k4.9.124-slim32
Network:   Card-1: Intel Ultimate N WiFi Link 5300
           driver: iwlwifi bus-ID: 04:00.0
           IF: wlan0 state: up
           mac: <filter>
           Card-2: Broadcom NetXtreme BCM5764M Gigabit Ethernet PCIe
           driver: tg3 v: 3.137
           bus-ID: 05:00.0
           IF: eth0 state: down
           mac: <filter>
Drives:    HDD Total Size: 168.1GB (39.1% used)
           ID-1: /dev/sda model: WDC_WD1600BEVT size: 160.0GB
           ID-2: USB /dev/sdb model: DataTraveler_3.0 size: 8.0GB
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 194 Uptime: 1:07 Memory: 275.5/3977.7MB
           Init: SysVinit runlevel: 5
           Gcc sys: N/A
           Client: Shell (sh) inxi: 2.3.0
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 5345
Location: Ontario

PostPosted: Sat 02 Feb 2019, 13:41    Post subject:  

I'll test iso.
-----------------
Back to top
View user's profile Send private message 
mistfire

Joined: 04 Nov 2008
Posts: 1191
Location: PH

PostPosted: Sat 02 Feb 2019, 19:58    Post subject:  

@don570 could you also please test gtkdialog scripts by installing gtkdialog 0.8.3 from slitaz repo. To see if there is weird rendering of dialog. As of now the default gtkdialog used in latest tazpuppy is 0.8.4 from a pet package. I wonder it was fixed at 0.8.3 I test pfind using gtkdialog 0.8.3 and it worked nicely for me.
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 5345
Location: Ontario

PostPosted: Sun 03 Feb 2019, 16:50    Post subject:  

slitaz has a very old source version of gtkdialog....
http://distro.ibiblio.org/slitaz/sources/packages/g/gtkdialog-0.7.20.tar.gz
___________________________________

They have
http://distro.ibiblio.org/slitaz/packages/next64/gtkdialog-0.8.3-x86_64.tazpkg

I'll test it for you.

From my experience there is very little difference between version 0.8.3 and 0.8.4 . In fact developers didn't even notice the difference.

_______________________________________
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 5345
Location: Ontario

PostPosted: Sun 03 Feb 2019, 17:04    Post subject:  

There's a script 'Simple Samba Management' that is popular with puppy users

http://www.murga-linux.com/puppy/viewtopic.php?p=896005#896005

I wonder if it can be used in tazpup??
_________________________________________
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 5345
Location: Ontario

PostPosted: Sun 03 Feb 2019, 17:07    Post subject:  

Tazpup recognized my devices nicely . I could set up wifi by just
filling in password.
________________________________________

I booted a frugal install pfix=ram

Here are my boot messages. You can see it recognized my wifi adaptor.

______________________________________________________
boot-messages.tar.gz
Description 
gz

 Download 
Filename  boot-messages.tar.gz 
Filesize  4.51 KB 
Downloaded  30 Time(s) 
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 5345
Location: Ontario

PostPosted: Sun 03 Feb 2019, 17:10    Post subject:  

Audio worked right away and ethernet connect was recognized automatically.

Code:
echo $EDITOR


gave leafpad

I noticed that nano is installed. 'mp' is the editor that barryK uses.
_____________________________________________________
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 5345
Location: Ontario

PostPosted: Sun 03 Feb 2019, 17:16    Post subject:  

When I tried to compile with the devx
https://archive.org/download/Puppy_Linux_Tazpup/devx_tazpup.sfs
I got terminal message...

Code:
sh-4.4# ./configure --prefix=/usr
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... no
checking for nawk... no
checking for awk... awk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking for -Werror in CFLAGS (It breaks tests)... no
checking if you are up to something totally static with LDFLAGS/CFLAGS... no
checking for style of include used by make... GNU
checking for gcc... no
checking for cc... no
checking for cl.exe... no
configure: error: in `/root/mpg123-1.25.10':
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details
sh-4.4# make
make: *** No targets specified and no makefile found.  Stop.
sh-4.4#
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 5345
Location: Ontario

PostPosted: Sun 03 Feb 2019, 17:22    Post subject:  

pfind 6.3 page states

Quote:
Requirements
gtkdialog 0.8.2
pFilesearch
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 52 of 63 [935 Posts]   Goto page: Previous 1, 2, 3, ..., 50, 51, 52, 53, 54, ..., 61, 62, 63 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Cutting edge
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1407s ][ Queries: 13 (0.0699s) ][ GZIP on ]