Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 16 Sep 2019, 06:06
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Fatdog64-800 Alpha / Beta [20 Dec 2018] [CLOSED]
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 21 of 23 [335 Posts]   Goto page: Previous 1, 2, 3, ..., 19, 20, 21, 22, 23 Next
Author Message
jake29

Joined: 24 Jul 2015
Posts: 217

PostPosted: Fri 01 Feb 2019, 02:18    Post subject:  

jamesbond wrote:
@jake29: which version of wine?

autochown ... Do you have a lot of stuff under "Downloads" folder? If you do, it could explain it.


wine-2.0.1-721.sfs is the version I need to run a specific app. I see Wine 4.0 installs and successfully.

The 91-autochownd issue is in a clean install - 'Downloads' folder is almost empty.

EDIT: I just realized that I should probably try compiling wine 2.0.1 for Fatdog64-800 <blush>
Back to top
View user's profile Send private message 
jamesbond

Joined: 26 Feb 2007
Posts: 3357
Location: The Blue Marble

PostPosted: Fri 01 Feb 2019, 04:09    Post subject:  

jake29 wrote:
The 91-autochownd issue is in a clean install - 'Downloads' folder is almost empty.
We have an updated autochown. It may fix the issue, or it may not. But worth a try.

Quote:
EDIT: I just realized that I should probably try compiling wine 2.0.1 for Fatdog64-800 <blush>
Yeah you can't use wine from 710 with 800, too many of the library changes.
_________________
Fatdog64, Slacko and Puppeee user. Puppy user since 2.13.
Contributed Fatdog64 packages thread.
Back to top
View user's profile Send private message 
SFR


Joined: 26 Oct 2011
Posts: 1731

PostPosted: Fri 01 Feb 2019, 07:42    Post subject:  

@Jake29: It's possible that autochown is continuously crashing for some reason and the high CPU usage comes from this loop in 91-autochownd:
Code:
# start the daemon
# autochown -d -p $PIDFILE $CONFPATH
while true; do # anti-crash loop, from SFR, will look for something better later
   autochown -p $PIDFILE $CONFPATH
   case $? in 137|143) break ;; esac # 137=Killed (kill -9), 143=Terminated (kill)
done &

As James mentioned, autochown's been updated (version 2018.08, repo), so you can try and see if it makes a difference.
If not, some workaround would be to add sleep 1 below the 'case $?...' line to slow down the loop until autochown stabilizes and stops crashing.

Greetings!

_________________
[O]bdurate [R]ules [D]estroy [E]nthusiastic [R]ebels => [C]reative [H]umans [A]lways [O]pen [S]ource
Omnia mea mecum porto.
Back to top
View user's profile Send private message 
step

Joined: 04 May 2012
Posts: 1197

PostPosted: Fri 01 Feb 2019, 07:43    Post subject:  

@jake29 ... or you can try rebuilding that specific version of wine for FD-800. I reckon you've built wine using the Fatdog64 recipe before, haven't you?
_________________
Fatdog64-802|+Packages|Kodi|Findnrun|+forum|gtkmenuplus
Back to top
View user's profile Send private message 
don570


Joined: 10 Mar 2010
Posts: 5345
Location: Ontario

PostPosted: Sat 02 Feb 2019, 13:43    Post subject:  

I've installed a few wine packages from
http://murga-linux.com/puppy/viewtopic.php?t=88711&start=315&search_id=599126155
I convert the pet to SFS

Then I use load_SFS when I want a windows program. (mp3DirectCut)

___________________________________________
Back to top
View user's profile Send private message 
jake29

Joined: 24 Jul 2015
Posts: 217

PostPosted: Sat 02 Feb 2019, 14:40    Post subject:  

don570 wrote:
I've installed a few wine packages from
http://murga-linux.com/puppy/viewtopic.php?t=88711&start=315&search_id=599126155
I convert the pet to SFS

Then I use load_SFS when I want a windows program. (mp3DirectCut)

___________________________________________


Thanks for the comment. I'm still looking into this, however the change from Freetype 2.6 to 2.9.1 in Fatdog64-800 has raised a known issue with older versions of Wine and newer versions of Freetype.

Wine 2.18 included: FreeType 2.8.1 compatibility fixes.

I have tried compiling these patched files with Wine 2.0.1, however compiling fails with the same error each time - possibly this is due to an error on my part. I believe I read there are still compatibility issues being introduced with FreeType releases since. Maybe I can use a patch from a more recent release of Wine.

I realise this is a very specific problem and do not expect the Fatdog team to try to account for it.

EDIT: I just discovered `winetricks speechsdk`- this has resolved all my issues and means I am able to use Wine 4.0.
Back to top
View user's profile Send private message 
step

Joined: 04 May 2012
Posts: 1197

PostPosted: Sat 02 Feb 2019, 18:35    Post subject:  

jake29 wrote:

EDIT: I just discovered `winetricks speechsdk`- this has resolved all my issues and means I am able to use Wine 4.0.
Thanks for persevering and giving us this tip.
_________________
Fatdog64-802|+Packages|Kodi|Findnrun|+forum|gtkmenuplus
Back to top
View user's profile Send private message 
Revolverve


Joined: 08 Nov 2008
Posts: 227
Location: 45°17'28.8"N 72°16'08.8"W_avatar/ mira.ca

PostPosted: Fri 08 Feb 2019, 15:35    Post subject:  

Forget freecad sfs test i made for fatdog64...
Freecad appimage
Way better, if you can manage the openbox/lxpanel glitch...it works.
Back to top
View user's profile Send private message 
dr. Dan


Joined: 20 Apr 2015
Posts: 84
Location: Oregon, U.S.A.

PostPosted: Mon 11 Feb 2019, 18:18    Post subject: uploads and downloads  

Having a separate /home/spot/Uploads folder has proved very convenient. Perhaps it would be a useful addition to the final release.

Dan
Back to top
View user's profile Send private message 
h2sammo3

Joined: 04 Jan 2019
Posts: 22

PostPosted: Tue 12 Feb 2019, 04:17    Post subject:  

cannot update libexiv2: Failed to download libexiv2: HTTP response code said error.

this has been going on for a couple of weeks.
Back to top
View user's profile Send private message 
jamesbond

Joined: 26 Feb 2007
Posts: 3357
Location: The Blue Marble

PostPosted: Tue 12 Feb 2019, 10:31    Post subject:  

dr.Dan can you elaborate how do you use "Uploads" folder?

h2sammo3 - thanks for the report; libexiv2 is apparently built with the wrong dependency record (it claims to depend on libssh which doesn't exist). We'll fix this.

_________________
Fatdog64, Slacko and Puppeee user. Puppy user since 2.13.
Contributed Fatdog64 packages thread.
Back to top
View user's profile Send private message 
h2sammo3

Joined: 04 Jan 2019
Posts: 22

PostPosted: Tue 12 Feb 2019, 21:55    Post subject:  

i lost wifi connectivity on latest updates. the widget in the taskbar says wpa supplicant cannot give any data on the network.
Back to top
View user's profile Send private message 
jamesbond

Joined: 26 Feb 2007
Posts: 3357
Location: The Blue Marble

PostPosted: Wed 13 Feb 2019, 00:18    Post subject:  

What do you mean "update"? Did you update from gslapt, or do you update from alpha to beta release?

If you do update from gslapt, please try to run without savefile/savedir, and see if the connection works?

_________________
Fatdog64, Slacko and Puppeee user. Puppy user since 2.13.
Contributed Fatdog64 packages thread.
Back to top
View user's profile Send private message 
dr. Dan


Joined: 20 Apr 2015
Posts: 84
Location: Oregon, U.S.A.

PostPosted: Wed 13 Feb 2019, 00:46    Post subject:  

@jamesbond: I do a fair amount of uploading of documents and audio. Having an upload folder monitored by autochown works like an out box with the download folder as an in box. On systems that don't use an online root-surrogate, it wouldn't matter, but with Fatdog it's handy.

Dan
Back to top
View user's profile Send private message 
h2sammo3

Joined: 04 Jan 2019
Posts: 22

PostPosted: Wed 13 Feb 2019, 01:07    Post subject:  

i tried several times to update from the fatdog updater app but the updates would not finish successfully. i addressed this problem earlier (libexv something...)

so i did update from gslapt. several things updated including openbox. i am not sure what caused this. i will try to boot without savefile. currently typing this from a tinycore boot from the same usb stick.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 21 of 23 [335 Posts]   Goto page: Previous 1, 2, 3, ..., 19, 20, 21, 22, 23 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1275s ][ Queries: 13 (0.0180s) ][ GZIP on ]