Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 17 Sep 2019, 04:56
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Can't connect to wi-fi
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [10 Posts]  
Author Message
ionmich

Joined: 28 Jul 2014
Posts: 24

PostPosted: Mon 11 Feb 2019, 18:28    Post subject:  Can't connect to wi-fi
Subject description: Network Connection Wizard does not find wireless signal
 

Asus eee 900
Xenilapup 32 bit

It shows eth0 and I can connect via wire. I installed atheros_kernel_modules-4.4.95noPAE-xenial32 but no wifi signal shows. I confirmed that the signal exists with another notebook.
Back to top
View user's profile Send private message 
ionmich

Joined: 28 Jul 2014
Posts: 24

PostPosted: Mon 11 Feb 2019, 20:17    Post subject:  

Some information.

Code:
ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:22:15:6D:63:C1 
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Memory:fbfc0000-fc000000

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:16 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1
          RX bytes:1248 (1.2 KiB)  TX bytes:1248 (1.2 KiB)

tunl0     Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00 
          NOARP  MTU:1480  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)



Code:
iwconfig
lo           no wireless extensions

eth0         no wireless extensions

tun0         no wireless extensions

Back to top
View user's profile Send private message 
cthisbear

Joined: 29 Jan 2006
Posts: 4437
Location: Sydney Australia

PostPosted: Mon 11 Feb 2019, 21:46    Post subject:  

I still have a similar netbook.
So I find that strange.

Are you sure your wireless light is on.

" hold down the "Fn" key and press the "F2" button once.
The Wi-Fi light should come on and the Eee PC will prompt you to select
a Wi-Fi network.

https://www.techwalla.com/articles/i-cant-connect-to-wi-fi-on-my-eee-pc

I always use Frisbee to connect wireless in Puppy.

Chris.
Back to top
View user's profile Send private message 
ionmich

Joined: 28 Jul 2014
Posts: 24

PostPosted: Tue 12 Feb 2019, 14:49    Post subject:  

cthisbear wrote:
I still have a similar netbook.
So I find that strange.

Are you sure your wireless light is on.

" hold down the "Fn" key and press the "F2" button once.
The Wi-Fi light should come on and the Eee PC will prompt you to select
a Wi-Fi network.

https://www.techwalla.com/articles/i-cant-connect-to-wi-fi-on-my-eee-pc

I always use Frisbee to connect wireless in Puppy.

Chris.


Thanks for the speedy response. Yes the wireless light is on. Yes I am using Frisbee. Can you confirm that you are using Xenialpup 7.5? Because I think that's my problem. The previous OS I used connected without a problem.
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 12628
Location: Stratford, Ontario

PostPosted: Tue 12 Feb 2019, 14:55    Post subject:  

You have not yet identified the make/model of your wifi adapter. Run the command: lspci -nnk

Look for the "network controller".
Back to top
View user's profile Send private message 
ionmich

Joined: 28 Jul 2014
Posts: 24

PostPosted: Tue 12 Feb 2019, 15:55    Post subject:  

rcrsn51 wrote:
You have not yet identified the make/model of your wifi adapter. Run the command: lspci -nnk

Look for the "network controller".


Those would be...

Code:
01:00.0 Ethernet controller [0200]: Qualcomm Atheros AR242x / AR542x Wireless Network Adapter (PCI-Express) [168c:001c] (rev 01)
   Subsystem: AzureWave AW-GE780 802.11bg Wireless Mini PCIe Card [1a3b:1026]
03:00.0 Ethernet controller [0200]: Qualcomm Atheros Attansic L2 Fast Ethernet [1969:2048] (rev a0)
   Subsystem: ASUSTeK Computer Inc. Device [1043:8233]
   Kernel driver in use: atl2
   Kernel modules: atl2
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 12562
Location: S.C. USA

PostPosted: Tue 12 Feb 2019, 16:10    Post subject:  

If you are sure you installed this pet.
http://distro.ibiblio.org/puppylinux/puppy-xenial/32/atheros_kernel_modules-4.4.95noPAE-xenial32.pet
If frugal install. Have Xenialpup using a save file/folder.
Have rebooted.

Try using the Network Wizard to do the setup.
If asked about loading the driver or module, do that.

Here are steps for using Network Wizard.
1. Select Network Wizard
2. Select wlan0 (your network card may have a different description)
3. Select Wireless in the Configure wireless network box.
4. Select Scan and your ESSID should come up.
5. Select your ESSID and OK
6. Give a name to your profile. It should already be what you selected in step 5.
7. Encryption. Most people use WPA/TKIP - select it or WPA2.
8. A box will open for you to write the WPA password. It is called a Shared Key. Enter the password.
9. Leave the other boxes as they are. Rarely do these need adjustment.
9. Select Save
10. Select Use This Profile
11. A box will appear showing Puppy trying to connect
12. A box will come up “REPORT ON TEST 0f wlan0CONNECTION”
13. Select Auto DHCP in the Configure interface box and it will go through a handshake routine. and declare itself successful
14. Select done

If something does not work.
You do what?
You see what?

_________________
The things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
YaPI(any iso installer) http://www.murga-linux.com/puppy/viewtopic.php?t=107601
Back to top
View user's profile Send private message 
ionmich

Joined: 28 Jul 2014
Posts: 24

PostPosted: Tue 12 Feb 2019, 16:57    Post subject:  

Thanks to everyone for trying to help, but I think my initial suspicion may have been correct. That Xenialpup 7.5 is the problem. It's based on Ubuntu 16.04 and the following links indicate that there is a problem between that version and the Qualcomm Atheros AR242x / AR542x.

https://askubuntu.com/questions/763080/no-wifi-in-qualcom-atheros-ubuntu-16-04-acer-aspire-e-15

https://askubuntu.com/questions/78115/help-set-up-atheros-ar242x-ar542x-wireless-adapter

https://ubuntuforums.org/showthread.php?t=2183347
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 12628
Location: Stratford, Ontario

PostPosted: Tue 12 Feb 2019, 17:12    Post subject:  

Your [168c:001c] device is handled by the ath5k driver, which is included in the PET you downloaded.

Something has gone wrong with its install procedure.

Type: modinfo ath5k
Back to top
View user's profile Send private message 
ionmich

Joined: 28 Jul 2014
Posts: 24

PostPosted: Tue 12 Feb 2019, 19:34    Post subject:  

rcrsn51 wrote:
Your [168c:001c] device is handled by the ath5k driver, which is included in the PET you downloaded.

Something has gone wrong with its install procedure.

Type: modinfo ath5k


Possibly. But I found it simpler to trash Xenialpup 7.5 and to install UpUpBB (based on Ubuntu 18.04) which works as expected as I am on it now.

Thank you for your assistance.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [10 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0500s ][ Queries: 12 (0.0060s) ][ GZIP on ]