Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 26 Nov 2014, 02:44
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
I can't encrypt a filesystem with Puppy's aes
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
Mazzo

Joined: 19 Jul 2005
Posts: 26
Location: UK - Thames Valley

PostPosted: Wed 10 Aug 2005, 08:45    Post_subject:  I can't encrypt a filesystem with Puppy's aes  

Hi

I am trying to set up an encrypted filesystem using losetup-FULL and aes encryption. It doesn't work!

Barry used xor encryption for the pup001 on usb / hard drive, but I would prefer something a little stronger.

the command would be:

losetup-FULL -e aes /dev/loopx filename

It allows me to put in a password (although it expects 20 characters) but then fails.

I have setup succesfully a filesystem on ubuntu which works fine, but when trying to mount it in puppy, it fails. It may be the aes is different.

Anyone any ideas? Is the aes in puppy purely for wireless networking?

The command to mount would be:
mount -t umsdos -o loop filename /mountpoint -oencryption=aes

If there is another strong and reasonably quick alternative to aes that is easy to put into puppy, it would be good to know. I don't want to (and worry about my capability) of recompiling the kernel.

Here's hoping someone else has tried it (and been successful!) Wink

Edited_time_total
Back to top
View user's profile Send_private_message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7082
Location: Perth, Western Australia

PostPosted: Wed 10 Aug 2005, 11:00    Post_subject:  

I wonder if the aes.o module is getting loaded.
It probably should happen automatically, but just in case, you could try "modprobe aes".
Back to top
View user's profile Send_private_message Visit_website 
Mazzo

Joined: 19 Jul 2005
Posts: 26
Location: UK - Thames Valley

PostPosted: Wed 10 Aug 2005, 17:05    Post_subject:  

Hi Barry - thanks for replying.

It seems to be loaded - it certainly asks for a 20 character password which xor doesn't.
Back to top
View user's profile Send_private_message 
Mazzo

Joined: 19 Jul 2005
Posts: 26
Location: UK - Thames Valley

PostPosted: Wed 17 Aug 2005, 18:10    Post_subject:  

I still cannot get aes to work at all with losetup-Full.

I can get xor to work, but it is really weak (it looks to me that the password is visible in the file if you view it in a text editor!). Maybe I am doing something wrong?

The idea would be to create an encrypted pup00x on a usb or HD so that only you can access it.

Is there anyone who is able to help with this? I think (stands by to be corrected Wink ) that I have done my homework and that aes encryption is both pretty secure and also quick for loopback systems.

When trying to:
losetup-FULL -e aes /dev/loopn filename

I simply get
ioctl: LOOP_SET_STATUS: Invalid argument

This doesn't happen if aes is changed to xor.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0433s ][ Queries: 12 (0.0036s) ][ GZIP on ]