Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 20 Mar 2019, 20:03
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
UNITY3D + Mono
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [9 Posts]  
Author Message
FatBeard

Joined: 02 Feb 2019
Posts: 10

PostPosted: Thu 14 Feb 2019, 17:30    Post subject:  UNITY3D + Mono
Subject description: Games & 3D Creation Software
 

PACKAGES REQUIRED: UNITY3D + Mono
TARGET PUPPY: FATDOG64 721 ...
... (or any other 64 bit PUPPY... I can move! eg. XENIAL?)

https://unity3d.com/

Unix Versions seem to come packaged with MONO but I have not yet managed to install one of them correctly. MONO-DEVELOP seems to be the sticking point on the unix versions.

https://forum.unity.com/threads/unity-on-linux-release-notes-and-known-issues.350256/

NB...

Have tried installing UNITY3D under WINE ... This failed due to Grey Reg Screen Issue ...

Have tried all ideas eg. replace registration .htm files from packages from /Editor/Data/Resources/Packages

Also tried installing Unity3D onto a Windows machine and copying over the missing files. Still Grey Screen.

Needed to fix mscorlib.dll ... download > .system32 then...
wine regsvr32.exe /u mscorlib.dll

Yes have installed IE8 into wine (winetricks unity3d.verb does this).

The missing details are the registration screen... but... can't manually register because I am a TRIAL user ... we get no serial number as a TRIAL customer! so the manual registration line will not work therefore the free version won't work.

The package DID install under WINETRICKS unity3d.verb

My target version is either last Unity3d 5.x.x or Unity3d 2017.x.x but would be happy with later?

Has anyone managed to have UNITY3D running under PUPPY?! How much worked? What wouldn't?

Arrr!










...


# uname -a
Linux fatdog64 4.14.12 #1 SMP Tue Jan 9 23:44:49 AEST 2018 x86_64 AMD Phenom(tm) II X3 B75 Processor AuthenticAMD GNU/Linux
#
# wine --version
wine-3.0
#
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3385
Location: wales

PostPosted: Fri 15 Feb 2019, 10:23    Post subject:  

hi FatBeard,

just tried the linux version Unity-2018.3.0f2 in bionicpup64 and it fired up (note that i have a lot of other stuff also installed).

i had a few problems entering text with the sign in screen, it seems if you make a mistake text input stops working. restarting and not making any mistakes got me through it .

created a cube, sphere & tree but didn't test more than that.


aaaaar
unity-2019-02-15-14-16-58.png
 Description   
 Filesize   132.56 KB
 Viewed   154 Time(s)

unity-2019-02-15-14-16-58.png


_________________
Bionicpup64 built with bionic beaver packages http://murga-linux.com/puppy/viewtopic.php?t=114311
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
FatBeard

Joined: 02 Feb 2019
Posts: 10

PostPosted: Fri 15 Feb 2019, 13:09    Post subject:  

ARRrrrRRRrrr! Grats 666!

So this CAN work in Puppy!

Any chance of a snapshot / sfs / remaster?

Fatdog64-721? or on a new Bionicpup64?

Lots installed ... yes a distinct advantage on a seasoned linux system ... all the deps that come in with installed software.

I recently moved from a 32bit os based on debiandog that has had its day ... shot behind the barn! ... so this is onto a pristine install of any late puppy that must support:

ATI HD4200 direct rendering
Wine + 32 bit compat
Compiz (it's actually a deal breaker for me if CF can't work out of the box!)

What to do what to do ...
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3385
Location: wales

PostPosted: Fri 15 Feb 2019, 13:56    Post subject:  

aaaar FatBeard,

it works in fatdog but i needed to install libsoup & gtk3 from the package manager.

as for the rest of your requirements
ATI HD4200 direct rendering ... not sure in either bionic or fatdog as i don't have an amd card to test

Wine + 32 bit compat .... ok in fatdog & bionicpup64

compiz ... not sure about fatdog but i've had it working in bionicpup but it has issues that i haven't figured out (not really looked into it) that is when you close a window it exits to prompt Sad emerald is in bionicpups repo though if you're inclined to look into it

and looking forward to you post about getting 'mono' working in the how to section Wink
unity-fatdog.jpg
 Description   
 Filesize   79.33 KB
 Viewed   136 Time(s)

unity-fatdog.jpg

Back to top
View user's profile Send private message 
FatBeard

Joined: 02 Feb 2019
Posts: 10

PostPosted: Sat 16 Feb 2019, 10:57    Post subject:  

OK... Yes this version installs, allows me to register and create a project, then crashes out with no error log!

If you fancy posting a remaster of that working unity3d puppy no matter how large... (google drive?) I can at least guarantee a thorough test of unity there!

In terms of the mono runtimes... these should be installed with the editor, and do end up in the installers temp folder, but do not seem to be unpacked on my setup in this version of the editor... maybe deps again possibly 7zip (tho clearly you managed this)... arrr!
UnitySetup-Windows-Mono-Support-for-Editor-2018.3.0f2.pkg
^^

... Later ... Tried UnityHub 1.5.0 as installer ...
Worked until white screen of death in the signup.




I am probably missing deps so will have another go after the weekend ... off to the boat now!
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3385
Location: wales

PostPosted: Mon 18 Feb 2019, 06:11    Post subject:  

hi FatBeard,

give bionicpup64 a go as it fires up straight away http://murga-linux.com/puppy/viewtopic.php?t=114311

P.S. my savefolder is currently 81gb .... that would be a hell of a remaster Very Happy

_________________
Bionicpup64 built with bionic beaver packages http://murga-linux.com/puppy/viewtopic.php?t=114311
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
FatBeard

Joined: 02 Feb 2019
Posts: 10

PostPosted: Tue 19 Feb 2019, 11:29    Post subject:  

Neeeearly with Bionic64...



Stalls when creating / loading a scene.
No sign of an error log in /var/logs/ ...

On the plus side mono seems to have installed correctly as part of the installer / download assistant (see it flash up in task manager as Unity loads).

Not sure what to do next ... hmmmmm....

Had a little read up ... my ATI HD4200 card was suspect BUT as it offers GL 3.3 features I have to assume it meets minimum spec and runs ok under windows7 ... and can see posts from other linux editor people running this card ... however it could be the graphics DRIVER... will try on an nvidia box soon / tomoz.

Code:

name of display: :0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
server glx extensions:
    GLX_ARB_create_context, GLX_ARB_create_context_profile,
    GLX_ARB_create_context_robustness, GLX_ARB_fbconfig_float,
    GLX_ARB_framebuffer_sRGB, GLX_ARB_multisample,
    GLX_EXT_create_context_es2_profile, GLX_EXT_create_context_es_profile,
    GLX_EXT_fbconfig_packed_float, GLX_EXT_framebuffer_sRGB,
    GLX_EXT_import_context, GLX_EXT_libglvnd, GLX_EXT_texture_from_pixmap,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_INTEL_swap_event,
    GLX_MESA_copy_sub_buffer, GLX_OML_swap_method, GLX_SGIS_multisample,
    GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group,
    GLX_SGI_make_current_read, GLX_SGI_swap_control
client glx vendor string: Mesa Project and SGI
client glx version string: 1.4
client glx extensions:
    GLX_ARB_context_flush_control, GLX_ARB_create_context,
    GLX_ARB_create_context_profile, GLX_ARB_create_context_robustness,
    GLX_ARB_fbconfig_float, GLX_ARB_framebuffer_sRGB,
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_buffer_age,
    GLX_EXT_create_context_es2_profile, GLX_EXT_create_context_es_profile,
    GLX_EXT_fbconfig_packed_float, GLX_EXT_framebuffer_sRGB,
    GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_EXT_visual_info,
    GLX_EXT_visual_rating, GLX_INTEL_swap_event, GLX_MESA_copy_sub_buffer,
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
    GLX_MESA_swap_control, GLX_OML_swap_method, GLX_OML_sync_control,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
    GLX_SGIX_visual_select_group, GLX_SGI_make_current_read,
    GLX_SGI_swap_control, GLX_SGI_video_sync
GLX version: 1.4
GLX extensions:
    GLX_ARB_create_context, GLX_ARB_create_context_profile,
    GLX_ARB_create_context_robustness, GLX_ARB_fbconfig_float,
    GLX_ARB_framebuffer_sRGB, GLX_ARB_get_proc_address, GLX_ARB_multisample,
    GLX_EXT_buffer_age, GLX_EXT_create_context_es2_profile,
    GLX_EXT_create_context_es_profile, GLX_EXT_fbconfig_packed_float,
    GLX_EXT_framebuffer_sRGB, GLX_EXT_import_context,
    GLX_EXT_texture_from_pixmap, GLX_EXT_visual_info, GLX_EXT_visual_rating,
    GLX_INTEL_swap_event, GLX_MESA_copy_sub_buffer,
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
    GLX_MESA_swap_control, GLX_OML_swap_method, GLX_OML_sync_control,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
    GLX_SGIX_visual_select_group, GLX_SGI_make_current_read,
    GLX_SGI_swap_control, GLX_SGI_video_sync
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: X.Org (0x1002)
    Device: AMD RS880 (DRM 2.50.0 / 4.19.12, LLVM 6.0.0) (0x9710)
    Version: 18.0.5
    Accelerated: yes
    Video memory: 368MB
    Unified memory: no
    Preferred profile: core (0x1)
    Max core profile version: 3.3
    Max compat profile version: 3.0
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.0
Memory info (GL_ATI_meminfo):
    VBO free memory - total: 367 MB, largest block: 367 MB
    VBO free aux. memory - total: 509 MB, largest block: 509 MB
    Texture free memory - total: 367 MB, largest block: 367 MB
    Texture free aux. memory - total: 509 MB, largest block: 509 MB
    Renderbuffer free memory - total: 367 MB, largest block: 367 MB
    Renderbuffer free aux. memory - total: 509 MB, largest block: 509 MB
Memory info (GL_NVX_gpu_memory_info):
    Dedicated video memory: 368 MB
    Total available memory: 877 MB
    Currently available dedicated video memory: 367 MB
OpenGL vendor string: X.Org
OpenGL renderer string: AMD RS880 (DRM 2.50.0 / 4.19.12, LLVM 6.0.0)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 18.0.5
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
Back to top
View user's profile Send private message 
oui

Joined: 20 May 2005
Posts: 3310
Location: near Woof (Germany) :-) - 3 PC's: DELL SX280 750 MB Pentium4, Acer emachines 2 GB AMD64. DELL XPS15

PostPosted: Tue 19 Feb 2019, 17:04    Post subject:  

note: mono is very important in Wine, a kind of "about dependency" (and you have after that a good step to a well installed Wine). but it's heavy (somewhat like 600 and more Mb in Lubuntu of course full install, and not the newest...)
Back to top
View user's profile Send private message 
FatBeard

Joined: 02 Feb 2019
Posts: 10

PostPosted: Tue 19 Feb 2019, 22:13    Post subject:  

Mono seems to have installed via the Unity Download Assistant so maybe we dodged one there.

Currently still trying to get the Native Linux editor running. Sorry for confusion.

Under Wine was using the native .net stuff via winetricks.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [9 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0786s ][ Queries: 13 (0.0101s) ][ GZIP on ]