Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 26 Mar 2019, 13:00
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
BionicPup32 (UPupBB) (March 2019)
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 35 of 37 [555 Posts]   Goto page: Previous 1, 2, 3, ..., 33, 34, 35, 36, 37 Next
Author Message
rockedge


Joined: 11 Apr 2012
Posts: 1007
Location: Connecticut, United States

PostPosted: Tue 12 Mar 2019, 08:29    Post subject:  

it could be as simple as the path to the ISO is incorrect or the iso is missing.

I have run the command in varoius ways and I get this using a test iso:

Code:
#7z l /initrd/mnt/dev_save/ISO/upupbb-18.05+23.iso 2>/dev/null

7-Zip [64] 16.02 : Copyright (c) 1999-2016 Igor Pavlov : 2016-05-21
p7zip Version 16.02 (locale=en_US.UTF-8,Utf16=on,HugeFiles=on,64 bits,4 CPUs Intel(R) Core(TM) i5-2400 CPU @ 3.10GHz (206A7),ASM,AES-NI)

Scanning the drive for archives:
1 file, 271581184 bytes (259 MiB) 

Listing archive: /initrd/mnt/dev_save/ISO/upupbb-18.05+23.iso

--
Path = /initrd/mnt/dev_save/ISO/upupbb-18.05+23.iso
Type = Iso
ERRORS:
Unexpected end of archive
Physical Size = 8796092989440
Comment =
System: LINUX
Volume: CDROM
Application: MKISOFS ISO9660/HFS/UDF FILESYSTEM BUILDER & CDRECORD CD/DVD/BluRay CREATOR (C) 1993 E.YOUNGDALE (C) 1997 J.PEARSON/J.SCHILLING
Created = 2019-01-13 05:10:03
Modified = 2019-01-13 05:10:03

   Date      Time    Attr         Size   Compressed  Name
------------------- ----- ------------ ------------  ------------------------
2019-01-13 04:26:24 .....     21594112     21594112  adrv_upupbb_18.05.sfs
2019-01-13 05:10:03 .....         2048         2048  boot.cat
2019-01-13 05:10:02 .....          126          126  boot.msg
2019-01-13 04:26:24 .....         1278         1278  DISTRO_SPECS
2019-01-13 04:26:25 .....     20283392     20283392  fdrv_upupbb_18.05.sfs
2019-01-13 05:10:02 .....         1462         1462  help.msg
2019-01-13 05:10:02 .....         1506         1506  help2.msg
2019-01-13 04:22:46 .....      2325650      2325650  initrd.gz
2018-04-27 05:14:45 .....        14336        14336  isolinux.bin
2019-01-13 05:10:02 .....          151          151  isolinux.cfg
2019-01-13 05:10:03 .....            0            0  logo.16
2019-01-13 04:28:08 .....    196550656    196550656  puppy_upupbb_18.05.sfs
2019-01-13 05:10:03 .....         3231         3231  README.HTM
2019-01-13 04:26:24 .....          544          544  README-extra_sfs
2018-04-25 23:49:01 .....      5501792      5501792  vmlinuz
2019-01-13 04:26:25 .....        32768        32768  ydrv_upupbb_18.05.sfs
2018-04-26 03:15:22 .....     24051712     24051712  zdrv_upupbb_18.05.sfs
                    .....         2048         2048  [BOOT]/Boot-NoEmul.img
------------------- ----- ------------ ------------  ------------------------
2019-01-13 05:10:03          270366812    270366812  18 files

Errors: 1
#
Back to top
View user's profile Send private message Visit poster's website 
tosim

Joined: 19 Nov 2015
Posts: 35

PostPosted: Tue 12 Mar 2019, 11:20    Post subject:  

I think I may have solved it. Will check a little later on. I re downloaded the iso, extracted it this time, int a directory, then, using the terminal with command "mkisofs -o destination-filename.iso /home/username/folder-name" made the new iso. It installed on my MultiBootUSB flash with no problem, which is what I could not do before. Will let y'all know if all OK.
Thanks again for the assistance.
Update:
Well, it did start to boot-up, but then error, something to the effect of not previously dismounting. Guess I'll have to wait for v29, or look for v27 which I had no problems with.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3739
Location: Worcestershire, UK

PostPosted: Thu 14 Mar 2019, 11:13    Post subject:  

For testing please....

UPupBB-19.03 (now rebadged as BionicPup32-8.0)

9d753e2dffd49beaba80751e87a45c3f bionicpup32-8.0+0-uefi.iso

BUILD_FROM_WOOF='testing;0c9e0a1c;2019-03-13 09:51:50 +0000'

Kernel-4.9.163

Updating existing personal saves not recommended (unless backed up first)

Thanks

_________________
LxPup = Puppy + LXDE
Main version used daily: LxPupSc; Assembler of UPup, ScPup & ScPup64, LxPup, LxPupSc and LxPupSc64

Last edited by peebee on Sat 16 Mar 2019, 11:31; edited 2 times in total
Back to top
View user's profile Send private message Visit poster's website 
mavrothal


Joined: 24 Aug 2009
Posts: 3017

PostPosted: Fri 15 Mar 2019, 00:35    Post subject:  

peebee wrote:
For testing please....

UPupBB-19.03 (now rebadged as BionicPup32-8.0)

f88ac23aee9dd18d61924aef28694d8c bionicpup32-8.0+0-uefi.iso


Looks good here! Very Happy

However the welcome/info screen is rather scary/negative than informative...
You might want to consider something like the one below, instead of the original.

in case it is hard to read is says:
Quote:
Welcome to Puppylinux 8, the BionicPup32 (UPupBB) system.
Below are some things that are different/new in this puppy.

1. Kernel
To facilitate kernel changes, the kernel SFS (zdrv) is built with the firmware in a different SFS, fdrv (see below).
For the same reason we also keep kernel headers with the kernel source SFS instead of the development SFS, devx and should be installed separately when needed

2. adrv web-browser
To facilitate easy replacement, we also supply the web-browser in a separate SFS, adrv. The included Ulight browser, a "lightweight" Firefox derivative, could be replaced or augmented by one of the full blown browsers. The menu item "Get Web Browser" under Internet, can be used to download a selection of browsers once internet access has been established.

3. fdrv firmware
The fdrv contains firmware for most hardware. However if a device (e.g. wifi) fails to work, check kernel messages with the "dmesg | grep firm” command in the terminal for clues. The full firmware sfs should be downloaded from http://www.fishprogs.software/puppy/firmware-sfs/ and the needed firmware extracted and put into /lib/firmware folder.
and the color is "seashell" Shocked
before.jpg
 Description   
 Filesize   64.88 KB
 Viewed   441 Time(s)

before.jpg

after.jpg
 Description   
 Filesize   59.63 KB
 Viewed   437 Time(s)

after.jpg


_________________
== Here is how to solve your Linux problems fast ==

Last edited by mavrothal on Fri 15 Mar 2019, 00:49; edited 1 time in total
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 11923
Location: S.C. USA

PostPosted: Fri 15 Mar 2019, 00:46    Post subject:  

I know all about why you changed the name to Bionicpup32-8.0.
That was a good idea, so it could be posted in Distrowatch, to go with Bionicpup64 8.0.

I suggest you need to say something about the name change in the first post of this topic.
Also, if you try to download the devx. It is still named for UpupBB, so it looks like the wrong one, if you have Bionicpup32 8.0

_________________
The things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
YaPI(any iso installer) http://www.murga-linux.com/puppy/viewtopic.php?t=107601
Back to top
View user's profile Send private message 
mavrothal


Joined: 24 Aug 2009
Posts: 3017

PostPosted: Fri 15 Mar 2019, 03:52    Post subject:  

Posting from a circa 2005 HP/Compaq Presario 4000 1.6GHz Pentium M 768MB RAM 512MB swap.
It runs fine!
Video driver (intel), wifi (ipw2200), the (strange - AlpsPS/2) touchpad, battery, brightness keys, lid switch, even the off-keyboard sound controls!
Played youtube video full screen smoothly and still has free ram and swap space!
It is a bit slow to load apps (nothing compared to Win XP2/3) but once up they are running fine and smoothly.
Way to go!

Latter: Updated also a (minimally used) 18.04 savefile.
The only problem I noticed is the pup_even complaining that does not know what to do when you click a drive icon. There are several changed in woof between the 2 versions but should not be difficult to fix.

_________________
== Here is how to solve your Linux problems fast ==
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1782
Location: Italy

PostPosted: Fri 15 Mar 2019, 09:48    Post subject:  

peebee wrote:
For testing please....

UPupBB-19.03 (now rebadged as BionicPup32-8.0)


New frugal install. Is PuppyPhone in the last release 1.42? I removed the built-in puppyphone and installed psip 1.42. My backuped conf file works with psip 1.42.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3739
Location: Worcestershire, UK

PostPosted: Fri 15 Mar 2019, 10:01    Post subject:  

watchdog wrote:
peebee wrote:
For testing please....

UPupBB-19.03 (now rebadged as BionicPup32-8.0)


New frugal install. Is PuppyPhone in the last release 1.42? I removed the built-in puppyphone and installed psip 1.42. My backuped conf file works with psip 1.42.

Same as in previous build....
:puppyphone:|pet|Packages-puppy-tahr-official|puppyphone-1.2-psip32-1-w5|puppyphone|1.2-psip32-1-w5||Internet|1576K||puppyphone-1.2-psip32-1-w5.pet|+gtk+|Psip PuppyPhone Internet telephone|puppy|wary5||

Can't see 1.42 anywhere in the ibiblio repos???

_________________
LxPup = Puppy + LXDE
Main version used daily: LxPupSc; Assembler of UPup, ScPup & ScPup64, LxPup, LxPupSc and LxPupSc64
Back to top
View user's profile Send private message Visit poster's website 
watchdog

Joined: 28 Sep 2012
Posts: 1782
Location: Italy

PostPosted: Fri 15 Mar 2019, 10:52    Post subject:  

Look at:

http://smokey01.com/software/internet/

Discussion around:

http://murga-linux.com/puppy/viewtopic.php?p=1012071#1012071

Old versions of psip no longer work for me (using ekiga call-out). I'm using version 1.42.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 3739
Location: Worcestershire, UK

PostPosted: Fri 15 Mar 2019, 13:49    Post subject:  

watchdog wrote:
Look at:

http://smokey01.com/software/internet/


Which version is known to work on BionicPup32??

_________________
LxPup = Puppy + LXDE
Main version used daily: LxPupSc; Assembler of UPup, ScPup & ScPup64, LxPup, LxPupSc and LxPupSc64
Back to top
View user's profile Send private message Visit poster's website 
Terry H

Joined: 29 Mar 2009
Posts: 576
Location: The Heart of Muskoka, ON Canada

PostPosted: Fri 15 Mar 2019, 13:59    Post subject:  

The USB Flash drive I am currently using was getting full of frugal installs. I recently swapped the HDD in my laptop for an SSD. In doing so I shrunk the Windows 10 installation and created an ext4 partition and also a Linux swap partition. Lots of space for frugal installs now. This is the first frugal install I have done on the ext4 partition. I am using the legacy grub on the USB to boot.

New frugal install, created new save folder. All working well. Great job peebee.

Code:
# inxi -Fxxz
System:    Host: puppypc8092 Kernel: 4.9.163-lxpup-32-pae i686 (32 bit gcc: 8.3.0) Desktop: JWM 2.3.7 dm: N/A
           Distro: BionicPup32 19.03
Machine:   Device: laptop System: Dell product: Latitude 3350 Chassis: type: 9
           Mobo: Dell model: 0TMD22 v: X02 UEFI [Legacy]: Dell v: A09 date: 11/24/2016
Battery    BAT0: charge: 59.0 Wh 130.2% condition: 45.3/59.0 Wh (77%) volts: 8.4/7.4
           model: Samsung SDI DELL 6C0FN58 serial: 37544 status: Full
CPU:       Dual core Intel Core i5-5200U (-HT-MCP-) cache: 3072 KB
           flags: (lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 8779
           clock speeds: min/max: 500/2700 MHz 1: 995 MHz 2: 1056 MHz 3: 1539 MHz 4: 899 MHz
Graphics:  Card: Intel HD Graphics 5500 bus-ID: 00:02.0 chip-ID: 8086:1616
           Display Server: X.org 1.19.6 drivers: modesetting (unloaded: fbdev,vesa)
           tty size: 116x24 Advanced Data: N/A for root
Audio:     Card-1 Intel Wildcat Point-LP High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0 chip-ID: 8086:9ca0
           Card-2 Intel Broadwell-U Audio Controller driver: snd_hda_intel bus-ID: 00:03.0 chip-ID: 8086:160c
           Sound: Advanced Linux Sound Architecture v: k4.9.163-lxpup-32-pae
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 03:00.0 chip-ID: 10ec:8168
           IF: enp3s0 state: down mac: <filter>
           Card-2: Intel Wireless 7265 driver: iwlwifi bus-ID: 04:00.0 chip-ID: 8086:095a
           IF: wlp4s0 state: up mac: <filter>
Drives:    HDD Total Size: 264.1GB (4.8% used)
           ID-1: /dev/sda model: Crucial_CT256MX1 size: 256.1GB serial: N/A
           ID-2: /dev/sdb model: DataTraveler_3.0 size: 8.0GB serial: N/A
Partition: ID-1: swap-1 size: 10.49GB used: 0.00GB (0%) fs: swap dev: /dev/sda4
RAID:      System: supported: linear raid0 raid1 raid10 raid6 raid5 raid4
           No RAID devices: /proc/mdstat, md_mod kernel module present
           Unused Devices: none
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 197 Uptime: 2 min Memory: 316.5/7722.9MB Init: SysVinit v: N/A runlevel: 5 Gcc sys: N/A
           Client: Shell (bash 4.4.191 running in lxterminal) inxi: 2.3.8
#
Back to top
View user's profile Send private message 
Brown Mouse

Joined: 09 Jun 2009
Posts: 525
Location: Canary Islands

PostPosted: Fri 15 Mar 2019, 14:46    Post subject:  

Been running all day and found no major issues as yet except that it doesn't seem to recognize Android phones.There is no menu entry and MTP is missing.

Thank you for your hard work.
Back to top
View user's profile Send private message 
Terry H

Joined: 29 Mar 2009
Posts: 576
Location: The Heart of Muskoka, ON Canada

PostPosted: Fri 15 Mar 2019, 15:12    Post subject:    

Just had one of the weirdest things that have happened using puppy (or any distro). I somehow in some strange way double clicked the launcher in the top bar to launch light browser. This normally generates an error message that the browser is already running, but didn't this time. A second instance of light was started, one in maximized full screen mode, the second in a reduced window. I was able to close the full window, but the controls for the second window were not accessible, so I couldn't do anything with it. This light browser instance was functioning correctly. All other applications I attempted to run were hidden by the light window. I couldn't access the top tray either, it was also under the window.

I opened a terminal, but it opened below the light window. I then tried to access other virtual desktops, but this light window was still on top. As the terminal window was seemingly the active window as displayed in the tray. I blindly typed reboot (wish I had typed 'killall light' before to see if that worked). The reboot worked and now back in bionicpup32 with no residual issues. Prior to doing the reboot, I was able to also to blindly get a screenshot of the desktop showing the errant window.


Edit: In hindsight, I suppose I could have just used the 'Leave' icon from the bottom tray to reboot. Oh well!



Last edited by Terry H on Fri 15 Mar 2019, 15:26; edited 2 times in total
Back to top
View user's profile Send private message 
Terry H

Joined: 29 Mar 2009
Posts: 576
Location: The Heart of Muskoka, ON Canada

PostPosted: Fri 15 Mar 2019, 15:23    Post subject:  

Deleted double post.
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3386
Location: wales

PostPosted: Fri 15 Mar 2019, 15:42    Post subject:  

hi peebee,
looking good!
as brownmouse says mtp_phone_connect is missing,
also pplog doesn't work as the missing perl fix is in /usr/share/perl/5.24.1 when should be in /usr/share/perl/5.26.1 ... also needs a link 5.26.1 >> 5.26
there's a few missing icons in /usr/local/apps

i've attached the pplog fix the missing icons, and also a samba start/stop script that makes /etc/init.d/rc.samba none executable when not in use
missingstuff.zip
Description 
zip

 Download 
Filename  missingstuff.zip 
Filesize  29.75 KB 
Downloaded  11 Time(s) 

_________________
Bionicpup64 built with bionic beaver packages http://murga-linux.com/puppy/viewtopic.php?t=114311
Xenialpup64, built with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 35 of 37 [555 Posts]   Goto page: Previous 1, 2, 3, ..., 33, 34, 35, 36, 37 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1448s ][ Queries: 13 (0.0308s) ][ GZIP on ]