Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 14 Dec 2019, 01:07
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
VP9 codec not needed for streaming from youtube
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [4 Posts]  
Author Message
nic007


Joined: 13 Nov 2011
Posts: 3200
Location: Cradle of Humankind

PostPosted: Mon 29 Apr 2019, 09:10    Post subject:  VP9 codec not needed for streaming from youtube  

I'm a bit confused but fairly certain that one does not need the VP9 codec (.webm) as part of your avcodec pack to be able to stream and play VP9 video. This ability seems to be built in when you use a fairly new browser. I've checked this on both my windows xp system and puppy. I have very old codecs on my xp machine and yet I can stream from youtube no problem with a new seamonkey browser. In puppy I've disabled libavcodec and was still able to watch youtube streams. Also, you can watch VP9 video offline by running it via the browser without any other installed codec packs. Interesting.
Back to top
View user's profile Send private message 
s243a

Joined: 02 Sep 2014
Posts: 2205

PostPosted: Mon 29 Apr 2019, 23:13    Post subject: Re: VP9 codec not needed for streaming from youtube  

nic007 wrote:
I'm a bit confused but fairly certain that one does not need the VP9 codec (.webm) as part of your avcodec pack to be able to stream and play VP9 video. This ability seems to be built in when you use a fairly new browser. I've checked this on both my windows xp system and puppy. I have very old codecs on my xp machine and yet I can stream from youtube no problem with a new seamonkey browser. In puppy I've disabled libavcodec and was still able to watch youtube streams. Also, you can watch VP9 video offline by running it via the browser without any other installed codec packs. Interesting.


Interesting Smile. Do you know if this applies to both firefox and palemoon?
Back to top
View user's profile Send private message Visit poster's website 
nic007


Joined: 13 Nov 2011
Posts: 3200
Location: Cradle of Humankind

PostPosted: Tue 30 Apr 2019, 01:05    Post subject:  

I've checked with Palemoon and Seamonkey. Can't see why FF would be any different.
Back to top
View user's profile Send private message 
norgo


Joined: 13 Nov 2015
Posts: 354
Location: Germany

PostPosted: Thu 02 May 2019, 18:43    Post subject:  

@nic007 @s243a

whether you will need installation of libvpx or not
is depending how firefox, seamonkey or palemoon has been compiled.

type about:buildconfig in browser address-bar
have a look at section configure options

is there an entry --with-system-libvpx you will need installation of libvpx at your system
otherwise browser contains and use internal libvpx

There doesn't exist a general statement.
libvpx.jpg
 Description   configure option
 Filesize   8.77 KB
 Viewed   63 Time(s)

libvpx.jpg

Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [4 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0372s ][ Queries: 13 (0.0104s) ][ GZIP on ]