Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 17 Jun 2019, 01:45
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Regarding HP Notebook that wont boot from USB
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [6 Posts]  
Author Message
puppyhp

Joined: 06 Jun 2019
Posts: 2

PostPosted: Thu 06 Jun 2019, 17:55    Post subject:  Regarding HP Notebook that wont boot from USB
Subject description: .. and which puppy to use
 

I have a HP notebook (Pavilion 17 p180no) with a dying harddrive.
I installed Xenial to a SanDisk Ultra USB 3.0 Flash Drive 32 GB with unetbootin. When I try to boot from it nothing happens. My computer knowledge is poor, and I am new to linux. I have been reading the solutions on installing puppy for Windows 10 (http://murga-linux.com/puppy/viewtopic.php?p=858159#858159) but it just goes way over my head. I am hoping there is an easier way, or simpler step-by-step instructions, perhaps with pictures.
I have tried disabling "Secure Boot", and this "how to make any puppy ISO boot from a pc with UEFI bios" http://www.murga-linux.com/puppy/viewtopic.php?t=109702, but with no luck. The CD-tray automatically ejects when I start the computer, so I assume there is something wrong with it as well. Tried disabling booting from cd, but there was no change; nothing happens when I attempt to boot from USB (and the cd-tray still ejects on start).
Further, I hope someone can recommend which puppy I should use. I only chose Xenial because it appeared to be the newest. I intend to use the computer for surf, youtube, netflix.
Here are the specifications for my computer:
Processor: AMD E1-6010 1.35 GHz
Memory: 4 GB DDR3 RAM
Graphic card: AMD Radeon R2
Thanks in advance
Back to top
View user's profile Send private message 
slavvo67

Joined: 12 Oct 2012
Posts: 1600
Location: The other Mr. 305

PostPosted: Thu 06 Jun 2019, 21:45    Post subject:  

Secure boot is sometimes difficult to disable. It seems many brands have different ways to boot to bios and change.

Did you look at the HP guidance to remove secure boot?

https://support.hp.com/us-en/document/c04784866

Also, I don't think a 32 bit version will boot UEFI; will it? You will need a 64 bit.

I'm not sure about the Puppies but you may want to try Fatdog. Those guys are always working on their project and it's quite well done.

You can try a Quirky, where BarryK's instructions for Quirky Xerus (I made an RUXerus branded version but admittedly, most of the work here is Barry's) are quite good. The RUXerus link is below but certainly there are many other options. I just think the Quirky's have pretty easy boot and install to USB options.

http://murga-linux.com/puppy/viewtopic.php?t=106870

I'm also guessing that Slacko has a good version though I haven't visited it in a while.

Whichever you choose, I'm pretty sure 64bit is a must. If you're running Windows 10, your pc is most likely 64bit. Be a little patient - you'll get it. I'm sure others will chime in here, too....

Best,

Slavvo67
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 12208
Location: S.C. USA

PostPosted: Thu 06 Jun 2019, 21:54    Post subject:  

32 or 64 bit should not matter with Xenialpup 7.5

Are you actually telling the computer to boot from the USB drive?

Quote:
Opening the Startup Menu during system startup

Follow these steps to open the Startup menu.

Turn on the computer.
Immediately press the Escape key repeatedly, about once every second, until the Startup Menu opens.
(Can try just press and hold escape key until startup menu pops up)


Press F9 key to access the boot device options.
This should be a list of devices to boot from.
Select to boot from the Xenial USB drive.
c04121931.jpg
 Description   
 Filesize   48.48 KB
 Viewed   107 Time(s)

c04121931.jpg


_________________
The things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
YaPI(any iso installer) http://www.murga-linux.com/puppy/viewtopic.php?t=107601
Back to top
View user's profile Send private message 
ozsouth

Joined: 01 Jan 2010
Posts: 517
Location: S.E Australia

PostPosted: Fri 07 Jun 2019, 00:44    Post subject:  

Good advice above. I recently tried an HP E2-9000E with Radeon 2. Booted to a black screen & had to edit kernel append line to end with radeon.modeset=0
Back to top
View user's profile Send private message 
puppyhp

Joined: 06 Jun 2019
Posts: 2

PostPosted: Wed 12 Jun 2019, 16:31    Post subject:  

Thank you all for responding. I was not able to solve it within "bios settings", but there was a simple solution; pressing esc and then f9 for "change boot order" did it. However, new problems have presented themselves.

Xenialpup64 7.5 - Linux 4.9.58 [x86_64]
Waiting for USB storage.....
Finding puppy main sfs file.
Dumping last lines of /tmp/bootinit.log...
MENU_MAX_PUPSAVES=
4: ONE_PART=sda5
MENU_MAX_PUPSAVES=
6: ONE_PART=sda5 ONE_TRY_FN=/puppy_xenialpup64_7.5.sfs PDRV=
Dumping last lines of kernel log...
blk_update_request: I/0 error, dev sda, sector 796758
Buffer I/0 error on dev sda3, logical block 86, async page read
ata1: EH complete
FAT-fs (sda1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.
*** sda5 /puppy_xenialpup64_7.5.sfs not found.
*** Error is too critical, dropping out to console...
star star star To save debug info to a partition, type 'debugsave' (I didnt)

Earlier in my attempts to boot puppy I tried this way, http://www.murga-linux.com/puppy/viewtopic.php?p=973006#973006, that involved copying edited files to the USB. I made copies of the original files, which when the new ones didnt make any difference, I copied back. But perhaps that is not the same as installing with unetbootin? I was careful to unmount the USB drive before removing it, so I am guessing it has something to do with this.

The same thing that has happened to the computer I am attempting to boot puppy on, the harddrive failing, has now happened with the computer I used to create the puppy USB. I no longer have access to a computer that can read USB 3.0 unless I buy I new one. Is there any way I can repair the USB on my laptop?

Any help is greatly appreciated
Back to top
View user's profile Send private message 
mikeslr


Joined: 16 Jun 2008
Posts: 3157
Location: 500 seconds from Sol

PostPosted: Wed 12 Jun 2019, 19:39    Post subject:  

Hi puppyhp,

The Pavilion 17 p180no appears to be a 64-bit computer with Windows 10 Home Edition installed if it corresponds to these specs, https://support.hp.com/us-en/document/c04946377. The most significant part being that it almost certainly uses the UEFI device to boot.

I don't know how you used Unetbootin to install Xenialpup to the USB-Stick. Nor how accurate Unetbootin may be when it comes to installing Puppies. "*** sda5 /puppy_xenialpup64_7.5.sfs not found" suggests that Unetbootin did not properly write the file. But rather than attempting to unravel those mysteries, let me suggest that 'start from scratch' with the application designed to run under Windows to install Puppies to a USB-Key and function under computers employing the UEFI boot device: LICK. You can find it here, http://murga-linux.com/puppy/viewtopic.php?p=462720#462720.

When you run it, select your USB-Key as the location to install both LICK and your Puppy.

As bigpup pointed out, your can use either a 32 or 64 bit operating system. There being no reason not to take advantage of the 64 bit architecture your computer has, I suggest --if you have not already done so-- that you download Xenialpup64 from either of the links provided here, http://murga-linux.com/puppy/viewtopic.php?p=910078#910078 and store it someplace where you can find it while running LICK.

As you may already know, even with LICK you will have to turn off Fast-Boot, which is Windows' speak for hibernate. A hibernating system is not really turned off. Consequently, no other system can be booted into.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [6 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0372s ][ Queries: 13 (0.0087s) ][ GZIP on ]