Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 16 Oct 2019, 21:03
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking » Dialup
Can't get Conexant SoftK 56 PCI modem to connect
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [10 Posts]  
Author Message

Joined: 26 Feb 2007
Posts: 380

PostPosted: Fri 09 Mar 2007, 04:45    Post subject:  Can't get Conexant SoftK 56 PCI modem to connect  

I have two HDDs. Hda has Win98SE and hdb has Puppy. The modem works fine in Windows and is on COM 2. I tried the Modem Wizard and went through all the selections and it failed to find the modem. Then saved the first two settings and tried PAP and CHAP and still it wouldn't connect. Anyone know what I'm doing wrong? Thanks.
Back to top
View user's profile Send private message 

Joined: 07 Apr 2006
Posts: 176

PostPosted: Fri 09 Mar 2007, 15:26    Post subject:  

What kind of modem?

Look in the Windows Control Panel under Modems or download and run scanmodem, do a search.

Then read the sticky post at the top of the fourm.

We can't help now other than to say the modem wizard wont detect about half of the modems out there.
Back to top
View user's profile Send private message 

Joined: 26 Feb 2007
Posts: 380

PostPosted: Fri 09 Mar 2007, 17:23    Post subject:  

It's a Conexant SoftK 56 PCI modem. Is this a winsoft modem? If so, how do I configure Puppy to run it?

I can just replace it with a real hardware modem. What would be a good one for Puppy and Linux? Thanks.
Back to top
View user's profile Send private message 

Joined: 07 Apr 2006
Posts: 176

PostPosted: Fri 09 Mar 2007, 17:55    Post subject:  

Your modem is a HSF winmodem (software modem) that requires a driver the cost 20.00 dollars U.S. to work at 56K. A free driver is available but is limited to a max speed of 14.4K which is useless.

Your only solution to use this modem with Puppy is to use a version with a 2.4*** kernel like Puppy 1.09CE. If you want to use any 2*** version of Puppy you will need to pay www.linuxant.com 20 bucks. There is a hack which no longer works with Puppy so dont waist your time there.

There is a dot.pop by Jcoder for the HCF/HSF modem driver for the 1*** Puppys like 1.09CE.

IMO, use the external hardware modem. Search to forum for hardware modems that work with Puppy. As long as it IS NOT a USB modem it should work. USB modems also rely on software and are not true hardware modems.

I hope this helps.
Back to top
View user's profile Send private message 

Joined: 26 Feb 2007
Posts: 380

PostPosted: Fri 09 Mar 2007, 18:38    Post subject:  

Seems most of the external modems attach via USB. What about replacing the winmodem with a regular internal PCI one. They're's a boatload of them on eBay for very little money? Thanks.
Back to top
View user's profile Send private message 

Joined: 07 Apr 2006
Posts: 176

PostPosted: Fri 09 Mar 2007, 19:18    Post subject:  

A lot of USB modems work with linux. A lot of PCI modems work. You just got the odd ball. I have the same odd ball in my laptop with 1.09CE.

I'm using a home PC now with the standard PCI ltmodem that came with it. They cost less than 10 bucks US. However I can't think of a single small linux distro smaller than 100mb except Puppy that will detect it. Ubuntu at 698mb wouldn't even detect it. Mepis (sp) does. This is a main reason I love Puppy, winmodem support is great. Very Happy

I would search this forum for the pages that talk about what modems work with Puppy first. You are overlooking many pages already posted that can help your problem. Dont buy a modem that only has Windows drivers. Search Google for PCI modems with linux support if you have to but everything you need has already been posted here.

I wont buy a modem on Ebay.

Welcome to Puppy.
Back to top
View user's profile Send private message 

Joined: 20 Jan 2006
Posts: 6756
Location: hobart

PostPosted: Fri 09 Mar 2007, 19:56    Post subject:  


two places for you to browse are:

http://puppylinux.org/wikka/ModemPageWorking and:

(also if you find one that works well, please add it to the wikka list as it's a bit bare)
Back to top
View user's profile Send private message 

Joined: 17 Nov 2006
Posts: 298

PostPosted: Mon 26 Mar 2007, 01:30    Post subject:  


You say your modem is a - Conexant Softk 56k PCI modem .. Question

You should be aware that there are a number of variations in model types for Conexant Softk 56k PCI modems - so you should also include what "type & model number (& CLASS)" info to this forum as well so we can then give you the needed help .. Idea

You could also try this link - http://www.murga-linux.com/puppy/viewtopic.php?t=14663

to see if the info provided is of any assistance.. Laughing


3 x boot:- ASROCK VIA 'all-in-one' m/b; AMD Duron 1.8Ghz+; 1.0GB RAM; 20GB hdd (WinXP Pro); 80GB hdd (MEPIS 3.4-3/Puppy v2.15CE Frugal); 1GB USB pendrive (Puppy 2.15CE Frugal); CD/DVDRW; 17" LCD monitor; HSF 56k modem... MEPIS is great.. Puppy ROCKS..
Back to top
View user's profile Send private message 

Joined: 26 Feb 2007
Posts: 380

PostPosted: Mon 26 Mar 2007, 05:14    Post subject:  

I gave up on the winmodem and bought an external U.S. Robotics modem that was on the "works" list. Now I'm having problems getting that to work just in Windows. Linux seems to have a lot of problems with modems and getting connected. Strange.
Back to top
View user's profile Send private message 

Joined: 09 Nov 2005
Posts: 417

PostPosted: Wed 28 Mar 2007, 15:35    Post subject: I have a USR 56k external serial modem.  

If you bought the same one I did. Then you found out they did not supply the serial port cable in the box. ha ha. One on me.

Hate to ask about what you surely already know. You did buy the external modem that goes on the serial port. Not the one that goes on the USB port?

I am perplexed about Windows having a problem with an external serial port modem. For me. I plug it into the computer. One must use a screw driver to fully screw in the cable to the serial port. Else it will not seat well enough to work. Something about the way the cable end is designed. I turn on the modem. I reboot the computer. Windows finds the Modem. Then installs the drivers for the modem.

What I have found out about the process. The modem came with a CD. Mostly this seems like Spyware which they want to add to an already overburdened Windows. The actual .inf that comes with this thing might be better than what Windows installs. I dunno. If one goes to the US Robotics site one can get some programs to flash the Modem with some upgrades. Like one for v.92 Then I find out my ISP never would use this protocol anyway. So. Probably not doing any of that is necessary. Windows will find and install a usable - working driver.

In Windows. Must set the options to use the External Serial Modem in different places to use it. I must go into Control Panel/Modems and choose the external serial modem to use, in place of the usual Modem. Then I must go into my Windows dialer, for my ISP, and choose the external serial modem there as well. Sometimes this information can get lost on reboot. So I have to reset the pointers to the modem I want to use, again.

In Puppy Linux. My Serial Modem is ttyS0. Which I can choose and save even if the Modem Wizard does not find it.

Now the part that gives me confusion. I have a workaround that I use. My workaround is surely not the right way to do this. However.

I change the serial port speed down. In doing this I prefer to use the GnomePPP dialup modem program. These must be downloaded and installed. Since your Puppy is offline. This is a manual operation.


You will need these two packages..



One wvdial comes installed. What you will need is the other one. I can not easily look to see which version comes preinstalled right now while I am online.

To repeat the obviousl. One puts them someplace on your computer and while running Puppy you click on gnome_ppp-0.3.23.pet.

When it installs it will ask for the wvdial it wants as a dependency. You point over to where you already have it saved. It will install that. When you reboot it will install the GnomePPP modem dialup into the start menu. Menu/Network/GnomePPP modem dialup.

What I like about this program is several things. I do not have to run the Modem Wizard. This program will find the Modem on its own. I do not have to choose the protocol. PAP, CHAP, CHAT. This program has a feature to easily set the serial port speed. In the button setup I see a bunch of speeds. Usually this thing tries to start at 115200.

From experience I know that if I let it try to connect at this speed of 115200. It might seem to connect. The connection dies the first time I ask it do anything. (go to a web address), I use 57600. As the guru told me. I probably should instead use a different init string and leave the port speed alone. I do not know. I am not completely sure what the init string should be. (and the US Robotics web site is not helpful in getting me this information. They do offer an .inf for Windows. Which if I knew how to interpret might help.) In any case. Adding init strings with the dialers now in Puppy is not possible. That is. Specifically. I can not change the first init string. I can change the second init string in the dialers.

To change the port speed in Gkdial. From a previous post.

PostPosted: Fri Feb 23, 2007 8:53 pm Post subject: Eureka. (I hope). Reply with quote Edit/Delete this post
To speak on with this Modem dialer problem. I just found this note from the technical support from a local ISP. (on connecting with dial up Modems.)

(Warning: Do not force a connect rate that is higher than your normal connect rate. When your modem makes an initial connection, it will determine that the lines cannot handle that speed, and immediately hang up.)

Now looking to find out about Gkdial:

I look in: /etc/ppp/chatscripts

there is a txt file that describes my connection with Gkdial.

I find that my modem speed has been set too high: 115200

connect "/usr/sbin/chat -v -f /etc/ppp/chatscripts/house"
user circle

I manually edit the speed down to 56800 and I can log in. However the speed is way too slow. I reset the value to 38400 and the speed to download a web page is nearly OK. (house is the name I choose for my connection.)

I took a peek at Wvdial and it has the same problem with setting the speed too high. However I have not tested it.

I see should not try to manually edit the file for Wvdial. And that is right. It hangs the computer. ha ha ha ha.

When editing the speed. Be sure to use one of the standard port speeds.


These numbers from the GnomePPP dialer options. If you use a randomly chosen number. Seems if you get on. The speed of connection is dead slow.

Related postings.



linux hardware incompatibilty list

There can be some strange issues with telephone lines. A long telephone line. Like from the wall plug in the next room to the Modem
can make the connection run slow. I have an electric heater which seems to effect my modem, and keep me from logging on before the power loss effects any other part of the computer. Obviously telephone wires can be damaged in some way. Which is why US Robotics includes a telephone line and tells the user to use their wire from the wall to the modem. I used to have a friend whose modem had issues with a caller ID box. He had to unplug the caller ID box to get his modem to work. Obviously modems have problems with the click click or whatever from a message service. At least once in our lives. Everyone must plug the telephone line into the wrong hole in the modem. The markings are on the bottom of the modem to show where the wires go.

I hope some part of this helps with your problem.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [10 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Networking » Dialup
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0666s ][ Queries: 12 (0.0218s) ][ GZIP on ]