Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 18 Aug 2019, 06:54
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
Need Money ManagerEx for BionicPup32-8.0
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [7 Posts]  
Author Message
tosim

Joined: 19 Nov 2015
Posts: 42

PostPosted: Fri 14 Jun 2019, 13:21    Post subject:  Need Money ManagerEx for BionicPup32-8.0  

Been running BionicPup32-8.0+6(also the 64b since it came out), and the only other app I urgently could use is "Money ManagerEx". No matter how many times I've d/l it and tried installing, it never works. I've even tried(using package manager) installing snapd, and d/l the snap, still no go.
BTW-am using the full install of Bionic Pups. Any help will be greatly appreciated. Thank you.
Back to top
View user's profile Send private message 
mikeslr


Joined: 16 Jun 2008
Posts: 3270
Location: 500 seconds from Sol

PostPosted: Fri 14 Jun 2019, 14:12    Post subject:  

Hi tosim,

I looked at what the Money Manager Ex site had to offer, https://www.moneymanagerex.org/download. The only Linux version was built for Arch Linux, https://www.archlinux.org/packages/community/x86_64/moneymanagerex/ and required the installations of dependencies noted on the above page. Building a Puppy version seem both time-consuming and "iffy" -- often dependencies have dependencies and so on infinitum; and searching for them isn't always successful.

As I have Wine setup, I figured success or failure of the Windows portable version, https://sourceforge.net/projects/moneymanagerex/files/v1.3.3/mmex_1.3.3_win32_portable.zip/download, could be ascertained in a matter of minutes. It was, and apparently successfully. That is, after unpacking the zip file, clicking MoneyManagerEx/bin/mmex.exe opened what seemed to be a functioning application. That's as far a I got as I wouldn't know how to use it and wouldn't know how to test it. But my experience with portable windows programs is that if they can be opened under Wine they usually run flawlessly.

Obviously, to use any Windows version you'll need Wine. To run it under a 64-bit Puppy (mine is Xenialpup64 --but Wine usually doesn't care which Puppy it runs under except) you'll need Bionicpup64's 32-bit compatibility SFS. Ask if you need help with either.

There are also Window 64-bit versions. But I've yet to get Wine64 to function.

When there's a choice between "installable" and "portable", choose the latter. Designed not to have to write to "windows' registry" they are more likely to function under Wine. And, if they don't, it's easy to get rid of them: just delete their folder. Files and registry items used by other Windows applications are unaffected.
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 12442
Location: S.C. USA

PostPosted: Fri 14 Jun 2019, 16:01    Post subject:  

To use and install Wine.

Make sure you have the latest version of Wine.
Good place to get Wine for Puppy.
http://murga-linux.com/puppy/viewtopic.php?t=88711
The pet packages listed will work in most Puppy versions.
They are compiled in Racy, other Puppy versions, but not made just for them.
They are universal pet packages, usable in all Puppy versions.

Also, look on the first post of the Wine topic for a added program that puts Wine entries in the menu.

When you get Wine installed and the Wine menu entries.
Run Wine config to setup Wine.
It will probably offer you a few more programs needed for Wine to run properly.
Should download and install them as part of the initial config.

Also, in Wine config->Drivers Select autodetect to get all the driver locations loaded in Wine.

A lot of settup options in Wine config, so check them all.

What version of Windows you want Wine to mimic can affect how a program runs. Wine Config->Applications.

About specific programs running in Wine.
Go to the Wine web site and see what it says about a specific program and issues.
http://www.winehq.org

Using Wine is almost like learning a new operating system.
Takes a while to learn how to use Wine and to get things working properly.

_________________
The things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
YaPI(any iso installer) http://www.murga-linux.com/puppy/viewtopic.php?t=107601
Back to top
View user's profile Send private message 
tosim

Joined: 19 Nov 2015
Posts: 42

PostPosted: Sat 15 Jun 2019, 09:25    Post subject: MMEX install  

Thank you both so very, very much for your very helpful replies. I will (attempt to) do the installation sometime next week, when I get released from hospital. Again, many, many, thanks to you both.
Back to top
View user's profile Send private message 
poopup

Joined: 30 Jun 2019
Posts: 1

PostPosted: Sun 30 Jun 2019, 01:37    Post subject:  

Hi, I've tried both 32bit and 64bit installer and portable edition; none of them worked. When I tried to load the 32bit Compatibility sfs it gave me "fatal: Failed to append '/initrd/pup_ro3' to unionfs".
I downloaded and installed mmex binary package from this link https://packagecloud.io/moneymanagerex/moneymanagerex/packages/ubuntu/bionic/mmex_1.4.0-alpha.7-1~bionic_amd64.deb. They have listed the required dependencies for mmex to work. I used PPM to install those and now mmex works on my puppy. Hope it will work for you.
Back to top
View user's profile Send private message 
tosim

Joined: 19 Nov 2015
Posts: 42

PostPosted: Sun 11 Aug 2019, 12:03    Post subject: MoneyMgrEx  

"I downloaded and installed mmex binary package from this link https://packagecloud.io/moneymanagerex/moneymanagerex/packages/ubuntu/bionic/mmex_1.4.0-alpha.7-1~bionic_amd64.deb. They have listed the required dependencies for mmex to work. I used PPM to install those and now mmex works on my puppy. Hope it will work for you.[/quote]

You dl'd the 64b debi;and it is running in: BionicPup32?, or BionicPup64??????
Back to top
View user's profile Send private message 
Semme


Joined: 07 Aug 2011
Posts: 8015
Location: World_Hub

PostPosted: Sun 11 Aug 2019, 19:58    Post subject:    

Tosim, you need to re-read poopup's post. 32b systems "cannot" run 64b applications.
Quote:
I downloaded and installed the mmex binary package >> mmex_1.4.0-alpha.7-1~bionic_amd64.deb

_________________
>>> Living with the immediacy of death helps you sort out your priorities. It helps you live a life less trivial <<<
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [7 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0512s ][ Queries: 12 (0.0165s) ][ GZIP on ]