Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 16 Jul 2019, 07:00
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
DPupBuster-7.9.0.2 published 17 Feb 2019
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 15 of 15 [222 Posts]   Goto page: Previous 1, 2, 3, ..., 13, 14, 15
Author Message
watchdog

Joined: 28 Sep 2012
Posts: 1842
Location: Italy

PostPosted: Wed 10 Jul 2019, 23:19    Post subject: Dpupbuster 64 bit  

In my install xarchive is not properly working. Click tar.bz2 archive, Select All, Extract, Choose destination and it closes.

In console:

Code:
(xarchive:17849): GLib-GObject-WARNING **: 05:56:38.739: Two different plugins tried to register


There is a glib problem. The same warning-error makes to segfault puppyphone.
Back to top
View user's profile Send private message 
josejp2424


Joined: 01 Aug 2010
Posts: 433

PostPosted: Thu 11 Jul 2019, 12:55    Post subject: Re: Dpupbuster 64 bit  

watchdog wrote:
In my install xarchive is not properly working. Click tar.bz2 archive, Select All, Extract, Choose destination and it closes.

In console:

Code:
(xarchive:17849): GLib-GObject-WARNING **: 05:56:38.739: Two different plugins tried to register


There is a glib problem. The same warning-error makes to segfault puppyphone.


Hello Watchdog
the xarchive is working well for me

did you test puppyphone-1.41-x86_64?

http://distro.ibiblio.org/puppylinux/pet_packages-bionic64/puppyphone-1.41-x86_64.pet

_________________
Shiba Inu | Pupjibaro jessie | My Blog
Back to top
View user's profile Send private message Visit poster's website 
watchdog

Joined: 28 Sep 2012
Posts: 1842
Location: Italy

PostPosted: Thu 11 Jul 2019, 13:19    Post subject: Re: Dpupbuster 64 bit  

josejp2424 wrote:


Hello Watchdog
the xarchive is working well for me


That's odd! Something hardware related?

Quote:
did you test puppyphone-1.41-x86_64?

http://distro.ibiblio.org/puppylinux/pet_packages-bionic64/puppyphone-1.41-x86_64.pet


Yes, I did. It segfaults on my hardware. I'll continue to test.

EDIT: you are right! Puppyphone and xarchive work in a live session. Something I installed in my savefile has corrupted it.
I'll try to uninstall something and see what corrupts the savefile.

EDIT1: xarchive and puppyphone work for me only in a live session. As you install anything they do not work anymore. In a first attempt I installed only guvcview: the operation corrupted the savefile. In a second attempt I installed only the printer: the operation has corrupted the savefile, too. I give up.
Back to top
View user's profile Send private message 
josejp2424


Joined: 01 Aug 2010
Posts: 433

PostPosted: Thu 11 Jul 2019, 16:41    Post subject: Re: Dpupbuster 64 bit  

watchdog wrote:
josejp2424 wrote:


Hello Watchdog
the xarchive is working well for me


That's odd! Something hardware related?

Quote:
did you test puppyphone-1.41-x86_64?

http://distro.ibiblio.org/puppylinux/pet_packages-bionic64/puppyphone-1.41-x86_64.pet


Yes, I did. It segfaults on my hardware. I'll continue to test.

EDIT: you are right! Puppyphone and xarchive work in a live session. Something I installed in my savefile has corrupted it.
I'll try to uninstall something and see what corrupts the savefile.

EDIT1: xarchive and puppyphone work for me only in a live session. As you install anything they do not work anymore. In a first attempt I installed only guvcview: the operation corrupted the savefile. In a second attempt I installed only the printer: the operation has corrupted the savefile, too. I give up.


If you installed a package by pkg, that's what breaks the system

_________________
Shiba Inu | Pupjibaro jessie | My Blog
Back to top
View user's profile Send private message Visit poster's website 
s243a

Joined: 02 Sep 2014
Posts: 1942

PostPosted: Thu 11 Jul 2019, 16:53    Post subject: Re: Dpupbuster 64 bit  

josejp2424 wrote:
watchdog wrote:
josejp2424 wrote:


Hello Watchdog
the xarchive is working well for me


That's odd! Something hardware related?

Quote:
did you test puppyphone-1.41-x86_64?

http://distro.ibiblio.org/puppylinux/pet_packages-bionic64/puppyphone-1.41-x86_64.pet


Yes, I did. It segfaults on my hardware. I'll continue to test.

EDIT: you are right! Puppyphone and xarchive work in a live session. Something I installed in my savefile has corrupted it.
I'll try to uninstall something and see what corrupts the savefile.

EDIT1: xarchive and puppyphone work for me only in a live session. As you install anything they do not work anymore. In a first attempt I installed only guvcview: the operation corrupted the savefile. In a second attempt I installed only the printer: the operation has corrupted the savefile, too. I give up.


If you installed a package by pkg, that's what breaks the system


In which case maybe the installation of libc6 needs to be blocked.

_________________
Find me on minds and on pearltrees.
Back to top
View user's profile Send private message Visit poster's website 
artsown

Joined: 12 Sep 2012
Posts: 341

PostPosted: Fri 12 Jul 2019, 09:44    Post subject:  

Working with the 64 bit version on a Dell Optiplex 3010 having i5 3470 and
4 gig ram. Besides Firefox, I've installed several of my favorite applications.
All worked. However, my Canon printer-scanner would not install. Now, in
a different context, s243a mentioned blocking libc6. In frustration, I decided
to do something nutty and remove both libc6 and libc6-i386. To my
surprise, the printer then installed and worked. The only negative effect
I've noticed after removing libc6 is after a fresh boot. When I try PPM
the first time it just sits there saying it's starting. I kill X and restart it,
then PPM runs. Note that I cannot get into printer installation via the menu.
I use http://localhost:631/admin in Firefox.

I hope this "nutty" experiment provides a useful clue. I'll also include here
a snapshot of the errors PPM reports while doing a update:

http://home.ptd.net/~artnpeg/ppm_errors.png

Art
Back to top
View user's profile Send private message 
josejp2424


Joined: 01 Aug 2010
Posts: 433

PostPosted: Fri 12 Jul 2019, 15:05    Post subject: Re: Dpupbuster 64 bit  

s243a wrote:
josejp2424 wrote:
watchdog wrote:
josejp2424 wrote:


Hello Watchdog
the xarchive is working well for me


That's odd! Something hardware related?

Quote:
did you test puppyphone-1.41-x86_64?

http://distro.ibiblio.org/puppylinux/pet_packages-bionic64/puppyphone-1.41-x86_64.pet


Yes, I did. It segfaults on my hardware. I'll continue to test.

EDIT: you are right! Puppyphone and xarchive work in a live session. Something I installed in my savefile has corrupted it.
I'll try to uninstall something and see what corrupts the savefile.

EDIT1: xarchive and puppyphone work for me only in a live session. As you install anything they do not work anymore. In a first attempt I installed only guvcview: the operation corrupted the savefile. In a second attempt I installed only the printer: the operation has corrupted the savefile, too. I give up.


If you installed a package by pkg, that's what breaks the system


In which case maybe the installation of libc6 needs to be blocked.


s243a

pkg eliminates the symbolic links / usr / lib / x86_64-linux-gnu, causes the system to fail

_________________
Shiba Inu | Pupjibaro jessie | My Blog
Back to top
View user's profile Send private message Visit poster's website 
josejp2424


Joined: 01 Aug 2010
Posts: 433

PostPosted: Fri 12 Jul 2019, 15:10    Post subject: DpupBuster 64
Subject description: Dpupbuster 64
 

new iso corrected several bug.

dpupbuster64_7.9.0.2-Alpha4-12072019.iso. .


DELTA dpupbuster64_7.9.0.2-Alpha4. .

_________________
Shiba Inu | Pupjibaro jessie | My Blog
Back to top
View user's profile Send private message Visit poster's website 
josejp2424


Joined: 01 Aug 2010
Posts: 433

PostPosted: Fri 12 Jul 2019, 15:28    Post subject: Pkg
Subject description: Pkg
 

pkg seems to be working well now
_________________
Shiba Inu | Pupjibaro jessie | My Blog
Back to top
View user's profile Send private message Visit poster's website 
watchdog

Joined: 28 Sep 2012
Posts: 1842
Location: Italy

PostPosted: Sat 13 Jul 2019, 00:56    Post subject: dpupbuster64  

The solution to the this pup woes' is to natively compile glib.

http://gtk.10911.n7.nabble.com/Need-help-with-Two-different-plugins-tried-to-register-warnings-with-gio-modules-td60977.html

I downloaded:

http://deb.debian.org/debian/pool/main/g/glib2.0/glib2.0_2.58.3.orig.tar.xz

Untar the archive. Click autogen.sh and wait. Then:

Code:
./configure --prefix=/usr
make
make install


Installwatch for new2dir is missing in this pup so I can't share my compilation. Puppyphone and Xarchive are now working.
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1842
Location: Italy

PostPosted: Sat 13 Jul 2019, 01:28    Post subject:  

I made a pet of installwatch from bionicpup64:

https://drive.google.com/file/d/1A_Bs3eYH_K-yLiAy_ujIaDTUgmh1M0Ot/view?usp=sharing

These are my glib packages:

https://drive.google.com/file/d/1RmsyZePdOk1d8Z-28BjLAmhaVSJjPR2w/view?usp=sharing

https://drive.google.com/file/d/1JWAZ9K7bRl97BYeNiWLhNn8hYWKs-8Up/view?usp=sharing

https://drive.google.com/file/d/1kgkfczzJ3zlj1cCVcmidcNYG1AmsJOpQ/view?usp=sharing
Back to top
View user's profile Send private message 
artsown

Joined: 12 Sep 2012
Posts: 341

PostPosted: Sat 13 Jul 2019, 07:46    Post subject:  

Concerning the 64 bit alpha 4 ... PPM no longer reports error messages
during updates.

1. Installed getflash via PPM. It takes a exceptionally long time (about
three minutes) to respond.
2. Setting 12 hour clock has no effect. It's stuck on 24 hrs.
3. CUPS still not working.

Art
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 15 of 15 [222 Posts]   Goto page: Previous 1, 2, 3, ..., 13, 14, 15
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0525s ][ Queries: 13 (0.0034s) ][ GZIP on ]