(OLD) (ARCHIVED) Puppy Linux Discussion Forum Forum Index (OLD) (ARCHIVED) Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info

This forum can also be accessed as http://oldforum.puppylinux.com
It is now read-only and serves only as archives.

Please register over the NEW forum
https://forum.puppylinux.com
and continue your work there. Thank you.

 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups    
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 01 Oct 2020, 01:55
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Unable to Get Virtualbox Running - XenialPup64v7.5 (Solved)
Moderators: Flash, Ian, JohnMurga
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
Page 1 of 1 [6 Posts]  
Author Message
MrDuckGuy


Joined: 31 Jan 2019
Posts: 159
Location: Hermosa Beach, CA, USA

PostPosted: Thu 13 Feb 2020, 21:10    Post subject:  Unable to Get Virtualbox Running - XenialPup64v7.5 (Solved)  

*** SCROLL TO BOTTOM FOR SOLUTION ***

I downloaded the latest version for
Debian 10 (v6.1.2).
The popup says to install both devx
and kernal sources for the first run,
from quickpet. So I installed devx and
kernal_sources-4.9.58 (the highest
version).

When I ran the rcvboxdrv setup, the
output says:
failed: Cannot change group vboxusers for
device /dev/vboxdrv.


Screenshots below:

System information:
** OS: Linux 4.9.58 x86_64
** Distro: xenialpup64 7.5
** Window Manager: JWM v2.3.7
** Desktop Start: xwin jwm
** CPU: 4 x Intel(R) Core(TM) i5-2500 CPU @ 3.30GHz (GenuineIntel) @ 2.09GHz
** RAM: Physical: 11.6GiB, 89.8% free
** Disk: Total: 13.6GiB, 68.1% free
** VGA: 8086:0102
** Sound: HDA-Intel - HDA Intel PCH1: PC-Speaker - pcsp
** Ethernet: 8086:1502 *

Thanks in advance.
2020-02-13-1427-22_Screenshot00.png
 Description   Virtualbox website screen showing version selection.
 Filesize   73.98 KB
 Viewed   152 Time(s)

2020-02-13-1427-22_Screenshot00.png

2020-02-13-1617-11_Screenshot.png
 Description   Puppy instruction popup showing installation procedure.
 Filesize   13.17 KB
 Viewed   151 Time(s)

2020-02-13-1617-11_Screenshot.png

2020-02-13-1541-45_Screenshot00.png
 Description   SFS Downloader file manager showing devx and kernal sources downloads
 Filesize   26.25 KB
 Viewed   153 Time(s)

2020-02-13-1541-45_Screenshot00.png

2020-02-13-1640-13_Screenshot00.png
 Description   Terminal output showing failed installation error messages.
 Filesize   172.42 KB
 Viewed   155 Time(s)

2020-02-13-1640-13_Screenshot00.png


Last edited by MrDuckGuy on Fri 14 Feb 2020, 19:03; edited 2 times in total
Back to top
View user's profile Send private message 
perdido


Joined: 09 Dec 2013
Posts: 1601
Location: ¿Altair IV , Just north of Eeyore Junction.?

PostPosted: Thu 13 Feb 2020, 21:22    Post subject:  

Might be helpful, seems to be a work-around for a similar issue.

http://murga-linux.com/puppy/viewtopic.php?t=114256
Back to top
View user's profile Send private message 
MrDuckGuy


Joined: 31 Jan 2019
Posts: 159
Location: Hermosa Beach, CA, USA

PostPosted: Thu 13 Feb 2020, 22:19    Post subject:  

perdido wrote:
... a work-around for a similar issue.
http://murga-linux.com/puppy/viewtopic.php?t=114256 ...

Thanks.
I had done everything on the list except:
4. Edit your /etc/group file to add the following line:
"vboxusers::1001:root,spot,fido"

Unlike the other user, I have not succeeded
in any GUI running yet. Still the advice is
helpful.

So, the error messages have not appeared.
However when I click on VM Virtualbox in the
menu, nothing happens.

Tried running from a terminal window.
The outputs say I'm missing some
required files.

1) Error output states: libQt5Core.so.5 is missing.
2) Error output states: /lib64/libc.so.6: version `GLIBC_2.28' not found.


Screenshots below.
2020-02-13-1802-30_Screenshot00.png
 Description   No more installation errors.
 Filesize   82.13 KB
 Viewed   134 Time(s)

2020-02-13-1802-30_Screenshot00.png

2020-02-13-1750-22_Screenshot00.png
 Description   Error output states: /lib64/libc.so.6: version `GLIBC_2.28' not found.
 Filesize   40.07 KB
 Viewed   139 Time(s)

2020-02-13-1750-22_Screenshot00.png

2020-02-13-1752-02_Screenshot00.png
 Description   Error output states: libQt5Core.so.5 is missing.
 Filesize   41.5 KB
 Viewed   139 Time(s)

2020-02-13-1752-02_Screenshot00.png

Back to top
View user's profile Send private message 
p310don

Joined: 19 May 2009
Posts: 1502
Location: Brisbane, Australia

PostPosted: Fri 14 Feb 2020, 01:34    Post subject:  

I always recommend downloading virtualbox from virtualbox.

https://www.virtualbox.org/wiki/Downloads

Get this file:

https://download.virtualbox.org/virtualbox/6.1.2/VirtualBox-6.1.2-135662-Linux_amd64.run

Download the .run file, make it executable and run it
Back to top
View user's profile Send private message 
OscarTalks


Joined: 05 Feb 2012
Posts: 2202
Location: London, England

PostPosted: Fri 14 Feb 2020, 07:19    Post subject:  

Downloading the virtualbox which has been compiled for Debian 10 is a mistake if you are trying to run it in XenialPup64. That is why you are getting the error about your libc.so.6 version being too old. Try the Ubuntu 16.04 (Xenial) version instead, or try using the .run installer package as suggested.
The error about libQt5Core is just telling you that you need to install Qt5 libraries which are not included in XenialPup. You can probably do this via PPM.

_________________
Oscar in England

Back to top
View user's profile Send private message 
MrDuckGuy


Joined: 31 Jan 2019
Posts: 159
Location: Hermosa Beach, CA, USA

PostPosted: Fri 14 Feb 2020, 18:15    Post subject:  

OscarTalks wrote:
Downloading the virtualbox which has been compiled
for Debian 10 is a mistake ... in XenialPup64. ...
Thanks!

Quote:
Try the Ubuntu 16.04 (Xenial) version instead, or try using the
.run installer package as suggested.
Sounds easy enough.

Quote:
The error about libQt5Core is just telling you that you need to
install Qt5 libraries which are not included in XenialPup.
You can probably do this via PPM.
This seems simplest, since
I'm either doing this or uninstalling
everything I've worked on up to now.
I'm trying this now.

UPDATE: installed these, but it's not happening.
I'm uninstalling and trying the other suggestions.


UPDATE II: installed suggested version from the
correct website, and the program is running, it
seems! Thanks to all for the help!
2020-02-14-1516-44_Screenshot.png
 Description   Live CD of Tahrpup64 running inside VirtualBox. Thanks to ALL!!
 Filesize   175.14 KB
 Viewed   72 Time(s)

2020-02-14-1516-44_Screenshot.png

2020-02-14-1456-41_Screenshot.png
 Description   Works from Terminal window!
 Filesize   95.17 KB
 Viewed   80 Time(s)

2020-02-14-1456-41_Screenshot.png

2020-02-14-1450-49_Screenshot.png
 Description   Seems to be working!
 Filesize   160.18 KB
 Viewed   82 Time(s)

2020-02-14-1450-49_Screenshot.png

2020-02-14-1440-09_Screenshot.png
 Description   Downloading from 'OFFICIAL WEBSITE."
 Filesize   62.23 KB
 Viewed   85 Time(s)

2020-02-14-1440-09_Screenshot.png

2020-02-14-1412-53_Screenshot.png
 Description   Found PPM version of Qt5 library.
 Filesize   84.67 KB
 Viewed   91 Time(s)

2020-02-14-1412-53_Screenshot.png

Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [6 Posts]  
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0451s ][ Queries: 13 (0.0087s) ][ GZIP on ]