(OLD) (ARCHIVED) Puppy Linux Discussion Forum Forum Index (OLD) (ARCHIVED) Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info

This forum can also be accessed as http://oldforum.puppylinux.com
It is now read-only and serves only as archives.

Please register over the NEW forum
https://forum.puppylinux.com
and continue your work there. Thank you.

 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups    
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 27 Sep 2020, 11:06
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Drivers
Nvidia drivers
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
Page 13 of 13 [193 Posts]   Goto page: Previous 1, 2, 3, ..., 11, 12, 13
Author Message
foxpup

Joined: 29 Jul 2016
Posts: 1141

PostPosted: Tue 11 Jun 2019, 15:43    Post subject: geforce 6 series  

GTX 660 (Geforce 6 series) seems to be supported by almost any driver! Surprised
Have you found these from shinobar? http://shinobar.server-on.net/puppy/opt/pup64/xenialpup64/
(If you prefer .pet to .sfs you can unsquash the sfs in a directory and use dir2pet on the directory.)

After installation of the nvidia sfs/pet, don't let nvidia set up/configure.
Just reboot immediately.

Before installing the driver make sure nouveau is not loaded and will not be loaded on reboot.
I do this by booting to the prompt with pfix=nox. Then execute
Code:
rmmod nouveau
xwin
You could also blacklist nouveau in Set > Puppy Setup > Startup > Modules.
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 13981
Location: S.C. USA

PostPosted: Tue 11 Jun 2019, 18:29    Post subject:  

Getnvidia program will take care of Unloading the nouveau driver.

It is hard to say what you are doing wrong, but it is something.
Step by step info on what you do is the only way to find out.
Just saying I tried a driver is not giving any useful info on what you may be doing wrong.

Nvidia says you need the 430.26 driver.
https://www.nvidia.com/Download/driverResults.aspx/148435/en-us
However, that is the latest version driver by Nvidia.
The 340 or 383 driver pets, from the Xenialpup repository, should be able to support that old a Nvidia card.
For some reason there are two pets for each driver.
One smaller by half the size of the other.
Make sure to try the larger pet.

You say you are using Xenialpup64 7.5
Sorry, have to ask.
You are not using the Xenialpup 7.5 (32bit)?
You are downloading the correct bit version driver?
Is Xenialpup a full or frugal install?

_________________
The things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
YaPI(any iso installer)
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 13981
Location: S.C. USA

PostPosted: Tue 11 Jun 2019, 18:51    Post subject:  

Jynxd wrote:
Yeah, I used that website, I got the correct driver.

So ,what exact driver?
You think you got the correct one.
We think you may not have.
We need specific details to help you!

We only know what you tell us!!! Shocked

_________________
The things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
YaPI(any iso installer)
Back to top
View user's profile Send private message 
foxpup

Joined: 29 Jul 2016
Posts: 1141

PostPosted: Wed 12 Jun 2019, 04:02    Post subject:  

bigpup wrote:
Getnvidia program will take care of Unloading the nouveau driver.
... unless you do not use getnvidia and just use the prepared sfs or pet or 'run' the nvidia driver package directly.
Back to top
View user's profile Send private message 
Jynxd

Joined: 15 May 2019
Posts: 14

PostPosted: Wed 12 Jun 2019, 11:17    Post subject:  

bigpup wrote:
Jynxd wrote:
Yeah, I used that website, I got the correct driver.

So ,what exact driver?
You think you got the correct one.
We think you may not have.
We need specific details to help you!

We only know what you tell us!!! Shocked


I was answering to dancytron, who linked to nvidia's website to download nvidia's .run linux driver.

bigpup wrote:
Getnvidia program will take care of Unloading the nouveau driver.

It is hard to say what you are doing wrong, but it is something.
Step by step info on what you do is the only way to find out.
Just saying I tried a driver is not giving any useful info on what you may be doing wrong.


The .sfs drivers took care of nouveau too, I didn't have to do it.

foxpup wrote:
GTX 660 (Geforce 6 series) seems to be supported by almost any driver! Surprised
Have you found these from shinobar? http://shinobar.server-on.net/puppy/opt/pup64/xenialpup64/
(If you prefer .pet to .sfs you can unsquash the sfs in a directory and use dir2pet on the directory.)

After installation of the nvidia sfs/pet, don't let nvidia set up/configure.
Just reboot immediately.

Before installing the driver make sure nouveau is not loaded and will not be loaded on reboot.
I do this by booting to the prompt with pfix=nox. Then execute
Code:
rmmod nouveau
xwin
You could also blacklist nouveau in Set > Puppy Setup > Startup > Modules.


Oh yeah! Those two worked, now I can run retroarch and it won't forcibly quit after a few seconds or minutes. I haven't tried it yet, but blender should detect the GPU now and it should let me use GPU acceleration for cycles.

Thanks all!
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 3822
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Tue 24 Mar 2020, 13:21    Post subject: kernel_sources-4.4.70-s32-700_PAE.sfs [SOLVED]  

Bonjour,
Does anyone know where to find the 32 bits 4.4.70 kernel sources to build NVIDIA drivers sfs file using Getnvidia? (I found the 64 bits version but not the 32 bits! Confused )
Thank you for your attention.

Cordialement

EDIT: Arrow For those who would be interested
(Thanks to norgo Wink)

EDIT: Please, see this thread on the French Murga Forum: Arrow GetNVIDIA 1.5.1

Cordialement.

_________________

Puppy Search
Back to top
View user's profile Send private message Visit poster's website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 9400
Location: Perth, Western Australia

PostPosted: Fri 03 Apr 2020, 07:16    Post subject: Re: kernel_sources-4.4.70-s32-700_PAE.sfs [SOLVED]  

Argolance wrote:
EDIT: Please, see this thread on the French Murga Forum: Arrow GetNVIDIA 1.5.1


Thanks for that, the 1.5.1 PET is now in Easy:

https://bkhome.org/news/202004/getnvidia-pet-added-to-easy.html

The help should be fine for EasyPup, but might need some rewording for EasyOS. I think that there was something about shinobar's load-sfs-on-the-fly PET, which won't work in EasyOS. Also, if an SFS is created, it might need some small changes to be compatible with EasyOS -- I will check that out sometime.

_________________
https://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
Argolance


Joined: 06 Jan 2008
Posts: 3822
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Fri 03 Apr 2020, 16:11    Post subject:  

BarryK wrote:
Thanks for that, the 1.5.1 PET is now in Easy

Cheers! Smile

_________________

Puppy Search
Back to top
View user's profile Send private message Visit poster's website 
Lassar

Joined: 08 Jul 2014
Posts: 238

PostPosted: Sun 05 Apr 2020, 11:32    Post subject: lacking module for kernel 4.9.58  

I am using a xenialpup64 from either from wolfce, or a stripped down Xenialpup64 CE 7.5

I tried to install nvidia-glx-304.135-k4.9.15-xenial64.sfs for xenialpup64.

Restarted the x server.

Got this error message

"Nvidia driver is found, but lacking the module for kernel 4.9.58

So what is causing this error?

What can I do to fix this?
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 13981
Location: S.C. USA

PostPosted: Sun 05 Apr 2020, 11:48    Post subject:  

Xenialpup64 7.5 was released with versions using the 4.9.58 kernel or the 4.9.15 kernel.

You have the Xenialpup64 7.5 that is using the 4.9.58 kernel.
The Nvidia driver package has to be for that kernel.
Graphics driver packages, have to be compiled for a specific kernel, and will only work on that kernel.

Try using this pet package
http://distro.ibiblio.org/puppylinux/pet_packages-xenial64/nvidia-340-b_K4.9.58-x86_64.pet

I would advise having graphics drivers install as a pet package, so they are a part of the active file system all the time and for sure at startup.

If you really need the 304 driver.
Install it using this info:
http://www.murga-linux.com/puppy/viewtopic.php?t=110611

_________________
The things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
YaPI(any iso installer)
Back to top
View user's profile Send private message 
hikohan

Joined: 29 Nov 2011
Posts: 32

PostPosted: Mon 06 Apr 2020, 00:30    Post subject: Re: lacking module for kernel 4.9.58  

mount a kernel SFS for that message!
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 13981
Location: S.C. USA

PostPosted: Mon 06 Apr 2020, 11:19    Post subject:  

What is that saying?
A little detail about your answer would help?
What kernel SFS?
What is it going to do?
Why do this and not use the correct driver package, compiled for the specific Linux kernel?

_________________
The things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
YaPI(any iso installer)
Back to top
View user's profile Send private message 
baraka

Joined: 25 Oct 2018
Posts: 8

PostPosted: Sun 05 Jul 2020, 04:41    Post subject: bug
Subject description: xwin failed to restart; getnvidia 1.5 limitation and a limited solution
 

Maybe it is a well known bug with a obvious solution, but for me it wasn't, and for that reason the following post.

Setting: nvidia gt 430; 340.xxx, 384.xxx or 390.xxx x64 driver version; tahr64, xenial64, or beaver64 (default kernels).
Problem: xwin command doesn't restart xserver after logout, more exactly, it will fail at /usr/bin/xinit line.
(reboot, cold start, or suspend to ram works fine.)
Collateral: every script who has a logout-login implementation will crash, ex: xorgwizard, getnvidia.

Bug's presentation:
- total black screen hangs indefinetely and hard reboot is required or
- the (alert) letters in console will be messy, unreadeable, but after 10-15s, the command prompt will be released and "a blind" reboot command will work.

Bug's nature (I think):
- power related issue

Relevant log: "Failed to initialize the NVIDIA GPU at PCI:2:0:0"

Solution: enable GPU persistence mode with the command
Code:
nvidia-smi -pm 1

(add this in your startup folder if you like)

The bug is not particulary interesting-bad (yet, it could be very annoying for some people) if you can get the nvidia driver to install properly,
but it could be a deal breaker with its endless restarts and black screens following the interference with getnvidia script and the like.

I can't fix getnvidia by myself, I have very limited knowledge of how it works, and if someone is willing... much appreciation.

Totally unrelated: using getnvidia multiple times sometimes breaks the symlinks - they'll still refer to the old library number, they don't get updated
with the package version. Again, apart from the plain solution - get them right manually - I can offer nothing else.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 13 of 13 [193 Posts]   Goto page: Previous 1, 2, 3, ..., 11, 12, 13
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Drivers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0912s ][ Queries: 13 (0.0087s) ][ GZIP on ]