Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 27 May 2018, 08:24
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Tantalus used an old IBM Thinkpad 600
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [3 Posts]  
Author Message

PostPosted: Mon 22 Aug 2005, 17:22    Post subject:  Tantalus used an old IBM Thinkpad 600  

Puppy and Thinkpad 600 Issues: This is both an invitation for advice, comment, and, if no workable advice is available, also a warning to anyone else out there who picked up a Thinkpad 600 on the cheap. This may also apply to other older laptops. The big challenge here was not the low-strength processor, or even the tiny hard drive, but the lack of an ethernet jack through which I could use PupGet the way I would have liked, and the great difficulty pinpointing the source of a problem for inexperienced users.

I got this laptop with a 266 mhz PII and a 1.3 gig hard drive for $50, which is about $40 more than I could afford this week. Hell, this month. Anyway:

I'd played around with various LiveCD's, and liked Puppy best, although I had already learned that not everything works out the way you hope (I never did manage a bootable USB drive). But it's a great package if it works for you.

So the first distro I tried on my Thinkpad 600 was Chubby Puppy. It booted, but the screen was absolutely unreadable. I took a stab at hitting some of the other button options, but to no avail. Other boot options? No effect. Regular Puppy, same routine--no luck. I tried Ubuntu LiveCD, which eventually loaded but ran slowly. Still, the screen was at least there. I assumed, therefore, that the problem was that Puppy just didn't have the kind of driver set that Ubuntu had.

I tried some other distributions out there. Most didn't work on the screen. I tried swapping in a 40GB drive I had around, as Ubuntu wouldn't fit on the 1.3 gb drive. Many, like Ubuntu and Fedora, would get most of the way through an install and then tell me they would restart and continue setup. Problem was, when they reset it was as if they forgot the setup ever started before (except for the files copied so far, I assume). There was no way to continue where I left off.

Once I got Ubuntu installed to the hard drive, but then grub bootloader would give me an error message on every boot and freeze the system.

Ultimately, I got exactly three distributions to boot. One was Ubuntu LiveCD, another was DSL, and the third was Blade Hunter's Puppy Package. The original problem, as it turns out, was that I needed a "framebuffer" in place to make the monitor work. Ubuntu ran it automatically; DSL will do so if you boot with the command fb800x600, and Blade's Puppy will default to framebuffer mode.

I knew from the start I needed office software--preferably OpenOffice--on my laptop. Chubby Puppy would have been ideal, but I could have dealt with AbiWord if absolutely necessary. Problem is, Blade's version has pretty much everything office-wise disabled. He seems to have included the install.tar.gz file for OOo 1.9.x, but I couldn't make it work. I tried for about two hours.

I have tried everything--the full-sized OpenOffice.tar.gz file with the tar command from a terminal window, guiTAR program, and PupGet, with and without a hand-crafted .packages.txt file, as well as the stripped-down version several ways, and finally I just tried to get AbiWord to work. I successfully installed AbiWord, at least, but it won't run - it just shows a grey box in the center of the screen for a second. PupGet has a "check for dependencies" button that's supposed to tell you if you need a new component. It reports that AbiWord is fine, but, well, it's not. Something's wrong and I cannot figure it out. I've even repartitioned my drive a few times--no help at all.

The readme files all open in leafpad and show as blank.

What did work for me and my thinkpad 600: If you need basic office software, get DSL and boot it with the fb800x600 option. When it asks you if you want to use some newer video driver with a shorter name or some older, longer-named one, pick the older one. DSL has a word processor and spreadsheet program that will suffice in a pinch.

Or: Get an ethernet card, get a wireless card, get a newer laptop, etc., etc. Actually, a fine alternative for those with a desktop and a burner and time to spend learning, is to figure out Puppy Unleashed and make yourself a LiveCD with framebuffer and anything else you want. Unfortunately, that's not me right now, as I do not have permission to add a partition to the hard drive of "my" WinXP computer, and therefore cannot use PuppyUnleashed.

I expect to be corrected or set straight 8 ways to Sunday. If you could go to the additional trouble of setting me straight in an educational manner, I'd love that.

Lest I be misunderstood--I am impressed with what you all have done, and am aware that it takes real brains and effort. For those among you who have a tendancy to react defensively (and the rest of us all know who you are), let me just say that I am writing this from a frustrated amateur to frustrated amateurs. If I could have read last Friday what I just wrote, I'd have gotten a good deal more sleep this past weekend. I hope it, or better yet, any comments to follow, help someone.


Side question: When a LiveCD distribution gets, say, OOo through PupGet, is that saved in the pupxxx file, or elsewhere? Does adding packages jeopardize the ability to load all of puppy OS into ram?
Back to top

PostPosted: Mon 22 Aug 2005, 17:41    Post subject:  

Forgot to thank Puppian and Lobster for advice early on in my travails, and Blade for publishing his framebuffer version. Barry, I assume, goes without saying.
Back to top

PostPosted: Tue 23 Aug 2005, 10:08    Post subject:  

Some, at least, of the above should be ignored. It seems that Blade's framebuffer-enabled version does not come with OpenOffice 1.9 bizarrely disabled, but rather with the usual abiword, etc. Somehow my little hard drive retained remnants of programs from earlier installation attempts and displayed broken links to openoffice 1.9 instead. I still don't understand why; I had run cfdisk and deleted and re-created the /dev/hda1. I expected that to wipe the disk clean, but it seems that it does not.

I wasn't sure, but it seemed like /mnt/home was the hard drive, in effect. So I tried deleting everything in there. It took around half an hour--it must have been completely full from way back when I tried to install Ubuntu but didn't have room.

Sorry for any confusion I've created. It will be worth noting, for regular helpers-of-newbies, that those who have tried numerous previous hard-disk installations may have a bunch of junk left on their hard drive, which they might not realize can interfere with Puppy, or which they might think that cfdisk has taken care of.

Back to top
Display posts from previous:   Sort by:   
Page 1 of 1 [3 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0790s ][ Queries: 11 (0.0312s) ][ GZIP on ]