Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 20 Oct 2014, 09:55
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Video
video and language support pblm w/Puppy 2.16
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
helmet2

Joined: 27 Jun 2007
Posts: 7

PostPosted: Wed 27 Jun 2007, 06:48    Post_subject:  video and language support pblm w/Puppy 2.16
Sub_title: ATI 128M RAGE Voodo2 bridge chipset
 

Hi, I have a strange problem with xorg. It's telling me that it has no problem about probing my video hardware but in the end when I enter "xwin" xorg is not starting, I have to run on xvesa.
I think it's cause of the Voodo bridge chipset. I had this problem with vector linux which was recognizing ATI but not seeing Voodo. Finally, I don't remember how, but it worked.
Anyway, I would like to know if there is a way for xorg to fully recognize my hardware.


my specs are (I'm talking of an HDD install of Puppy)
pentium3 450 katmai
128M ram
ATI 128M rage Voodoo2 Chipset bridge (might be 16M but not sure)
9G HDD
Ethernet card....

Ok, thanks. Rolling Eyes

PS : I would like to know, as well, if there is a relation between running xvesa and the fact that japanese language is not supported in an english version of Puppy 2.16.

Again thanks. Shocked
Back to top
View user's profile Send_private_message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Wed 27 Jun 2007, 13:49    Post_subject:  

If you chose xorg in the xorgwizard, it should have created a /etc/X11/xorg.conf
It remains also, if you choose Xvesa again later.

So use Xvesa again to get a grafical desktop, Edit this file, replace
driver "ati"
with
driver "voodoo"
or
driver "vesa"

Then exit X, and type these comands:
Code:
cd /usr/X11R7/bin
rm -f X
ln -s Xorg X
xwin


X is just a symlink to Xorg or Xvesa, so you can switch between those two by deleting it and creating a new one.
Like this you don't have to run the xorgwizard again, that would overwrite your modified xorg.conf again.

And yes, xvesa has limitations concerning international charsets.
Xorg should solve that.
Mark

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
Dougal


Joined: 19 Oct 2005
Posts: 2505
Location: Hell more grotesque than any medieval woodcut

PostPosted: Wed 27 Jun 2007, 16:19    Post_subject:  

Could you please run this dotpup (download it and then just click on it), then attach here the results, so I can see how the card is recognized and change the xorgwizard to match it?

Thank you.
HW-test.pup
Description 
pup

 Download 
Filename  HW-test.pup 
Filesize  1.88 KB 
Downloaded  435 Time(s) 

_________________
What's the ugliest part of your body?
Some say your nose
Some say your toes
But I think it's your mind
Back to top
View user's profile Send_private_message 
helmet2

Joined: 27 Jun 2007
Posts: 7

PostPosted: Thu 28 Jun 2007, 09:03    Post_subject: video card results  

Thanks for supporting,
attached to this thread, the file you asked.
results-helmet2.tar.gz
Description 
gz

 Download 
Filename  results-helmet2.tar.gz 
Filesize  6.91 KB 
Downloaded  453 Time(s) 
Back to top
View user's profile Send_private_message 
Dougal


Joined: 19 Oct 2005
Posts: 2505
Location: Hell more grotesque than any medieval woodcut

PostPosted: Thu 28 Jun 2007, 15:48    Post_subject:  

Thanks, I'll see what I can do.
_________________
What's the ugliest part of your body?
Some say your nose
Some say your toes
But I think it's your mind
Back to top
View user's profile Send_private_message 
Dougal


Joined: 19 Oct 2005
Posts: 2505
Location: Hell more grotesque than any medieval woodcut

PostPosted: Sat 30 Jun 2007, 07:47    Post_subject:  

I've had a look through it and both Xvesa and ddcprobe detect your card as being rage128, which should be used with the "r128" driver.

However, I don't know where that voodoo business comes in, so maybe the problem is as you mentioned you had in Vector...

_________________
What's the ugliest part of your body?
Some say your nose
Some say your toes
But I think it's your mind
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Video
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0861s ][ Queries: 13 (0.0375s) ][ GZIP on ]