Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 23 Jul 2014, 18:13
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking » Wireless
How to get Realtek rtl8185 wifi card working?
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [15 Posts]  
Author Message
joesavana

Joined: 20 Jan 2007
Posts: 15

PostPosted: Mon 05 Feb 2007, 13:36    Post subject:  How to get Realtek rtl8185 wifi card working?  

gents,
can you please help a frustrated newby to puppy..

i really like this distro. it runs fast as heck on a gateway solo 1150. BUT, i cant get this wireless card to work..

it works in xp, and it works perfectly with Kanotix live cd.

none of the puppy drivers will make it show up as a wifi device. i have downloaded the realtek .tar.gz file for this device, but have had no success doing anything with it. I probably don't know how to use it either.

the card was Compusa brand, but it came with Realtek software, and XP reports it as a Realtek rtl8185 wireless LAN card.

please help me out.. puppy is the ideal distro, but i need to get my wireless running.

thanks in advance.

joesavana
Back to top
View user's profile Send private message 
jonyo

Joined: 28 Dec 2006
Posts: 2727

PostPosted: Thu 15 Feb 2007, 11:25    Post subject:  

Had some realtek (forget which one..) crappy card on this Gateway mx 3410.
Ended up swaping it out.
Back to top
View user's profile Send private message 
jonyo

Joined: 28 Dec 2006
Posts: 2727

PostPosted: Fri 16 Feb 2007, 16:40    Post subject:  

Have you tried loading an .inf file with ndiswrapper?
Back to top
View user's profile Send private message 
jonyo

Joined: 28 Dec 2006
Posts: 2727

PostPosted: Fri 16 Feb 2007, 16:48    Post subject:  

Actually, just to clear up, it worked good but just didn't have the wifi range of my other computers. In the same spot, All others ran fine but this one always went down to a low 1 mbs & slow connection. Closer to the wifi router, she hummed.

So only fiddled with it a bit in puppy & at some point had a connection, I'm not sure if the same card as yours (i'm assuming laptop) but i'll check it out.

jonyo wrote:
Had some realtek (forget which one..) crappy card on this Gateway mx 3410.
Ended up swaping it out.
Back to top
View user's profile Send private message 
joesavana

Joined: 20 Jan 2007
Posts: 15

PostPosted: Fri 16 Feb 2007, 23:14    Post subject: realtek rt18185  

no, i've had no luck getting this card working.

i cant figure out what to do with the .tar i downloaded. if i unzip it, i have many files. but what do i do next?

are there more network card drivers i can get in dotpups, and then let puppy install them?

i've tried the ndiswrapper, with the driver xp uses, and even with any .inf file on the driver disc. ndiswrapper complains that its not a valid .inf file, or something like that.

thanks,

joesavana
Back to top
View user's profile Send private message 
jonyo

Joined: 28 Dec 2006
Posts: 2727

PostPosted: Sat 17 Feb 2007, 00:26    Post subject: Re: realtek rtl8185
Subject description: getting wireless to work
 

What driver works here?

joesavana wrote:
it works perfectly with Kanotix live cd.
Back to top
View user's profile Send private message 
joesavana

Joined: 20 Jan 2007
Posts: 15

PostPosted: Sun 18 Feb 2007, 23:12    Post subject: realtek rtl8185  

jonyo..
are you asking what driver works in kanotix?
i dont know. the software detects the network card, and i just configure it
with my wep key. no problem.

none of the puppy drivers will show any wifi interface with the network card.

i'd really like to get it working because puppy is ideal for an old laptop.

any other ideas?

joesavana
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5216
Location: Australia

PostPosted: Sun 18 Feb 2007, 23:56    Post subject:  

http://www.murga-linux.com/puppy/viewtopic.php?p=98056#98056
Back to top
View user's profile Send private message 
jonyo

Joined: 28 Dec 2006
Posts: 2727

PostPosted: Thu 22 Feb 2007, 18:20    Post subject: Re: realtek rtl8185  

If you find setting up the internal wifi card, to be to much of a PIA, might consider a usb wifi dongle, assuming you have a usb port. Is your's an onboard card? What pup ver?

joesavana wrote:
jonyo..
are you asking what driver works in kanotix?
i dont know. the software detects the network card, and i just configure it
with my wep key. no problem.

none of the puppy drivers will show any wifi interface with the network card.

i'd really like to get it working because puppy is ideal for an old laptop.

any other ideas?

joesavana
Back to top
View user's profile Send private message 
joesavana

Joined: 20 Jan 2007
Posts: 15

PostPosted: Thu 22 Feb 2007, 22:01    Post subject: realtek rtl8185  

jonyo,
the card is compusa's brand.. cost 20 bucks. it has realtek sofware and drivers. it goes into the pcmia slot (did i say that right!) of an old gateway solo 1150.

i have the latest version of puppy.

yep, i could buy one of those usb wifi devices. actually, i know the linksys wusb11 and wusb52 work in puppy because i use them on my desktop.

i still have to try what someone suggested in a link in another reply..

thanks again.

joesavana
Back to top
View user's profile Send private message 
joesavana

Joined: 20 Jan 2007
Posts: 15

PostPosted: Sun 25 Feb 2007, 13:42    Post subject: realtek rtl8185
Subject description: some success, but no cigar!
 

hi gents..
well, i noticed that there is a newer version of puppy. it has the drivers i need for the realtek 8185, so i tried it.
sure enough, the card shows up as wlan0, i see my network, then i go to configure wep..
darn it, i cant get wep set up.
RutilT is what got puppy configured on a desktop i have. but when i try to use it in this later puppy version, RutilT complains that it needs to be run as root.
i thought puppy always ran as root. someone please help me on this.
i'm almost there, but not quite.

thanks in advance.
joesavana
Back to top
View user's profile Send private message 
jonyo

Joined: 28 Dec 2006
Posts: 2727

PostPosted: Sat 31 Mar 2007, 09:53    Post subject:  

Not sure what pup ver ya runnin.? I got live cd 2.14 on this desk & wep is A-ok. No root stuff probs happenin for me.with rutilt . Never had a root scenario either with 2.12-3 or 4 live cd so dunno what it may be about in your setup.
Back to top
View user's profile Send private message 
joesavana

Joined: 20 Jan 2007
Posts: 15

PostPosted: Sun 29 Jul 2007, 11:24    Post subject: realtek rtl8185
Subject description: FINALMENTE! FINALLY!!!
 

i could never get this compusa (realtek) wifi pcmia card to work, TILL NOW!

the activity & link lites always came on, i entered my wep info, tried all of puppys tools.. never could connect.

downloaded puppy 2.17 the other day, used ndiswrapper, and i was able to get connected with rutilt. only this puppy version worked for me. something must be different, dont know what.

thanks to the puppy gurus.. this is the distro for me using my ol' gateway solo 1150. there is a god!

many thanks!

joesavana
Back to top
View user's profile Send private message 
munichjohn

Joined: 01 Oct 2009
Posts: 7

PostPosted: Sat 03 Oct 2009, 19:27    Post subject: Realtek rtl8185 working with WPA on puppy 4.3 but......
Subject description: ....needed to load the driver via NDISWRAPPER
 

A belated note. I'm running puppy 4.3 on an CPQ Armada M700 P3 notebook with a PCMCIA Digitus card. I found that the driver in puppy failed. Using this driver it talked to the hub but was consistently disconnected. However the driver from the Digitus site works when loaded with NDISWRAPPER. I'm using WPA(1) encryption. I had the same experience with puppy 4.2.1 so no related change in 4.3. What a really good facility in the puppy network wizard to be able to blacklist the original driver, Very Happy I've not seen that before. Best, munichjohn
Back to top
View user's profile Send private message 
Fishback

Joined: 24 May 2009
Posts: 56

PostPosted: Sat 03 Oct 2009, 20:27    Post subject:  

Munichjohn - Wireless issues can vary between versions of the same card. The information you provided will be much more helpful if you can provide the card model and version.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [15 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Networking » Wireless
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0691s ][ Queries: 12 (0.0045s) ][ GZIP on ]