Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 11 Dec 2017, 17:27
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
error while installing a Java jar file
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [3 Posts]  
Author Message
Browny

Joined: 12 Feb 2007
Posts: 59

PostPosted: Thu 13 Sep 2007, 11:20    Post subject:  error while installing a Java jar file  

Dear all,

I am trying to run one of my jar file for my own application. Its giving me an error

Exception in thread "main" java.lang.NoSuchFieldError: LIB_PATH_ENV
at org.jdesktop.jdic.browser.InternetExplorerEngine.<clinit>(Unknown Source)
at org.jdesktop.jdic.browser.BrowserEngineManager.initExitingEngines(Unknown Source)
at org.jdesktop.jdic.browser.BrowserEngineManager.<init>(Unknown Source)
at org.jdesktop.jdic.browser.BrowserEngineManager.instance(Unknown Source)
at BrowserTest.main(BrowserTest.java:1Cool

But this jar file is running fine in Fedora core 6.

Help me to resolve this error

Thanks in advance,
Browny
Back to top
View user's profile Send private message 
HairyWill


Joined: 26 May 2006
Posts: 2946
Location: Southampton, UK

PostPosted: Thu 13 Sep 2007, 12:11    Post subject:  

What versions of java are being used in the two installs?
What version did you compile with?
read this
http://java.sun.com/j2se/1.4.2/docs/api/java/lang/NoSuchFieldError.html

org.jdesktop.jdic.browser.InternetExplorerEngine
http://fisheye5.cenqua.com/browse/jdic/src/jdic/src/share/classes/org/jdesktop/jdic/browser/InternetExplorerEngine.java?r=1.9

Not being unfriendly but you are much more likely to get a sensible solution on a java programming forum.

_________________
Will
contribute: community website, screenshots, puplets, wiki, rss
Back to top
View user's profile Send private message 
Browny

Joined: 12 Feb 2007
Posts: 59

PostPosted: Sat 15 Sep 2007, 03:05    Post subject:  

I have upgraded the java version from 1.5 update 11 to java version 1.6. After upgrading tha jar file asked me some jibrary file like libgnome, libbonobo, libgconf, libesd, libdbus, libselinux. I have put all those .so files into puppy.

There is again an error which is

libselinux.so: cannot locate TLS data.

could you help me to resolve this issue
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [3 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0273s ][ Queries: 14 (0.0050s) ][ GZIP on ]