Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 30 Sep 2014, 14:43
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
How do I use my widescreen laptop at max resolution?
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [4 Posts]  
Author Message
Guest
Guest


PostPosted: Wed 28 Sep 2005, 07:32    Post subject:  How do I use my widescreen laptop at max resolution?  

Hi There!

I've been playing with Puppy for a few weeks now, and I love it!
I've been reading up on screen settings, because my Xvesa Wizard maxes out at 1024x768x16 even though my ATI mobility 9600 can do 1280x800x32.

I've been reading up on the issue, but I think I'm at the point where I can accidentally do more harm to my system than good. Here are the options I'm considering:
Should I try installing the X server through DotPup, reconfiguring the Xvesa somehow, or attempt to install the ATI linux drivers?

Any help is much appreciated.
Back to top
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Wed 28 Sep 2005, 11:10    Post subject:  

Hi,

I would try to install the Xorg-Xserver:
http://www.murga.org/%7Epuppy/viewtopic.php?t=2303

After installation, edit /etc/X11/xorg.conf with beaver, and replace
Driver "vesa"
with
Driver "ati"

Then change this

DefaultDepth 24
to
DefaultDepth 32

Then change these lines:
Code:

    Subsection "Display"
        Depth       24
        Modes       "800x600" "640x480"
#        Modes       "800x600"
#         Modes       "512x384"
        ViewPort    0 0
    EndSubsection


to
Code:

    Subsection "Display"
        Depth       24
        Modes       "800x600" "640x480"
#        Modes       "800x600"
#         Modes       "512x384"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       32
        Modes       "1280x800"
        ViewPort    0 0
    EndSubsection


And restart X.

The inbuilt ATI-driver should support that mode.

Mark
Back to top
View user's profile Send private message Visit poster's website 
Guest
Guest


PostPosted: Wed 28 Sep 2005, 20:06    Post subject: Thanks!  

Thank You for the help!

I had to try it a couple of times, but I now have a *sweet* looking Puppy!

This lap dog looks great at 1280 by 800 wxga!

Here's what worked:
-Switced from Driver "ati" to
Driver "radeon"

-fiddled with the settings until it looked like this:
Section "Screen"
Identifier "Screen 1"

Device "Standard VGA"
Monitor "My Monitor"
DefaultDepth 24

Subsection "Display"
Depth 8
Modes "800x600" "640x480"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 16
Modes "800x600" "640x480"
# Modes "640x460"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 24
Modes "1280x800" "1024x768"
# Modes "1280x800"
# Modes "1024x768"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 24
Modes "800x600" "640x480"
# Modes "800x600"
# Modes "512x384"
ViewPort 0 0
EndSubsection


EndSection

For some reason, I haven't been able to get depth 32 yet, but that's fine - the 1280x800 was the priority. Also, found that the start menu has lost some functionality:
In the Shut Down area, the Reboot, Power-off and JWM Restart commands hang on me. I think that they can't manage to kill Xorg. If I Shut Down->Exit to Prompt after selecting Reboot or Power-off, the reboot/power-off continues normally.

Any tips on fixing the Reboot, Power-off and JWM Restart commands?
Back to top
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Wed 28 Sep 2005, 23:59    Post subject:  

yes, http://www.murga.org/%7Epuppy/viewtopic.php?p=14838#14838

SomePuppy-Programs like the Vesa-Wizard don't work of course, as they were written for the kdrive-server.
If you find other programs that do not work, please add it to the Xserver-Thread, as I read it certainly there. In the beginners Board I might oversee it.

I might tell you alternatives or fixes then.

Mark
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [4 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0509s ][ Queries: 12 (0.0051s) ][ GZIP on ]