Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 20 Aug 2014, 18:24
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Audio
problem with legacy isa sound card ct4520
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [8 Posts]  
Author Message
Digistar

Joined: 23 Nov 2007
Posts: 13

PostPosted: Fri 23 Nov 2007, 17:51    Post subject:  problem with legacy isa sound card ct4520
Subject description: creative labs sound blaster awe64
 

need to know how to make this card and a few others like it work
am using puppy 3.01
Back to top
View user's profile Send private message 
rockaway

Joined: 21 Nov 2007
Posts: 19

PostPosted: Mon 26 Nov 2007, 05:46    Post subject:  

I am putting down the system requirements that are required to make a isa sound card ct4520 work:
1) Intel Pentium 90 or higher, or AMD K5 or higher processor
2) 8 MB system RAM (16 MB recommended)
3) MS-DOS® 5.0 or higher, Windows 3.1 or higher, or Windows 95
4)Open half-length 16-bit ISA slot
5)Speakers or headphones
6)CD-ROM drive for software installation
Back to top
View user's profile Send private message 
Digistar

Joined: 23 Nov 2007
Posts: 13

PostPosted: Mon 26 Nov 2007, 13:38    Post subject: daffy duckless
Subject description: wtf
 

look i said puppy 3.01 and never mind widows windows 98se does it just fine i need driver for puppy daffy duckless
Back to top
View user's profile Send private message 
steevieb


Joined: 30 Dec 2006
Posts: 286
Location: Poole, Dorset. UK

PostPosted: Mon 26 Nov 2007, 14:32    Post subject:
Subject description: awe64
 

Try a forum search for awe64
http://www.murga-linux.com/puppy/viewtopic.php?t=16315 may help

_________________
Slacko 5.3 scsi on Proliant server, 2x2.4ghz P4,18gb & 4x36gb scsi drives, 128mb Radeon Pci, 2gb ram, usb 2, dvd
Back to top
View user's profile Send private message 
Digistar

Joined: 23 Nov 2007
Posts: 13

PostPosted: Mon 10 Dec 2007, 19:33    Post subject: problem with cs4248-kl soundcard
Subject description: help im a beginner this is all greek to me
 

need help getting isa sound cards to recognise simple verbose instructions please.
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5234
Location: Australia

PostPosted: Tue 11 Dec 2007, 01:21    Post subject:  

The Crystal (Cirrus Logic) cs4248 chipset is supported by the ALSA snd-ad1848 module.
So run this command in the terminal
Code:
modprobe snd-ad1848

Now run the ALSA sound configuration wizard.
If still no sound, it might be necessary to manually modify your /etc/modprobe.conf file (using the Geany text editor) to specify hardware parameters for the snd-ad1848 module. Here is a good example -
http://www.thinkwiki.org/wiki/CS4248
That link explains how to configure the cs4248 chipset in the Thinkpad 750.
Back to top
View user's profile Send private message 
prehistoric


Joined: 23 Oct 2007
Posts: 1262

PostPosted: Tue 18 Dec 2007, 11:04    Post subject: works with other SB AWE
Subject description: Tried this in puppy 2.14R with a SoundBlaster AWE64 VE
 

Just got sound working on an old machine with a slightly different SoundBlaster AWE64 ISA sound card. These boards are in the CT4500 series. Many were sold, many used by different OEMs, with slightly different parameters.

The only thing missing when Puppy installs is the kernel module. Do a modprobe for that before you run alsaconf.

Code:

modprobe snd_sbawe
alsaconf


After that, just answer as you would from the Puppy wizard. When you reboot the module should be loaded automatically and the mixer started, as shown in the system tray.

prehistoric
Back to top
View user's profile Send private message 
lol197282

Joined: 19 May 2008
Posts: 1

PostPosted: Mon 19 May 2008, 22:57    Post subject: puppy 3.01 ct4520 (soundblaster awe64)
Subject description: puppy 3.01 (retro) snd-sbawe isa pnp sound card
 

updating modprobe.conf file worked for me

Quote:
Geany /etc/modprobe.conf

2 lines added at the bottom
Quote:
alias snd-card-0 snd-sbawe
alias sound-slot-0 snd-sbawe

saved and closed

rebooted & the volume control appeared in the taskbar
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [8 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Audio
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0541s ][ Queries: 12 (0.0043s) ][ GZIP on ]