Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 01 Jul 2015, 00:53
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
cant start X
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message

PostPosted: Thu 29 Sep 2005, 04:24    Post_subject:  cant start X  


I just downloaded chubby puppy 1.0.4 and the puppy 1.0.5 distro. However I cant use them since they both fail at starting X:

as soon as they try to start X they hang and the only way I found to get back to the command prompt is to hit alt-SysReq (not sure if this is correct but it works Wink

I looked at the the /tmp/xerrs.txt and the error I get is:

>Interrupt pointer doesn't point at ROM
>Fatal server error:
>no screens found
>giving up.
>/usr/X11R6/bin/xinit: Connection refused (errno 111): unable to connect >to X server
>/usr/X11R6/bin/xinit: No such process (errno 3): Server error.

I tried then to run xwin by hand and this is the messages it gave before getting hang as well:

>This script will run X windows for you...
>Starting X with video mode 0x0111 and mouse psaux...
>Exited from X. Type "xwin [fvwm95|jwm]" to restart X ([ ] mean >optional).
>(To change mouse and keyboard, type "rm /etc/mousedevice", then run >xwin)

I am using a Pentium 2.4GHz, ASUS P4PE motherboard, ATI Radeon 9000 graphics card.

Is this a case of this particular hardware not supported by Puppy or is there something I could do?


Back to top
Puppy Master

Joined: 09 May 2005
Posts: 7441
Location: Perth, Western Australia

PostPosted: Thu 29 Sep 2005, 05:38    Post_subject:  

Try executing this:

# Xvesa -listmodes

see if the Xvesa server can find any useful video modes in your graphics chip.
Back to top
View user's profile Send_private_message Visit_website 

PostPosted: Fri 30 Sep 2005, 03:15    Post_subject: Cant start X  

No luck,

the output from "Xvesa -listmodes" is


Interrupt pointer doesn't point at ROM
Interrupt pointer doesn't point at ROM
0x0006: 640x200x1 (monochrome) Planar (1 planes)
0x000D: 320x200x4 Planar (4 planes) (no linear framebuffer)
0x000E: 640x200x4 Planar (4 planes) (no linear framebuffer)
0x0010: 640x350x4 Planar (4 planes) (no linear framebuffer)
0x0011: 640x480x1 (monochrome) Planar (1 planes)
0x0012: 640x480x4 Planar (4 planes) (no linear framebuffer)
0x0013: 320x200x8 PseudoColor

Is then the Xvesa implementation the problem? Can I do anything about it?

Thanx for your help
Back to top

Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Fri 30 Sep 2005, 04:51    Post_subject:  

You might need the xorg-Xserver:

You can install it even if X is not running:
mkdir /root/xorg
cd /root/xorg
wget http://noforum.de/dotpups/xorg682c.pup
unzip xorg682c.pup

This will download, extract and install it.
You might edit /etc/X11/xorg.conf then:
mp /etc/X11/xorg.conf

Press CTRL-A for a menue in mp.

Replace the "vesa" with "ati" or "radeon" .

Then type "xwin jwm" to start X.

Back to top
View user's profile Send_private_message Visit_website 

PostPosted: Fri 30 Sep 2005, 06:01    Post_subject: Cant start X  

Thanx for all the help !!!

I just downloaded xorg and I'm going to give this a try over the weekend!

Will let you know how it goes

P.S. I am VERY impressed by the response in this forum. Congrats, keep up the good work!

Back to top

PostPosted: Tue 04 Oct 2005, 02:42    Post_subject: cant start X - SOLVED  

Very Happy

Just tried yesterday chubby puppy 1.0.5 with xorg and it worked. I tweaked xorg.conf a bit: changed "vesa" to "radeon" and also changed the refresh rates to match those of my monitor. So now I am looking at a beautiful Puppy in 1024*768 resolution.

Exchellent work. So I am of to explore this new world!

Thanx for all your help!
Back to top
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0526s ][ Queries: 12 (0.0061s) ][ GZIP on ]