Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 24 Apr 2014, 22:24
All times are UTC - 4
 Forum index » Advanced Topics » Cutting edge
Printing from Abiword comment
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [5 Posts]  
Author Message
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Sun 18 Sep 2005, 07:06    Post subject:  Printing from Abiword comment  

I would like to make a comment about this, as the printing bug in Abiword,
text displaced upwards, is most annoying. More than annoying.

This morning, I wanted to print, got that &^%$#@ bug, so saved the file as
RTF format then booted Chubby Puppy and was able to print nicely from OO.

The problem is the page header. The Postscript code that Abiword generates
displays
okay in Gsview, but the translation to the printer PCL language stuffs up the
header and basically the header section of the page doesn't print, so all the
text of the page prints higher on the page.

The Abiword developers have known about this bug for at least a year.
So why aren't they fixing it?
Well, it seems that they are focussing on the 2.3 unstable series, which will be released soon as the stable 2.4 series. Puppy currently has 2.2.7.
Now, I'm not 100% certain, but the bug may go away when we upgrade to 2.4.
They are using the Gnome printer library, same as Gnumeric, so that library is
already in Puppy, and apparently they don't get that bug when use that library.

So, there is light at the end of the tunnel, ...hopefully.
Just thought I would let you know.
Other than that bug, Abiword is very nice to use.
Back to top
View user's profile Send private message Visit poster's website 
zygo
Guest


PostPosted: Tue 04 Oct 2005, 16:52    Post subject:  

Barry,

I can't print from 105 ( http://www.murga.org/~puppy/viewtopic.php?t=2613 ) but when I could print I compensated for the offset with an offset template. I replaced the normal.awt with the this one - attached.

Not perfect but all there. I thought the problem was caused by me using the nearest (but not) matching driver for my printer.
Back to top
zygo
Guest


PostPosted: Tue 04 Oct 2005, 16:59    Post subject:  

I just tried to attach the template but got the error 'The Extension awt is not allowed'.
Back to top
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Tue 04 Oct 2005, 17:36    Post subject:  

simply type gzip mytemplate.awt , then upload mytemplate.awt.gz

But at moment there seems so be an problem with the server.

Mark
Back to top
View user's profile Send private message Visit poster's website 
zygo
Guest


PostPosted: Wed 05 Oct 2005, 06:18    Post subject:  

I'm in ms.
normal.zip
Description 
zip

 Download 
Filename  normal.zip 
Filesize  994 Bytes 
Downloaded  238 Time(s) 
Back to top
Display posts from previous:   Sort by:   
Page 1 of 1 [5 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Cutting edge
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0478s ][ Queries: 13 (0.0069s) ][ GZIP on ]