Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 30 Sep 2014, 02:26
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Utilities
fox-1.6.33 + rezound-0.12.3beta + xfe-1.19.1 + more
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 3 [32 Posts]   Goto page: Previous 1, 2, 3 Next
Author Message
plinej

Joined: 13 Aug 2006
Posts: 1522

PostPosted: Tue 22 Jan 2008, 14:21    Post subject:  

Alright, now I seem to have a new issue with fox. I can't seem to type into any entry dialog boxes in rezound or xfe. I guess I have to figure out why and re-compile.
Back to top
View user's profile Send private message 
plinej

Joined: 13 Aug 2006
Posts: 1522

PostPosted: Tue 22 Jan 2008, 14:47    Post subject:  

Alright, I think I got it this time. How I compiled the fox package is shown at the beginning of the thread. Rezound & xfe seem to be working as expected now. I'm able to type into entry boxes just fine now. So once again, please re-download the fox & fox_dev packages from the beginning of this thread.
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Tue 22 Jan 2008, 15:00    Post subject:  

ok, done Smile
Mark
Back to top
View user's profile Send private message Visit poster's website 
plinej

Joined: 13 Aug 2006
Posts: 1522

PostPosted: Tue 22 Jan 2008, 15:09    Post subject:  

Thanks Mark. Hopefully that'll be the last time.
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Tue 22 Jan 2008, 15:20    Post subject:  

No prob.
I had to add so many bugfixes to Muppy, as I oversaw ... this ... and that ... Rolling Eyes

It is good, that you are so carefull.
Dingo is experimental, so it might be even more difficult to get things correct.
It is good to see, how the list of packages for it grows.
Though I will stay quite a long while with 3.01, as it gives access to the huge Slackware-repos.
But once Dingo is finished, I'll be glad if we have many pets Smile

Mark
Back to top
View user's profile Send private message Visit poster's website 
zigbert


Joined: 29 Mar 2006
Posts: 5728
Location: Valåmoen, Norway

PostPosted: Wed 23 Jan 2008, 05:11    Post subject:  

I have always liked Xfe! But I have to admit, PathFinder is even faster. - Wow. It renders like gtk1.

Rezound is also very impressive.

Very Happy Very Happy Very Happy

Thanks
Sigmund

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
GrinningLeopard

Joined: 30 Apr 2008
Posts: 8

PostPosted: Tue 20 May 2008, 15:21    Post subject:  

Firstly, thank-you for your evident hard work - I can't get used to ROX and XFE is vastly superior. One quick question though - is it possible to set XFE as the default FM? Oh and another thing, can I disable the root warning that pops up on launch?

cheers
GL

P.S. Using Dingo Wink
Back to top
View user's profile Send private message 
plinej

Joined: 13 Aug 2006
Posts: 1522

PostPosted: Tue 20 May 2008, 19:02    Post subject:  

To get rid of the root warning you can do this:

Edit > Preferences > Dialogs

untick the box that says "Warn if running as root"

Here's a dotpet that will make xfe the default file manager in Puppy.
It will overwrite the /usr/local/bin/rox script and move the original to /usr/local/bin/rox2. It also creates a new desktop file for rox which will execute rox2 instead. All the puppy scripts that use rox as a file manager should instead use xfe. Here is the script:

Code:

#!/bin/bash

if [ "$1" = "" ]; then
xfe &
exit 0
fi
if [ "$1" = -D ]; then
###don't believe there's a command to close specified window
exit 0
fi
if [ "$1" = -o ]; then
xfe "$2" &
exit 0
fi
if [ "$1" = -d ]; then
xfe "$2" &
exit 0
fi
if [ -d "$1" ]; then
xfe "$1"
exit 0
fi
if [ -x "$1" ]; then
xfe "$1"
exit 0
fi
if [ -x "$2" ]; then
xfe "$2"
exit 0
fi
rox2 "$@" &
exit 0
xfe-default-file-manager-0.1.pet
Description 
pet

 Download 
Filename  xfe-default-file-manager-0.1.pet 
Filesize  761 Bytes 
Downloaded  1091 Time(s) 
Back to top
View user's profile Send private message 
GrinningLeopard

Joined: 30 Apr 2008
Posts: 8

PostPosted: Wed 21 May 2008, 08:13    Post subject:  

Nice one, thanks again plinej Very Happy

-GL
Back to top
View user's profile Send private message 
plinej

Joined: 13 Aug 2006
Posts: 1522

PostPosted: Wed 21 May 2008, 19:48    Post subject:  

updated to fox-1.6.33 (the latest stable release)
Back to top
View user's profile Send private message 
dcbevins

Joined: 02 May 2008
Posts: 26

PostPosted: Sat 31 May 2008, 12:52    Post subject: Title Bar Missing  

I've installed the above packages.

XFE will start, but is missing the title bar so I can't drag it around. It has no min/max/close buttons.

XFE from console gives this:

# xfe
xfe: /usr/lib/libstdc++.so.6: no version information available (required by xfe)
xfe: /usr/lib/libstdc++.so.6: no version information available (required by xfe)
xfe: /usr/lib/libstdc++.so.6: no version information available (required by /usr/lib/libFOX-1.6.so.0)
xfe: /usr/lib/libstdc++.so.6: no version information available (required by /usr/lib/libFOX-1.6.so.0)
#

/usr/lib/libstdc++.so.6 exists as a link to libstdc++.so.6.0.9 in the same directory.
/usr/libFOX-1.6.so exists as a link to libFOX-1.6.0.0.31 in the same directory.

Is this a problem or is my problem some place else?

Thanks.
Back to top
View user's profile Send private message 
plinej

Joined: 13 Aug 2006
Posts: 1522

PostPosted: Sat 31 May 2008, 14:59    Post subject:  

While xfe is opened, right click on the xfe icon in the taskbar and click on Maximize. You will then see the xfe title bar, you can also resize xfe by choosing the Resize option.
Back to top
View user's profile Send private message 
dcbevins

Joined: 02 May 2008
Posts: 26

PostPosted: Sat 31 May 2008, 19:40    Post subject: Odd  

How odd, but whatever works!

Thanks.
Back to top
View user's profile Send private message 
plinej

Joined: 13 Aug 2006
Posts: 1522

PostPosted: Thu 03 Jul 2008, 21:14    Post subject:  

updated xfe to 1.19.1
Back to top
View user's profile Send private message 
Sylvander

Joined: 15 Dec 2008
Posts: 3446
Location: West Lothian, Scotland, UK

PostPosted: Tue 04 May 2010, 10:59    Post subject:  

See HERE how installing xfe-default-file-manager-0.1 within lupu-114 caused a problem.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 3 [32 Posts]   Goto page: Previous 1, 2, 3 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Utilities
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0674s ][ Queries: 13 (0.0044s) ][ GZIP on ]