Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 18 Dec 2014, 08:27
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
[Résolu] lenteur anormale d'affichage
Moderators: Béèm, darkerror05
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
rodney mullen

Joined: 19 Jan 2008
Posts: 20

PostPosted: Thu 31 Jan 2008, 13:08    Post_subject:  [Résolu] lenteur anormale d'affichage
Sub_title: (lors du défilement vertical)
 

Bonjour,
Dans un navigateur, dans un visionneur pdf ou meme dans un editeur de texte, quand je veut faire défiler verticalement ou horizontalement , l'affichage est lent , et si je m'amuse à donner 15 tours de roulettes d'affilé, l'affichage se fait pas avant 20 ou 30 secondes et l'indicateur de RAM (en rouge) en bas à droite m'indique que la RAM est completement saturée.

Y a t'il une solution ?

J'utilise toutou linux 3-01.1 avec Xvesa, sur un ordinateur portable récent qui possède 2 Go de RAM.

Edited_times_total
Back to top
View user's profile Send_private_message Visit_website 
maddox

Joined: 28 Sep 2007
Posts: 453
Location: sometimes in France

PostPosted: Thu 31 Jan 2008, 17:21    Post_subject:  

Bonjour rodney mullen,
cela semble être un prob d'affichage.
Je ne suis pas certain de cette phrase ->.. Xvesa n'est pas acceleré...
ou bien Xvesa n'a pas le bon driver pour la carte et utilise un generique, generique n'est PAS acceleré.

essai avec l'option -shadow
(force un "shadow framebuffer" même si ce n'est pas necessaire.
Peut nettement ameliorer la vitesse d'affichage avec certaines cartes.)

Trouve où la commande Xvesa est lancée et modifier :
Xvesa -shadow

pour afficher les modes possibles, dans rxvt : Xvesa -listmodes
pour afficher l'aide, dans rxvt : Xvesa -help

C'est peu d'info, mais je n'utilise pas Xvesa.
et Xorg ne vous convient pas ?

Cordialement,
Back to top
View user's profile Send_private_message 
rodney mullen

Joined: 19 Jan 2008
Posts: 20

PostPosted: Thu 31 Jan 2008, 18:05    Post_subject:  

J'ai pas du tout compris vers ou je devais chercher le fichier à modifier (pour mettre l'option -shadow).

J'ai essayé Xorg à l'installation mais ça n'as pas marché , seul Xvesa à fonctionné. Sinon , je vais essayer sur dans la partie anglaise.
Back to top
View user's profile Send_private_message Visit_website 
maddox

Joined: 28 Sep 2007
Posts: 453
Location: sometimes in France

PostPosted: Fri 01 Feb 2008, 18:20    Post_subject:  

Bonjour rodney mullen,
en cherchent un peu plus, voici les info's...

le fichier /etc/xextraoptions contient déjà le mot -shadow
(et passe ces options, de la ligne de commande, à Xvesa)
c'est dans ce fichier que vous pouvez ajouter/enlever des options de command pour Xvesa.
Attention, pas de retour de ligne à la fin, et tout les options sur la même ligne
ex: -shadow -blabla -nobuffer -logo

Le contenu de ce fichier est une variable ($XEXTRAOPTIONS)
. (les options de ligne de commande a passer à Xvesa)
et appartenant au script "/usr/X11R7/bin/xwin" de toutou-3.01-1 ->
lignes 266-268
Code:
XEXTRAOPTIONS=""
if [ -e /etc/xextraoptions ];then
 XEXTRAOPTIONS="`cat /etc/xextraoptions`"

essai de renommer ce fichier en "/etc/xextraoptions-bak" et redémarrez ou relancer le serveur X
Si pas de changements ou plus lent, vous pouvez toujours le remommer

si cela vous aide un peu...
maddox

Edited_time_total
Back to top
View user's profile Send_private_message 
rodney mullen

Joined: 19 Jan 2008
Posts: 20

PostPosted: Fri 01 Feb 2008, 18:32    Post_subject:  

ça maaaaaaarche !! il fallait écrire -shadow dans le fichier /etc/xextraoptions. merci beaucoup, maintenant ça scroll à la vitesse de l'éclair !
merci maddox

toutou linux for the win
Back to top
View user's profile Send_private_message Visit_website 
maddox

Joined: 28 Sep 2007
Posts: 453
Location: sometimes in France

PostPosted: Fri 01 Feb 2008, 18:57    Post_subject:  

cela peut servir à d'autres qui ont le même problème avec Xvesa Smile

A prendre dans l'aide Howto ...
merci pour le mot [Résolu] Smile

Cordialement,
maddox
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0525s ][ Queries: 12 (0.0035s) ][ GZIP on ]