Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info

 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 

The time now is Sun 09 Aug 2020, 23:03
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Can't boot from my Usb memory stick!
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [9 Posts]  
Author Message

Joined: 26 May 2005
Posts: 4

PostPosted: Thu 26 May 2005, 06:46    Post subject:  Can't boot from my Usb memory stick!  


I'm quite new to Linux and specially to this version. Anyway, I'm trying to make my memory stick bootable with Puppy. After finishing the setup script (without any errors) and rebooting the computer (with the right boot device set in bios) I get this error message...

Operating system not found

Any ideas what may be wrong?


Back to top
View user's profile Send private message 
Ultra Super-stud

Joined: 05 May 2005
Posts: 168

PostPosted: Thu 26 May 2005, 09:45    Post subject:  

This could be one of many problems...

If the USB port you're using is part of a hub, rather than a hard-mounted port, sometimes the boot will fail. I don't know the wheres and whys of this, but I have found this to be true in my experience. Also, sometimes a front-mounted USB port on your case is seen as a separate hub, and will not work.

This could also be the fault of your BIOS. It took a while for hardware manufacturers to get booting from USB settled out (I'm not even sure you can say it's settled out now), so there are a lot of computers out there that have serious difficulties booting from anything USB, though the have bios settings for it.

Finally, it could be your USB key. Some older keys in particular are just no good for booting (this is also from my experience). However, I've had pretty good luck with newer keys...so....

Also, depending on what BIOS you have, you may be using the wrong settings. Many many sites on the net will tell you to set your Bios to something like, "USB floppy" or "USB boot", but for many BIOS out there, these will not boot a USB key. If your BIOS sees the key as an additional hard drive, what you need to do is boot into the bios (with the key plugged in) and find the "hard drive boot order" setting. your key will be listed there with the hard drives, set it to first in the boot order and reboot.

Oh, and just to be sure, have the key plugged into one of the ports on the back.

Good luck.

Back to top
View user's profile Send private message 

PostPosted: Thu 26 May 2005, 10:31    Post subject:  


Unfortunately none of those arguments fits in as a solution Crying or Very sad

My PC is new (I have also tried my Usb key on other machines) and I dont use any hubs or front side ports. My Usb device is brand new and since I can boot my PC from another Usb key containing "Windows 98 boot diskette", there should be no problems with my bios.

Any other suggestions?

Back to top

Joined: 08 May 2005
Posts: 294
Location: Albany, NY

PostPosted: Thu 26 May 2005, 20:21    Post subject:  

Actually, nduanetesh comments do apply. I have two systems that refuse to boot from USB sticks, although they do using the utility that came with the USB stick, formatted as a win boot disk. The issue seems to be the varying standards that a bios uses to boot from usb. They vary from bios to bios.

Add how syslinux uses the bios to boot Puppy and the possibility of having more than one partition on the USB disk from trying to use the key over and over (over-writing say a win boot formatted key with syslinux) and there you have it.

My key drove me crazy like this. PartitionMagic saw one partition on the disk, qtparted saw a corrupted key with multiple partitions. A different brand USB key gave me even more headaches. Good as a data disk, but nogo as a boot device.

The message you are getting often refers to the bios not seeing the boot sector as what it thinks it should be. Often you get this using the USB-HDD option in the bios. The bios sees the key but finds no boot sector/reference to an OS, or no operating system.

This has been discussed a lot in the older form as well. On my Asus board, the readme of one of the bios updates even mentioned that they removed the USB boot option!

Barry mentions this also. He notes that on some systems, the option that works is actually USB-ZIP. So you have;

1. The bios and how it sees USB key devices

2. How the key is formatted and it it is formatted correctly for booting.

3. How syslinux is designed to work with your bios to properly see and use the device as a boot disk.

4. The key's complaince to standards, say USB1 or USB2 and if the usb port that you are using is USB1 or 2 compliant. Often the onboard usb ports work better than added cards or hubs. Some hubs require external power to work properly, expecially on laptops.

I love it when a plan comes together

--Hannibal Smith
Back to top
View user's profile Send private message Visit poster's website 

PostPosted: Fri 27 May 2005, 06:55    Post subject:  


I tried the same procedure with another Usb memory stick and then I got this short error message...

Boot failed

I don't know if this means exactly the same thing as the earlier message or if there may be some other problem here?!?

Another question... Can I put a boot loader on Puppy?


Back to top

PostPosted: Fri 27 May 2005, 07:43    Post subject: Make Bootable  

It appears that installing Puppy to a usb flash/pen drive does not make the drive bootable. I used a fdisk from a FreeDOS bootfloppy to set the boot flag.
Back to top

PostPosted: Fri 27 May 2005, 08:24    Post subject:  

I've already tried that, but it doesn't help Crying or Very sad
Back to top

PostPosted: Sun 29 May 2005, 17:06    Post subject: Can't boot from USB key  

This is what worked for me. I use a Sandisk Cruzer 128MB flash drive with puppy installed. First, I had to format the drive as a boot device. I found a free utility from HP that works with many other brands at this link:


My drive appears as a USB-HDD or USB-Floppy, depending on the BIOS of the computer that I boot from. Some older BIOS's won't recognize the USB drive at all. Note that I first tried FDISK and dos format commands under windows 98, before I found the HP utility. YMMV.
Back to top

PostPosted: Mon 30 May 2005, 04:19    Post subject:  

May I just ask how you did it? If you format the drive as a boot device and then install Puppy on it, the boot files will be wiped out by the setup program!?!
Back to top
Display posts from previous:   Sort by:   
Page 1 of 1 [9 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0422s ][ Queries: 12 (0.0090s) ][ GZIP on ]