Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 31 Oct 2014, 02:14
All times are UTC - 4
 Forum index » Advanced Topics » Cutting edge
apt-get on puppy?
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
elliboy
Guest


PostPosted: Mon 10 Oct 2005, 18:55    Post_subject:  apt-get on puppy?  

Hey, I use debian on my host and puppy on my client. I have copyed over a couple binaries and liberaries and am working on getting apt-get to work with puppy linux. Everything seems to be in order I can successfully do an "apt-get update" and it recognizes all my sources. the problem seems to be in dpkg. when I apt-get install something i get this message:

"E: sub process /usr/bin/dpkg returned with an error code (1)"

to get something a little more in depth I "dpkg -i"ed a packaged and got this:

"dpkg: couldn't extract control file."

okay I know my idea is a little crazy but i think its worth a try. If anyone has an idea let me know. Thanks!
Back to top
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Mon 10 Oct 2005, 21:00    Post_subject:  

Good plan. Smile

Are there front ends to apt get that would be suitable for Puppy?

_________________
Puppy WIKI
Back to top
View user's profile Send_private_message Visit_website 
elliboy
Guest


PostPosted: Tue 11 Oct 2005, 19:25    Post_subject:  

i dont think i will use any gui. it takes up space and its kinda unpractical. But if you had apt-get you could apt-get install any gui you wanted.

I got dpkg working now im having some other problem... i will tell you guys if i ever have it working all the way. Post here if you have information that might help me.
Back to top
rarsa


Joined: 29 May 2005
Posts: 3053
Location: Kitchener, Ontario, Canada

PostPosted: Wed 12 Oct 2005, 00:27    Post_subject:  

Great!

I've actually had slapt-get working in Puppy. Puppy is mostly compatible with the slackware binaries.

The problem I found was that it does not recognize that some libraries and dependencies are already installed, so it tries to download and install them, sometimes with incompatible versions.

If you try to install anything X, it will try to download the full X. I was planning to get back working on that based on priority. I was thinking on 'manually' creating the already installed package list to fool slapt-get.

It was actually not too difficult. after Installing the slapt-get dependencies, it worked (although as I said, corrupted all my pup001 file).

It's still on my list of things to do. I'm waiting for Barry to give me a hint on where are his priorities.
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Cutting edge
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0467s ][ Queries: 12 (0.0052s) ][ GZIP on ]