Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 26 Nov 2014, 21:41
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
"Script-fu" errors when running Web-O-Tine in GIMP
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
jcagle

Joined: 29 Sep 2005
Posts: 634

PostPosted: Tue 11 Oct 2005, 22:05    Post_subject:  "Script-fu" errors when running Web-O-Tine in GIMP  

I'm trying to run Webotine in GIMP. It works well until I hit "OK".

Quote:

GIMP Message

WARNING: Plug-In "script-fu"
(/usr/lib/gimp/2.0/plug-ins/script-fu)
called deprecated procedure 'gimp-channel-ops-duplicate'.
It should call 'gimp-image-duplicate' instead!

Web-O-Tine Message
Error while executing
(script-fu-webotine 1 2 "webotine.html" "." "webotine" "" 0 0 2
FALSE FALSE)
ERROR: unbound variable (errorbj carvert)


Don't know if there are many people who know much about GIMP to help out, but I figured I'd give this a try.
Back to top
View user's profile Send_private_message AIM 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Tue 11 Oct 2005, 22:54    Post_subject:  

The only thing I can think of is that gimp runs mtpaint
and gimp2 runs gimp from command line

and maybe this is confusing the plug in . . .

_________________
Puppy WIKI
Back to top
View user's profile Send_private_message Visit_website 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Tue 11 Oct 2005, 23:35    Post_subject:  

This looks like a version-conflict. The warning "depreciated" means, this function should not be used any more.

It seems the plugin was written for an older version of Gimp.
So a newer version of the plugin might help.

Mark
Back to top
View user's profile Send_private_message Visit_website 
jcagle

Joined: 29 Sep 2005
Posts: 634

PostPosted: Wed 12 Oct 2005, 08:09    Post_subject:  

hmm...Only problem was that was the only version of that script that I saw.

Grafpup came with GIMP 2.2.3...maybe I should switch back to GIMP 2.0?
Back to top
View user's profile Send_private_message AIM 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Wed 12 Oct 2005, 08:23    Post_subject:  

I don't know exactly what it does, but it seems to work in the Gimp of Puppy 1.0.5.

Opened an image, selected a folder when it asked for, and had a new file webotine-1-1.jpg afterwards.

Used this script:
http://registry.gimp.org/plugin?id=2821

Mark
Back to top
View user's profile Send_private_message Visit_website 
jcagle

Joined: 29 Sep 2005
Posts: 634

PostPosted: Wed 12 Oct 2005, 08:33    Post_subject:  

webotine basically guillotines images and puts then in HTML tables so they're put back together in HTML code. It's kind of like image maps but different as you have more than one image.
Back to top
View user's profile Send_private_message AIM 
jcagle

Joined: 29 Sep 2005
Posts: 634

PostPosted: Wed 12 Oct 2005, 08:35    Post_subject:  

now I'm getting "Too many error messages"
Back to top
View user's profile Send_private_message AIM 
jcagle

Joined: 29 Sep 2005
Posts: 634

PostPosted: Wed 12 Oct 2005, 08:37    Post_subject:  

ok, back down to those same two messages.
Back to top
View user's profile Send_private_message AIM 
Nathan F


Joined: 08 Jun 2005
Posts: 1760
Location: Wadsworth, OH (occasionally home)

PostPosted: Wed 12 Oct 2005, 09:30    Post_subject:  

jcagle-
Remember that the version of Gimp I put into grafpup is an "unstable" development release. Script-fu is one of the areas they still have to work on. I've encountered many such errors in this version.

This can be avoided by running the official gimp package Barry put together for the unleashed suite. Just don't try it in grafpup as the two versions will conflict.

I've gotten an even newer development release compiled and running but it seems to have many of the same errors when running script-fu. Basically the scripts need updatingand no one's bothered yet. It's still got a lot going for it, especially with changes in the user interface. I may go back to a more stable release if some of these problems persist, however.

Nathan
Back to top
View user's profile Send_private_message AIM YIM MSNM 
Guest
Guest


PostPosted: Wed 12 Oct 2005, 10:22    Post_subject:  

ok, I'll go back to Barry's version for now.
Back to top
jcagle

Joined: 29 Sep 2005
Posts: 634

PostPosted: Wed 12 Oct 2005, 12:31    Post_subject:  

By the way, that was me. I just forgot to log in. I'm at school right now.
Back to top
View user's profile Send_private_message AIM 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0595s ][ Queries: 12 (0.0069s) ][ GZIP on ]