Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 30 Jun 2015, 15:45
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking » Ethernet
3COM PCMCIA network card won't work in Toshiba 430CDT!
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 2 of 2 Posts_count   Goto page: Previous 1, 2
Author Message

Joined: 20 Jan 2006
Posts: 6698
Location: lisbon

PostPosted: Fri 08 Feb 2008, 04:08    Post_subject:  

Well, never having used any pcmcia devices I'm not sure what modules are required. There's this resource here:


And this puppy thread here:


where Pakt says:

- 3Com 3CXFE574BT Megahertz 10/100 LAN PC Card with XJACK connector. The network-wizard detects this automatically and loads module '3c574_cs'. Just click DHCP and the card works perfectly. This card has a special connector that pops out - doesn't need an adapter cable (dongle).

Out of curiousity, how have you installed puppy to the toshiba laptop, using frugal, or full, install?
Back to top
View user's profile Send_private_message 

Joined: 25 Mar 2008
Posts: 2

PostPosted: Tue 25 Mar 2008, 10:44    Post_subject:  

Caneri wrote:

I recently loaded Puppy on a Gateway Solo P2.

I had to go back to 2.13 to get the pcmcia 3comm to work. I used 3c59x for eth0 on the 3Comm pcmcia card

Try 2.13 and see if your 3comm is recognized. My driver was there and worked well.

EDIT: If it does work the drivers are in zdrv_2.13.sfs


Caneri- I can't thank you enough - I too loaded Puppy on a Gateway Solo P2, but was having a hard time getting Puppy to recognize the 3Com PCMCIA card. I followed your advice and loaded Puppy 2.13 into ram and figured out which driver I needed which was indeed 3c59x. In retrospect, I should have just loaded each module one by one until I loaded the correct one.

Thanks again for your help!
Back to top
View user's profile Send_private_message 

Joined: 22 Feb 2008
Posts: 39

PostPosted: Sun 04 May 2008, 22:08    Post_subject: Toshiba 315CDS using PCMCIA
Sub_title: Surfing Like Freddy

I had hell for a bit, but then pieced it together from the forum. Set the BIOS to accept Cardbus 16, and it will leave IRQ 11 alone long enough to recognize the card. Get the newest kernel, since the old one is deprecated and will kill the pcmcia. Best success with puppy 3.99 beta. Pupeez (the logical choice) didn't work, for some reason, even though it has the same kernel. Go figure.
Back to top
View user's profile Send_private_message 

Joined: 03 Oct 2008
Posts: 95
Location: arlington texas

PostPosted: Sat 10 Oct 2009, 00:26    Post_subject:  

muggins wrote:
Two useful sites, for linux on toshiba laptops, are:



From the latter came this link:


Don't use the PC-BUS option in BIOS setup.

This is for a toshiba Satellite Pro 430. Do you have this option in your Bios, and does disabling it make any difference?

this above quote solved my issue with a satellite 2535 cds buy changin bios i can now get on line(and yes its a old thread but worked so thanx)Ive spent many hours reading and searching
Back to top
View user's profile Send_private_message 

Joined: 15 Oct 2009
Posts: 3

PostPosted: Thu 15 Oct 2009, 11:38    Post_subject:  

I've also got my 3C589D pcmcia card working with changing the BIOS setting from PCMC-compatible to Cardbus / 16-bit, using the 3c589_cs module.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 2 of 2 Posts_count   Goto page: Previous 1, 2
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Networking » Ethernet
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0516s ][ Queries: 12 (0.0041s) ][ GZIP on ]