Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 30 Aug 2014, 14:53
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
1.0.5 Chubby Puppy HD install does not load USB driver.
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
cplater


Joined: 11 Jun 2005
Posts: 56
Location: Huntsville, Alabama

PostPosted: Wed 12 Oct 2005, 12:59    Post_subject:  1.0.5 Chubby Puppy HD install does not load USB driver.  

Anybody seen this before and know the fix?

I've installed 1.0.5 Chubby over a 1.0.4 version a fat32 partition. It booted fine from CD but the HD boot fails to load the usb driver and pauses. It does continue but the mouse is USB only so I need it. The error messages say:
/lib/modules/2.4.29/scsi/usbcore.0.gz not found?

It may be a grub thing but I'm not sure. I manually removed the old puppy version and did a fresh install.

This is my current grub file which used to work with 1.0.4 fine:
Code:

 generated by 'grubconfig'.  Thu Aug  4 15:50:17 2005
#
# Start GRUB global section
timeout 20
color light-gray/blue black/light-gray
# End GRUB global section
# Linux bootable initrd config begins
#
title Slackware 10.2
   root (hd1,0)
   kernel /boot/vmlinuz root=/dev/hdd1 noinitrd
title Puppy Linux
   rootnoverify (hd0,0)
   kernel (hd0,6)/vmlinuz root=/dev/ram PFILE=pup001-none-262144
   initrd (hd0,6)/image.gz
   boot
title WindozeXP
   rootnoverify (hd0,0)
   chainloader +1


Any body seen this before?
Back to top
View user's profile Send_private_message 
Cerberus

Joined: 13 Oct 2005
Posts: 57

PostPosted: Fri 14 Oct 2005, 23:23    Post_subject:  

i have teh same problem, but i hooked up an old PS/2 mouse in the meantime
Back to top
View user's profile Send_private_message MSNM 
Guest
Guest


PostPosted: Mon 17 Oct 2005, 16:13    Post_subject:  

I fingered it out. Needed to add the size to my grub statement to get the drivers loaded. The default ram disk size is too small.
Was:
Code:

title Puppy Linux
   rootnoverify (hd0,0)
   kernel (hd0,6)/vmlinuz root=/dev/ram FILE=pup001-none-262144
   initrd (hd0,6)/image.gz
   boot


Now:
Code:

title Puppy Linux
   rootnoverify (hd0,0)
   kernel (hd0,6)/vmlinuz root=/dev/ram ramdisk_size=13312 PFILE=pup001-none-262144
   initrd (hd0,6)/image.gz
   boot


I got the size from the config file, isolinux.cfg, on the CD.
Back to top
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0435s ][ Queries: 12 (0.0038s) ][ GZIP on ]