Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 18 Dec 2014, 17:08
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
Samsung ML2010
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [6 Posts]  
Author Message
rocar

Joined: 30 May 2006
Posts: 15
Location: Italy

PostPosted: Mon 05 May 2008, 11:13    Post subject:  Samsung ML2010  

I have one printing Samsung ML2010.
There is the driver for puppylinux?
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6690
Location: lisbon

PostPosted: Mon 05 May 2008, 22:25    Post subject:  

rocar,

you don't mention which version of puppy you're using. This detail may me relevant as some pupversions come with cups already installed, whereas with other versions, cups is an external package.

The openprinting site, for your printer, here, lists your printer as working perfectly. You've got the choice of the splix driver, or the gutenberg gdi .ppd file. As the former needs compiling, (or you can try an already compiled version if you google, or if you ask someone might compile for you), why not try downloading the gutenberg 2010-gdi.ppd & save this to /usr/share/cups/model directory, and see whether you can use the cups web printer interface to choose this as your printer.
Back to top
View user's profile Send private message 
rocar

Joined: 30 May 2006
Posts: 15
Location: Italy

PostPosted: Wed 07 May 2008, 11:55    Post subject: PUPPYLINUX 2.13.  

It's PUPPYLINUX 2.13.

I did not find the directory
/usr /share /cups /model
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9354
Location: Stratford, Ontario

PostPosted: Wed 07 May 2008, 16:12    Post subject:  

Why not make the jump to Puppy 4? It has CUPS built in.
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6690
Location: lisbon

PostPosted: Wed 07 May 2008, 19:37    Post subject:  

Hi Rocar,

Well you can either do as rcrsn51 suggests & try the latest pupversion, or if you want to continue with pup2.13, then the simplest method is to download the .ppd file above, and save this to /root, then download & install Pakt's cups .pup(19Mbytes) from here, then follow the steps to install the printer as the default.
Back to top
View user's profile Send private message 
rocar

Joined: 30 May 2006
Posts: 15
Location: Italy

PostPosted: Thu 08 May 2008, 08:18    Post subject:  Funziona  

It works!

Important.
Pakt's cups. Pup requires
Name: root
Location: woofwoof
Installing the printer is also fairly intuitive.

Unfortunately not use version 4 of PUPPYLINUX
I have an Italian version 2.13.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [6 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0433s ][ Queries: 12 (0.0035s) ][ GZIP on ]