Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Oct 2014, 19:59
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
How to disable screen saver? (solved)
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Author Message
LordQwerty

Joined: 29 May 2008
Posts: 13

PostPosted: Sat 31 May 2008, 08:28    Post_subject:  How to disable screen saver? (solved)  

hi,

another newby question ... sorry it's me again ...

Is there a way to disable the screensaver, so that my screen is not turning black after a few minutes?
I can do this, but it is only in the same session. After I rebooted the computer, all settings are gone.
So, is there a way to save this option to disable the screensaver?

tnx.

Edited_time_total
Back to top
View user's profile Send_private_message 
spluthier

Joined: 29 May 2008
Posts: 10

PostPosted: Sat 31 May 2008, 19:42    Post_subject:  

Hey,

Did you ever find out how to do this? I'm trying to do the same thing. After the computer reboots, the screensaver is re-enabled.
Back to top
View user's profile Send_private_message 
trapster


Joined: 28 Nov 2005
Posts: 2009
Location: Maine, USA

PostPosted: Sat 31 May 2008, 20:30    Post_subject:  

Try adding xset s off to /root/.xinitrc before exec $CURRENTWM
_________________
trapster
Maine, USA

Asus eeepc 1005HA PU1X-BK
Frugal install: Puppeee4.31 + 1.0, Puppy4.10 + Lupu52
Currently using Slacko AND lupu52 w/ fluxbox
Back to top
View user's profile Send_private_message Visit_website 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Sat 31 May 2008, 21:00    Post_subject:  

From the menu Puppy 4
    Menu / Desktop / pupx / Screensaver
    untick 'enable screensaver'

Does that help?
Smile

_________________
Puppy WIKI
Back to top
View user's profile Send_private_message Visit_website 
LordQwerty

Joined: 29 May 2008
Posts: 13

PostPosted: Sun 01 Jun 2008, 05:43    Post_subject:  

Lobster,

Thank you for your reply.

Nope that won't help, that's the option I found myself to Wink

This setting is lost when you restart the computer, so it is only disabled for the current session (as mentioned when you change this setting)
Back to top
View user's profile Send_private_message 
spluthier

Joined: 29 May 2008
Posts: 10

PostPosted: Sun 01 Jun 2008, 17:43    Post_subject:  

trapster wrote:
Try adding xset s off to /root/.xinitrc before exec $CURRENTWM


I tried this and it doesn't seem to work. I created a line inbetween a comment field and the exec $CURRENTWM field, and to no avail, the screensaver still enagages.

Also booted into the BIOS to see if there was a power-saving feature that was causing problems and didn't see anything.

Keep the suggestions coming! Smile
Back to top
View user's profile Send_private_message 
trapster


Joined: 28 Nov 2005
Posts: 2009
Location: Maine, USA

PostPosted: Sun 01 Jun 2008, 17:52    Post_subject:  

Try xset -s off in a console.
Then open the gui xsetter (Gxset from the menu) and see if the screensaver has been disabled.

I first opened the gui and checked to make sure it was enabled. Then I closed the gui.
Then I ran xset -s off
Reopened the gui and screensaver was not enabled. The command in the console worked for me by changing the gui.
I did not actually reboot to try it, but if the command worked, it would get set when .xinitrc ran.

Unless.....you're executing a wm prior to where you put it in .xinitrc
I actually bail out of .xinitrc a little early depending on which wm I use.

_________________
trapster
Maine, USA

Asus eeepc 1005HA PU1X-BK
Frugal install: Puppeee4.31 + 1.0, Puppy4.10 + Lupu52
Currently using Slacko AND lupu52 w/ fluxbox
Back to top
View user's profile Send_private_message Visit_website 
LordQwerty

Joined: 29 May 2008
Posts: 13

PostPosted: Mon 02 Jun 2008, 05:49    Post_subject:  

I actually solved it by putting the xset s off command as a script in the startup folder
Back to top
View user's profile Send_private_message 
LordQwerty

Joined: 29 May 2008
Posts: 13

PostPosted: Mon 02 Jun 2008, 10:49    Post_subject:  

I guess there must be some kind of power-manager look-alike in Linux, because the display is powered off after several minutes.

Maybe someone has a clue?
Back to top
View user's profile Send_private_message 
spluthier

Joined: 29 May 2008
Posts: 10

PostPosted: Tue 03 Jun 2008, 22:15    Post_subject:  

Quote:
I actually solved it by putting the xset s off command as a script in the startup folder


Did this too with the same result you had - computer screen still goes black. I'm surprised at just how difficult this is turning out to be. haha

Keep me posted if you, or anyone on the forum figures out a way to disable the screensaver/power management system in puppy. (BTW I've checked my BIOS for a power management setting and didn't find anything - Thinkpad 600)

Cheers.
Back to top
View user's profile Send_private_message 
erikson


Joined: 27 Feb 2008
Posts: 735
Location: Ghent, Belgium

PostPosted: Wed 04 Jun 2008, 05:10    Post_subject:  

Cfr http://www.murga-linux.com/puppy/viewtopic.php?t=29853
_________________
If it ain't broke, don't fix it. --- erikson
hp/compaq nx9030 (1.6GHz/480MB/37.2GB), ADSL, Linksys wireless router
http://www.desonville.net/
Puppy page: http://www.desonville.net/en/joere.puppy.htm

Back to top
View user's profile Send_private_message Visit_website 
dansolo


Joined: 20 Jun 2007
Posts: 65
Location: Argentina, Buenos Aires

PostPosted: Sun 08 Jun 2008, 11:39    Post_subject:  

Another way:

1- Do wath Lobster said
(be sure that (in Pupx) you click the 'Exit apply and save settings' button)
Lobster wrote:
From the menu Puppy 4
    Menu / Desktop / pupx / Screensaver
    untick 'enable screensaver'


2- Then, in rox, go to root directory.
3- Right clik on 'eye' button
(now you can see shared files witch names have a dot before the file name)
4- Right clik over '.xset.sh' file.
5- In the contextual menu go to " File '.xset.sh' / Permissions /"
6- Be sure that the command 'a+x (Make executable/searchable) is selected.
7- Clik the 'yes' button.

Please come here and reply us your results.
Thank you.

_________________
Mr. Green Acer Aspire 3690 full Puppy Laptop
Mr. Green An old Puppy Pentium II to control machines by paralel port in my atelier.
Arrow http://www.ceramicart.com.ar
Back to top
View user's profile Send_private_message Visit_website 
LordQwerty

Joined: 29 May 2008
Posts: 13

PostPosted: Tue 10 Jun 2008, 12:54    Post_subject: How to disable screen saver? (Solved)  

Actually I did it with a conbination of:

1) putting the xset s off command as a script in the startup folder

2) http://www.murga-linux.com/puppy/viewtopic.php?t=29853

So this case is solved Smile
Back to top
View user's profile Send_private_message 
erikson


Joined: 27 Feb 2008
Posts: 735
Location: Ghent, Belgium

PostPosted: Tue 10 Jun 2008, 14:29    Post_subject:  

Actually the issue is confusing because one should indeed think of setting both screensaver and dpms (display power management signaling) parameters.

This can be done in one, combined xset command.
Code:
xset s off -dpms

For Puppy series 4, the command can be put in a separate script placed in the startup folder (which is new to Puppy 4).

For Puppy series 3, the command can be put in /root/.xinitrc (or in /etc/rc.d/rc.local).

---
NB: There are still other ways, better integrated with xset gui's, and involving the /root/.xset.sh script. I'm working on a detailed, fully documented howto.

_________________
If it ain't broke, don't fix it. --- erikson
hp/compaq nx9030 (1.6GHz/480MB/37.2GB), ADSL, Linksys wireless router
http://www.desonville.net/
Puppy page: http://www.desonville.net/en/joere.puppy.htm

Back to top
View user's profile Send_private_message Visit_website 
sideburns

Joined: 27 Aug 2008
Posts: 56
Location: Freedonia

PostPosted: Sun 21 Sep 2008, 18:21    Post_subject:  

Thank you, you've just helped me solve the opposite problem. I don't like having to turn the screensaver back on every time I restart. (This seems to be the default in Dingo.) I've just edited the line in .xinitrc that sets up the screensaver, and will be rebooting to see how it worked.
_________________
Registered Linux user #470359
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0762s ][ Queries: 12 (0.0046s) ][ GZIP on ]