Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 20 Oct 2014, 14:39
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Desktop
Wbar: a fancy launchbar (using Imlib2)
Post new topic   Reply to topic View previous topic :: View next topic
Page 8 of 11 [158 Posts]   Goto page: Previous 1, 2, 3, ..., 6, 7, 8, 9, 10, 11 Next
Author Message
Eyes-Only


Joined: 10 Aug 2006
Posts: 1046
Location: La Confederation Abenaquaise

PostPosted: Mon 14 Jul 2008, 21:13    Post subject:  

I was just sitting here thinking how neat you're avatar is CatDude. Smile I don't ever recall it doing "that" before with the eyes! Very cool effect indeed my fellow friend! Normally I don't care for avatars that "do things" as a lot of people latch onto some that can be down-right gruesome (I have come to mind "everyone's favourite" the frustrated computerist bashing his head bloody on the keyboard---ghastly thing!) and even others with frame rates that can be dangerous for epileptics such as myself.

But yours deserves an award for being both tasteful and attractive. An Olympic Gold Medal from me CatDude and two thumbs up!

Amicalement/In Friendship,

Eyes-Only
"L'Peau-Rouge"

_________________
*~*~*~*~*~*
Proud user of LXpup and 3-Headed Dog. Cool
*~*~*~*~*~*
Back to top
View user's profile Send private message 
CatDude


Joined: 03 Jan 2007
Posts: 1484
Location: UK

PostPosted: Tue 15 Jul 2008, 09:47    Post subject:  

Hello Eyes-Only

Eyes-Only wrote:

I was just sitting here thinking how neat you're avatar is CatDude. Smile I don't ever recall it doing "that" before with the eyes! Very cool effect indeed my fellow friend!


Your absolutely correct my friend, it never used to, i got bored and thought i would add a bit of life to it.
The strange thing is, there appears to be a quick flash of white in the eyes, which is not part of the animation.
If you right click on the image and save it to your computer, then view it with mtpaint you will see that it does not
do the white flash, i suppose it must have something to do with the way the forum works. Rolling Eyes

Eyes-Only wrote:

...(I have come to mind "everyone's favourite" the frustrated computerist bashing his head bloody on the keyboard---ghastly thing!)...


I must admit that i did in fact find that particular avvy quite amusing. (But i do have a pretty warped/sick sense of humour Laughing )

Eyes-Only wrote:

But yours deserves an award for being both tasteful and attractive. An Olympic Gold Medal from me CatDude and two thumbs up!


Thank you very much, i shall wear it with pride. Smile Razz

CatDude
.

_________________

Back to top
View user's profile Send private message 
wjaguar

Joined: 21 Jun 2006
Posts: 279

PostPosted: Tue 15 Jul 2008, 10:41    Post subject:  

CatDude wrote:
The strange thing is, there appears to be a quick flash of white in the eyes, which is not part of the animation.
If you right click on the image and save it to your computer, then view it with mtpaint you will see that it does not
do the white flash, i suppose it must have something to do with the way the forum works.

No, it is a bug in the animation. The frame #0 has eyes filled with transparent color, which the subsequent frames then draw over - and when animation gets cycled, such an area apparently gets cleaned to background, which in this GIF is set to white. Merge frames #0 and #1 to get rid of it.
Back to top
View user's profile Send private message 
CatDude


Joined: 03 Jan 2007
Posts: 1484
Location: UK

PostPosted: Tue 15 Jul 2008, 11:28    Post subject:  

Hello wjaguar

wjaguar wrote:

No, it is a bug in the animation. The frame #0 has eyes filled with transparent color, which the subsequent frames then draw over - and when animation gets cycled, such an area apparently gets cleaned to background, which in this GIF is set to white. Merge frames #0 and #1 to get rid of it.


Well spotted mate, done as you suggested and now it looks as it was intended to. Cool

Thanks from one cat to another Wink

CatDude
.

_________________

Back to top
View user's profile Send private message 
Eyes-Only


Joined: 10 Aug 2006
Posts: 1046
Location: La Confederation Abenaquaise

PostPosted: Wed 16 Jul 2008, 17:57    Post subject:  

I noticed the white too guys---odd thing is that when I downloaded it to my computer and checked it in Mirage---no white flashy thing. How odd!? I wonder why?

Yeah, I know! I know! "Simple things amuse simple minds!" Well... ya just can't get more simple than MY MIND! Razz LOL!

Amicalement,

Eyes-Only
"L'Peau-Rouge"

P/S: CatDude? Don't wear the "Gold" medal mate!---it'll rust. You think I can afford to pass out REAL ones? Sheesh! Twisted Evil

_________________
*~*~*~*~*~*
Proud user of LXpup and 3-Headed Dog. Cool
*~*~*~*~*~*
Back to top
View user's profile Send private message 
CatDude


Joined: 03 Jan 2007
Posts: 1484
Location: UK

PostPosted: Thu 17 Jul 2008, 08:49    Post subject:  

Eyes-Only wrote:

P/S: CatDude? Don't wear the "Gold" medal mate!---it'll rust. You think I can afford to pass out REAL ones? Sheesh! Twisted Evil


It will be fine, upon first recieving it i gave it several coats of laquer to keep it from tarnishing.

CatDude
.

_________________

Back to top
View user's profile Send private message 
CatDude


Joined: 03 Jan 2007
Posts: 1484
Location: UK

PostPosted: Sun 20 Jul 2008, 18:29    Post subject:  

Hello all

For those people who would like a different coloured font on their wbar
here are 19 (yes, nineteen) in various colour combinations to choose from.

Only the wbar executable is included (well 19 of them actually) Laughing

They were all compiled in Dingo using wbar-v1.3.3 with the offset patch,
the same one as posted Here

It requires the same imlib2-1.4.0.pet as posted by Wolf Pup Here


When extracted you will see the following directory:

    wbar-v1.3.3-offset-patch-different-coloured-fonts

Inside of that directory you will find the following directories:

    Black-Text-Coloured-Shadow
    blue
    green
    red
    white
    yellow

    Coloured-Text-Black-Shadow
    blue
    cyan
    green
    red
    yellow

    Coloured-Text-White-Shadow
    blue
    cyan
    green
    red
    yellow

    White-Text-Coloured-Shadow
    black
    blue
    green
    red


Also included is a README explaining how to use them.

Some of the colour combinations may not be to everyones taste,
but i included as many as i could.

Thanks go to Dougal for pointing me in the right direction as to what code to change.

I hope you find one that you like.

CatDude
.
wbar-v1.3.3-offset-patch-19-different-coloured-fonts.tar.gz
Description 
gz

 Download 
Filename  wbar-v1.3.3-offset-patch-19-different-coloured-fonts.tar.gz 
Filesize  908.8 KB 
Downloaded  778 Time(s) 

_________________

Back to top
View user's profile Send private message 
battleshooter


Joined: 14 May 2008
Posts: 1095
Location: Australia

PostPosted: Sat 26 Jul 2008, 23:39    Post subject:  

It seems that no one in this forum has had the same problems as I have in trying to get wbar going. I've got it going now, but I thought it was pretty strange.

Before I got wbar going, whenever I typed "wbar" into the console it gave me"

Code:

Using /root/.wbar config file.
Using a Super Bar.


and I could see nothing. I looked at a couple different forums and I stubled upon the strangest fix: Just click where the bar should be, I did and it appeared! How weird is that? What did I do to get so strange a response? I used someone's patched pet file, sorry, I can't remember whose it was.

Edit: I remember! T'was CatDude's here
Not blaming CatDude in anyway BTW

Last edited by battleshooter on Sat 26 Jul 2008, 23:55; edited 1 time in total
Back to top
View user's profile Send private message 
battleshooter


Joined: 14 May 2008
Posts: 1095
Location: Australia

PostPosted: Sat 26 Jul 2008, 23:51    Post subject:  

I don't know why this wbar doesn't like me Sad

I can't configure it or anything cause I keep getting after I type eg. -config conf-file :

Code:

Using /root/.wbar config file.
Using a Super Bar.


Then nothing happens. Sigh.
Back to top
View user's profile Send private message 
battleshooter


Joined: 14 May 2008
Posts: 1095
Location: Australia

PostPosted: Sun 27 Jul 2008, 05:13    Post subject:  

Oh, oopps Embarassed

Right, I get it now, super bar runs cause that's the script that's running and the reason why I get it when I type in
Code:
-config conf-file
is cause that's the mode it's running in. Right! I get it! Noob I know Embarassed
Back to top
View user's profile Send private message 
battleshooter


Joined: 14 May 2008
Posts: 1095
Location: Australia

PostPosted: Sun 27 Jul 2008, 05:30    Post subject:  

Yes, I know I'm back again. Terrible I know, 4 posts back to back. I'd delete them if I could, I hope I'll not be hung as a spammer Laughing

This is just a yes or no question: Can wbar have shortcuts to directories? It doesn't seem to like me placing a directory on it. It says
Code:
sh: /mnt/hda5: is a directory
Back to top
View user's profile Send private message 
WhoDo


Joined: 11 Jul 2006
Posts: 4441
Location: Lake Macquarie NSW Australia

PostPosted: Sun 27 Jul 2008, 05:47    Post subject:  

battleshooter wrote:
Can wbar have shortcuts to directories? It doesn't seem to like me placing a directory on it. It says
Code:
sh: /mnt/hda5: is a directory

wbar expects something that can be executed. A directory cannot be executed. Remember, it's a "launch bar".

To do what you want you might try this...
Code:
rox --dir=/mnt/hda5
.
I've never tried it myself, but something like that should open the directory you are seeking. If not, open a console and type rox --help to see the parameters needed.

Hope that helps. Don't worry about the noob questions; most of us have been there before. I'm just surprised you didn't get any response to your earlier posts. Shocked

_________________
Actions speak louder than words ... and they usually work when words don't!
SIP:whodo@proxy01.sipphone.com; whodo@realsip.com
Back to top
View user's profile Send private message 
battleshooter


Joined: 14 May 2008
Posts: 1095
Location: Australia

PostPosted: Mon 28 Jul 2008, 00:51    Post subject:  Solved!  

*Big grin*

Sweetness! Thanks WhoDo! It worked! 'Preciate your empathy for my noobiness too Smile Thanks!
Back to top
View user's profile Send private message 
blacktulipgirl


Joined: 27 Aug 2008
Posts: 31

PostPosted: Fri 29 Aug 2008, 21:12    Post subject: ignore this post  

I installed the patched one, and it shows up like this:

I would like it to start up... BUT IT DOESN'T. I tried the help above and it doesn't come back when i click on the desktop after typing wbar into the console.

I'm still new at all this linux stuff, its v. exciting to be able to customize Smile I

Help!

Thanks, B

_________________
"I'm shiny, Captain." Kaylee on Firefly (my fave show of all time!)

Acer Aspire 3623 Laptop w/256MB RAM, 40G HD, Atheros AR5005G Wireless, Intel Celeron M, Running Puppy 4.0 Full Install!!!

I LOVE PUPPY!!!

Last edited by blacktulipgirl on Sat 30 Aug 2008, 03:24; edited 1 time in total
Back to top
View user's profile Send private message 
blacktulipgirl


Joined: 27 Aug 2008
Posts: 31

PostPosted: Sat 30 Aug 2008, 03:20    Post subject: It works finally! I'm going to bed  

I followed these directions and was finally able to have it work:



http://www.puppylinux.org/wiki/how-tos/easy/installing-wbar-program-launcher

Yippee!

B

_________________
"I'm shiny, Captain." Kaylee on Firefly (my fave show of all time!)

Acer Aspire 3623 Laptop w/256MB RAM, 40G HD, Atheros AR5005G Wireless, Intel Celeron M, Running Puppy 4.0 Full Install!!!

I LOVE PUPPY!!!
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 8 of 11 [158 Posts]   Goto page: Previous 1, 2, 3, ..., 6, 7, 8, 9, 10, 11 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Desktop
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1152s ][ Queries: 13 (0.0218s) ][ GZIP on ]