Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 31 Oct 2014, 19:49
All times are UTC - 4
 Forum index » Advanced Topics » Cutting edge
Improved Network Wizard (and rc.network)
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 40 [596 Posts]   Goto page: Previous 1, 2, 3, 4, ..., 38, 39, 40 Next
Author Message
urban soul


Joined: 05 Mar 2008
Posts: 276
Location: "Killing a nerd is not as much fun as ist sounds" B.Simpson

PostPosted: Mon 21 Jul 2008, 14:25    Post subject:  

Hi, sounds great. - can you put the WPA driver specs into a separate config-file ? Otherwise every time a new driver is compiled by tempestuous the wizard itself has to be modified.
Back to top
View user's profile Send private message Visit poster's website 
Keef


Joined: 20 Dec 2007
Posts: 639
Location: Staffordshire

PostPosted: Mon 21 Jul 2008, 16:31    Post subject:  

Dougal,

When I run it from the command line I get:-
/usr/bin/net-setup.sh: line 1341: scanpci: command not found

When I try to save a profile I get:-
/usr/sbin/wag-profiles.sh: line 706: : No such file or directory


This was with the original version - I have since tried the new one, but could not get a connection (did not detect wlan0) even after several reboots. Now reverted to the first, and have got back on-line. No save though!
Back to top
View user's profile Send private message 
prit1


Joined: 03 Jan 2008
Posts: 540
Location: Los Angeles

PostPosted: Tue 22 Jul 2008, 01:43    Post subject:  

@Dougal:

I tried your latest version. This time, it created the network connection. This is better than the last time.

But when I rebooted, the network did not get enabled. I had to load the profile again, and run auto dhcp to get the network running. Tried rebooting once again with the same result.

Here is an error message I noticed when running net-setup.sh from the prompt.
Code:

Failure (Operation not supported)
/usr/sbin/net-setup.sh: line 622: 4171 Terminated  gxmessage -center -bg "orange" -buttons "" -title "Puppy Network Wizard" "Configuring interface..."
Error, ra0: dhcpd not running

_________________
Macpup - The beauty of linux | Pritlog - Simple blog app
Back to top
View user's profile Send private message 
Dougal


Joined: 19 Oct 2005
Posts: 2505
Location: Hell more grotesque than any medieval woodcut

PostPosted: Tue 22 Jul 2008, 05:11    Post subject:  

urban soul wrote:
Hi, sounds great. - can you put the WPA driver specs into a separate config-file ? Otherwise every time a new driver is compiled by tempestuous the wizard itself has to be modified.

It would be easy to do, but I'm not sure worth it, since that will just have to be updated, just like the wizard, and it just makes things more scattered...

_________________
What's the ugliest part of your body?
Some say your nose
Some say your toes
But I think it's your mind
Back to top
View user's profile Send private message 
Dougal


Joined: 19 Oct 2005
Posts: 2505
Location: Hell more grotesque than any medieval woodcut

PostPosted: Tue 22 Jul 2008, 05:18    Post subject:  

Keef wrote:
When I run it from the command line I get:-
/usr/bin/net-setup.sh: line 1341: scanpci: command not found

That means that Barry hasn't included scanpci in Dingo (which is part of the Xorg package).

Quote:
When I try to save a profile I get:-
/usr/sbin/wag-profiles.sh: line 706: : No such file or directory

Ok, I'll have another look at it.

_________________
What's the ugliest part of your body?
Some say your nose
Some say your toes
But I think it's your mind
Back to top
View user's profile Send private message 
Dougal


Joined: 19 Oct 2005
Posts: 2505
Location: Hell more grotesque than any medieval woodcut

PostPosted: Tue 22 Jul 2008, 05:28    Post subject:  

prit1 wrote:
when I rebooted, the network did not get enabled. I had to load the profile again, and run auto dhcp to get the network running. Tried rebooting once again with the same result.

Can you try looking in /tmp/bootsysinit.log and see what kind of messages are there?

Quote:
Here is an error message I noticed when running net-setup.sh from the prompt.
Code:

Failure (Operation not supported)
/usr/sbin/net-setup.sh: line 622: 4171 Terminated  gxmessage -center -bg "orange" -buttons "" -title "Puppy Network Wizard" "Configuring interface..."
Error, ra0: dhcpd not running

That seems ok, it what you get after killing a dialog window.

_________________
What's the ugliest part of your body?
Some say your nose
Some say your toes
But I think it's your mind
Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7060
Location: Perth, Western Australia

PostPosted: Tue 22 Jul 2008, 05:55    Post subject:  

Dougal wrote:
Keef wrote:
When I run it from the command line I get:-
/usr/bin/net-setup.sh: line 1341: scanpci: command not found

That means that Barry hasn't included scanpci in Dingo (which is part of the Xorg package).

Quote:
When I try to save a profile I get:-
/usr/sbin/wag-profiles.sh: line 706: : No such file or directory

Ok, I'll have another look at it.

Yes I have. I've got it in 4.1 anyway. I don't recall if it got left out of 4.00, Surprised if I did, as my PupScan program uses it.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
tempestuous

Joined: 10 Jun 2005
Posts: 5275
Location: Australia

PostPosted: Tue 22 Jul 2008, 08:40    Post subject:  

Thanks for including the "Broadcast SSID" "Driver" "Hidden SSID" button label modification.

... when you do the next revision, can I just suggest a change in the order?
Between lines 531 and and 561 of wag-profiles.sh, I suggest shift the "Hidden SSID" stuff to the top, then "Broadcast SSID" next, then "Driver" at the bottom.
This would then result in a more logical graphical layout, as per attachment.
wpa-ap-scan.jpg
 Description   
 Filesize   4.5 KB
 Viewed   1973 Time(s)

wpa-ap-scan.jpg

Back to top
View user's profile Send private message 
prit1


Joined: 03 Jan 2008
Posts: 540
Location: Los Angeles

PostPosted: Tue 22 Jul 2008, 10:41    Post subject:  

@Dougal:

Here are the messages from bootsysinit.log:
Code:
...
...
  loading module rt2500
....
....
configuring network interface eth0
interface eth0 has not been configured... skipping
configuring network interface ra0
wireless scan with iwlist failed... skipping interface

_________________
Macpup - The beauty of linux | Pritlog - Simple blog app
Back to top
View user's profile Send private message 
prit1


Joined: 03 Jan 2008
Posts: 540
Location: Los Angeles

PostPosted: Tue 22 Jul 2008, 10:41    Post subject:  

Duplicate post.
_________________
Macpup - The beauty of linux | Pritlog - Simple blog app
Back to top
View user's profile Send private message 
Keef


Joined: 20 Dec 2007
Posts: 639
Location: Staffordshire

PostPosted: Tue 22 Jul 2008, 14:13    Post subject: Fat Free 3.01
Subject description: scanpci
 

I ran Pfind for scanpci and found
/usr/X11R7/lib/xorg/modules/libsanpci.la and
/usr/X11R7/lib/modules/libsanpci.la

Is this what the network wizard is looking for?
Back to top
View user's profile Send private message 
Dougal


Joined: 19 Oct 2005
Posts: 2505
Location: Hell more grotesque than any medieval woodcut

PostPosted: Tue 22 Jul 2008, 18:06    Post subject:  

tempestuous wrote:

... when you do the next revision, can I just suggest a change in the order?
Between lines 531 and and 561 of wag-profiles.sh, I suggest shift the "Hidden SSID" stuff to the top, then "Broadcast SSID" next, then "Driver" at the bottom.

Ok, I'll do that tomorrow.

_________________
What's the ugliest part of your body?
Some say your nose
Some say your toes
But I think it's your mind
Back to top
View user's profile Send private message 
Dougal


Joined: 19 Oct 2005
Posts: 2505
Location: Hell more grotesque than any medieval woodcut

PostPosted: Tue 22 Jul 2008, 18:11    Post subject:  

prit1 wrote:
Code:
...
...
  loading module rt2500
....
....
configuring network interface eth0
interface eth0 has not been configured... skipping
configuring network interface ra0
wireless scan with iwlist failed... skipping interface

It seems like it doesn't find anything with the wireless scan...
When you run "iwlist ra0 scan", does it detect anything?

_________________
What's the ugliest part of your body?
Some say your nose
Some say your toes
But I think it's your mind
Back to top
View user's profile Send private message 
Dougal


Joined: 19 Oct 2005
Posts: 2505
Location: Hell more grotesque than any medieval woodcut

PostPosted: Tue 22 Jul 2008, 18:17    Post subject: Re: Fat Free 3.01
Subject description: scanpci
 

Keef wrote:
I ran Pfind for scanpci and found
/usr/X11R7/lib/xorg/modules/libsanpci.la and
/usr/X11R7/lib/modules/libsanpci.la

Is this what the network wizard is looking for?

No, there should be a binary, /usr/X11R7/bin/scanpci, that is run. If it existed, running "scanpci" in a terminal would work...

_________________
What's the ugliest part of your body?
Some say your nose
Some say your toes
But I think it's your mind
Back to top
View user's profile Send private message 
Dougal


Joined: 19 Oct 2005
Posts: 2505
Location: Hell more grotesque than any medieval woodcut

PostPosted: Tue 22 Jul 2008, 18:18    Post subject:  

I've updated the attachment again, hopefully it will help solve the problem with saving profiles...
_________________
What's the ugliest part of your body?
Some say your nose
Some say your toes
But I think it's your mind
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 40 [596 Posts]   Goto page: Previous 1, 2, 3, 4, ..., 38, 39, 40 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Cutting edge
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0896s ][ Queries: 13 (0.0104s) ][ GZIP on ]