Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Oct 2014, 14:47
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
Want to boot to rdesktop login screen to remote server
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
maje

Joined: 03 Nov 2005
Posts: 3

PostPosted: Thu 03 Nov 2005, 12:45    Post_subject:  Want to boot to rdesktop login screen to remote server  

Hi!
I want to start remote desktop client automaticaly with the the ip to my server so the loginscreen comes up when I start puppy. I have puppy installed on my Hdd. How do I do this the easyest way? Please help a noob!
Back to top
View user's profile Send_private_message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Thu 03 Nov 2005, 12:55    Post_subject:  

You could edit /root/.xinitrc

Add a command as the second line, after "#!/bin/sh"

rdesktop -option &

It is important to add the "&" in the end.
This will have the effect, that rdesktop does not block the following commands, that launch the desktop.

Remember that you have the "mp" texteditor for the commandline, in case anything should go wrong...

For the -options, type "rdesktop --help" in a console.

Mark

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Thu 03 Nov 2005, 12:58    Post_subject:  

If you need your own IP, you could get it like this:

rdesktop `ifconfig |grep "P-t-P"| sed "s/^.*addr://" | sed "s/\w.*//"`

This would start rdesktop with your IP.
But I get an error there, so it seems rdesktop needs another parameter.
Try it out in a console, before you edit .xinitrc

I have no experience with rdesktop.

Mark
Back to top
View user's profile Send_private_message Visit_website 
maje

Joined: 03 Nov 2005
Posts: 3

PostPosted: Sat 05 Nov 2005, 04:50    Post_subject:  

Thanks it works. My only problem now is that when rdesktop autostart the puppy taskbar(tray) is visable and I don´t want it to be.I use the option -f for fullscreen and it works when I start Rdesktop manually. I read something about removing the taskbar by clicking a bomb icon but i can´t se that icon. Can someone help me.
Back to top
View user's profile Send_private_message 
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sat 05 Nov 2005, 06:10    Post_subject:  

You can start rdesktop after the desktop:

sleep 3 && rdesktop -option &

So here a pause (3 seconds) is started.
Meanwhile the rest of the script continues, as this pause runs as a background-process.

So your desktop should start, and after 3 seconds rdesktop.
Mabe you need 5 seconds, depends on your computer.
That should solve the taskbar-problem.

There also is another possibility.
If you want to run ONLY rdesktop, you can use rdesktop as the Desktop!
So NO jwm.

In this case, in .xinitrc ,replace "exec $CURRENTWM" with "exec rdesktop -options"


If this both does not help, you might need another Desktop like icewm.
It can be configured to show no taskbar (if you want that, I might help you).

The xkill (bomb) you mentioned was part of the fvwm95-Desktop, that you can install with pupget. But I am not shure if xkill still is included. I could upload that.

Mark
Back to top
View user's profile Send_private_message Visit_website 
GuestToo
Puppy Master

Joined: 04 May 2005
Posts: 4078

PostPosted: Sat 05 Nov 2005, 06:46    Post_subject:  

ifconfig will show your local ip address if you are behind a router
you can get your external ip address from a web page like this:
http://ipid.shat.net/iponly/
Back to top
View user's profile Send_private_message 
Guest
Guest


PostPosted: Sat 05 Nov 2005, 07:40    Post_subject:  

Thank you very much for your splended help. It works fine with the first alternative. I have no problem with the IP. Very Happy
Back to top
MU


Joined: 24 Aug 2005
Posts: 13642
Location: Karlsruhe, Germany

PostPosted: Sat 05 Nov 2005, 08:21    Post_subject:  

fine Very Happy
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0641s ][ Queries: 12 (0.0172s) ][ GZIP on ]