Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 21 Dec 2014, 02:19
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
MuppyQuickmount (August, 08, 2008)
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [30 Posts]   Goto page: 1, 2 Next
Author Message
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Sun 03 Aug 2008, 13:32    Post subject:  MuppyQuickmount (August, 08, 2008)  

This is a very fast drivemounter.

It does NOT support Floppy drives.

It supports harddisks and external drives, like USB-Sticks.
CD/DVD drives can be used from a second window, that increases speed.

Note:
If your drive is not listed, you might have an old Puppy, that misses nodes (Puppy 301/400).
In that case, install this bugfix:
http://murga-linux.com/puppy/viewtopic.php?p=214416#214416

MuppyQuickmount requires Puppybasic and Gtkdialog3.


Also have a look a pdrive:
http://www.murga-linux.com/puppy/viewtopic.php?t=21200

You can get a pet that includes muppyquickmount, Muppy-Filer and Gtkbasic all together from here:
http://www.murga-linux.com/puppy/viewtopic.php?p=224716

Mark
MuppyQuickmount.pet
Description 
pet

 Download 
Filename  MuppyQuickmount.pet 
Filesize  9.95 KB 
Downloaded  1209 Time(s) 
MuppyQuickmount.jpg
 Description   
 Filesize   102.45 KB
 Viewed   2244 Time(s)

MuppyQuickmount.jpg


_________________
my recommended links

Last edited by MU on Tue 11 Oct 2011, 12:29; edited 9 times in total
Back to top
View user's profile Send private message Visit poster's website 
lapis

Joined: 02 Jun 2008
Posts: 185

PostPosted: Sun 03 Aug 2008, 16:59    Post subject:  

I like the quickness of this, thanks. I have a slow dvd drive in my laptop so Mut can be slow even though I almost never use the dvd so this is great.

One question, the free space does not show anything but apart from that it detects all drives and their sizes correctly.

Edit:
Sorry, spoke too soon. I tried mounting some ntfs drives and they show up in MUT as mounted but I can't copy anything to them.
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Sun 03 Aug 2008, 17:43    Post subject:  

ok, uploaded new version.
now ntfs-drives should me mounted read/write.
I also added an option to mount all drives.
And you can repair them.

The list now uses a monospace font.

lapis, free spaces is shown for mounted drives only.
Or is it not shown for yours?
What Puppy do you use?

Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Sun 03 Aug 2008, 18:50    Post subject:  

I added another option:
"find free space on all drives".
This will mount unmounted drives, get the free space, then unmount them again.

As this is slower, it is not active by default.

Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Sun 03 Aug 2008, 19:43    Post subject:  

I forgot to add a file required to repair partitions.
It opens Puppys repairprograms in rxvt.
Added it now.

Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Sun 03 Aug 2008, 22:20    Post subject:  

I added the option to mount CDs.
This opens a new window, so the speed of harddrive-detection is not affected..
I tested it with just one drive, so I cannot guarantee, it works with all.

Now with these options it might make sense to use Gtkdialog instead of xdialog for a nicer interface like pdrive?

Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
lapis

Joined: 02 Jun 2008
Posts: 185

PostPosted: Mon 04 Aug 2008, 09:28    Post subject:  

MU wrote:

free spaces is shown.


I've installed your newer version and I have free space showing now. It did not show for mounted drives before.

However, I've gone backwards on everything else. I can't mount or unmount anything now and it won't close unless I kill the process.

If this is because I am using Puppy 2.15ce then I will give up. It was just that your earlier version seemed like it worked as it showed all drives and unmounted everything fine.
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Wed 06 Aug 2008, 04:54    Post subject:  

I made a major rewrite.

It now uses Puppys Gtkdialog3 instead of Xdialog.
It works more reliable when determing the freespace on all drives.

And it has this new option:

--------------------------------------------------
The "mount on" option:

Puppy mounts everything to "/mnt/".
This is the old Unix standard.

In 2008 there also is the new approach to mount removable media to "/media/".

Both standards can cause collisions.
So Gnome 2.22.1 will not display drives, that are mounted to /mnt/ by an entry in /etc/fstab.

MuppyQuickmount gives you the choice:

- "/mnt/" mounts to /mnt/ without using /etc/fstab.
- "/media/" mounts to /media/ without using /etc/fstab.
- "use "fstab" mounts to the mountpoint definded in /etc/fstab.

---------------------------------------------------------
Explanation of fstab:

/etc/fstab has informations, to where a device shall be mounted.
It also may contain additional info, like what codepage (language) shall be used.

So in general, it makes sense, to use this.

If you get problems, e.g. in Gnome, use the other options.

As with the options "/mnt/" and "/media/" you cannot set a language, there also is a 4th option:
"use mqmtab".
You can copy /etc/fstab to /etc/mqmtab.
This is a file used ONLY by MuppyQuickmount.

So drives can be mounted with language options, without conflicting with Gnome.


(c) Mark Ulrich, 2008
License: GPL V3 or later

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Wed 06 Aug 2008, 04:57    Post subject:  

lapis, please try the new one.
If you still have problems, please type in a consolewindow:
Code:
muppyfinddisks -m

muppyfinddisks -m -all

muppyfinddisks -m -free

muppyfinddisks -m -free -forcefree


Then tell me, where the error occurs.
Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
lapis

Joined: 02 Jun 2008
Posts: 185

PostPosted: Wed 06 Aug 2008, 10:17    Post subject:  

MU wrote:
If you still have problems


Thanks Mark, this is excellent. If I still have problems with this I can't find them. Smile

Mount/unmount NTFS and VFAT partitions all ok. Even closes properly Wink

I have said goodbye to MUT. No more having to listen to the DVD drive spin up. Quickmount it is in name and deed.

I like the double click on the chosen partition line to mount/unmount as well.

Only one small comment, it would be good to have some separation (either physically or with colours) between the different listed drive classes like HDAx grouped separately from SDAx and so on. Pardon me for not knowing if the gtkdialog can do that or not and maybe also mounted devices being in bold?
Back to top
View user's profile Send private message 
MU


Joined: 24 Aug 2005
Posts: 13644
Location: Karlsruhe, Germany

PostPosted: Fri 08 Aug 2008, 03:31    Post subject:  

I found a small bug, and corrected it.
If you had a drive mounted like sda10, then you could not mount sda1.
It thought, it was mounted already.

I also tested it in Puppy 400, works fine Cool
Mark

_________________
my recommended links
Back to top
View user's profile Send private message Visit poster's website 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Fri 08 Aug 2008, 04:15    Post subject:  

Quote:
I also tested it in Puppy 400, works fine Cool
Mark


Very good Mark,
much appreciated.

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send private message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2386
Location: UK

PostPosted: Wed 20 Jan 2010, 19:31    Post subject:  

I realise this thread is quite old now, but I'm looking to use Muppyquickmount - particulary the mount all command/button..

I have this script in /root/startup (not mine):

Code:
#!/bin/bash
xmessage -bg orange -center -buttons "" "Please wait, your drives are being mounted." &
pid=$!

cd /usr/local/MuppyQuickmount/resource/
./muppyquickmount -mode:mountall xxx
kill $pid


However, whenever I use the above script, or the mount all button in the gui, my NTFS partitions are read only..
It's driving me crazy...

They mount properly if I mount them seperately, but if I use 'mount all', it's always read only NTFS...

Any ideas?? I'd be very, very grateful for a fix..

One more question, if anyone can help.. What's the best way to unmount all partitions at shutdown?

I guess putting a few commands in /etc/rc.shutdown would be the right place, but what commands to use??

Thanks..

_________________
Akita Linux, VLC-GTK, Pup Search, Pup File Search
Back to top
View user's profile Send private message 
lapis

Joined: 02 Jun 2008
Posts: 185

PostPosted: Sat 23 Jan 2010, 03:42    Post subject:  

sc0ttman wrote:
whenever I use the above script, or the mount all button in the gui, my NTFS partitions are read only..
They mount properly if I mount them seperately, but if I use 'mount all', it's always read only NTFS...


I guess this is related to the original issue where ntfs was only mounted read only. MU fixed it for single mounts but maybe there was separate code for mounting all. I am afraid I am not good enough to follow the code but I think it has to do with the Mount command not mounting ntfs and vfat properly when the auto option is used or no file type is specified.

I noticed that vfat partitions are not mounted by MuppyQuickmount with long file names used but If you specifically have
mount -t vfat /dev/sda1 /mnt/sda1
Then long file names show up.

I like MuppyQuickmount for its speed but it would be nice if these two things could be fixed.

With regard to unmounting, I thought Puppy unmounted everything on shutdown already. Just for some reason it only shows unmounting of one partition in the shutdown messages.

Anyway, I think this does it
umount -a
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7841
Location: qld

PostPosted: Sat 23 Jan 2010, 04:20    Post subject:  

Hi

As far as I can tell, in the shutdown script in 4.3x the command "mount" is run to see what filesystems are mounted and then goes on to unmount them. It is reflected in the shutdown with "unmounting stray filesystems"..

You could try Startmount. It could fullfil your needs.

Cheers

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 2 [30 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0958s ][ Queries: 13 (0.0143s) ][ GZIP on ]