Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 10 Dec 2018, 23:24
All times are UTC - 4
 Forum index » House Training » HOWTO ( Solutions )
Enable Playback of Multiple sounds / streams / apps at once
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [1 Post]  
Author Message
telemetric_au

Joined: 28 Feb 2007
Posts: 54

PostPosted: Mon 01 Sep 2008, 01:40    Post subject:  Enable Playback of Multiple sounds / streams / apps at once
Subject description: with alsa dmix, for cards not supporting hardware mixing / mulitplexing
 

ok this was surprisingly simple , and im glad i looked into it, as it was annoying not to hear skype calls or IM sounds when watching a movie or otherwise already using the sound device.

firstly for details sake im running an old cheap on-board acer 230 laptop sound card;

#aplay -L

default:CARD=I82801DBICH4
Intel 82801DB-ICH4, Intel 82801DB-ICH4
Default Audio Device

basically cheap cards like this and ac97's don't support hardware mixing of streams and need software to do it for them.

following this guide here, I searched out the sources for and installed

alsa-oss, alsaplayer, and mpg321

(alsaplayer-alsa and alsa-base are also mentioned but i skipped them as they appear ok with puppy alpha 5)

*
you may not even need to install any of these you may be able to just setup the config below, as the apps are merely for testing, though maybe not alsa-oss, it may even come with puppy ?? im not fussed i enjoy installing sources now i have the devfs hooked up.
*


so the short of it is i created a .asoundrc file in /root/ with the following contents:
Code:


pcm.dsp0 {
    type plug
    slave.pcm "dmix"
}
# mixer0 can stay unchanged, because
# it isn't used anyway, I guess ;)
ctl.mixer0 {
    type hw
    card 0
}


and now everything plays at once Smile

(if it doesn't work for you see the guide as there are other setup options)

though i had to install newer pet of VLC.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [1 Post]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » HOWTO ( Solutions )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0426s ][ Queries: 12 (0.0076s) ][ GZIP on ]