Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 18 Apr 2014, 08:57
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
sound (yet again) on 1.02
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [10 Posts]  
Author Message
achilles

Joined: 16 May 2005
Posts: 5

PostPosted: Sun 05 Jun 2005, 14:41    Post subject:  sound (yet again) on 1.02  

Should I have my cdrom (/dev/hdc) linked to some device
other than /dev/cdrom?

/lib/modules/2.6/sound/oss includes "es1371.ko.gz" (the correct
module for my sound card.

Query PCI (under Hardware probe) shows:-
"1274:1371 (4,1) 11 [ESS Technology - Ensoniq ES1371]
AUDIO es 1371" This is expected.

the Modules button in the same place shows:-
"AUDIO es1371: ESS Technology Ensoniq ES1371
(1274:1371) running"

Under /dev, I have the expected devices, for example:-
/dev/audio, /dev/audio0, /dev/dsp, /dev/mixer, /dev/music
and /dev/sndstat.

But, none of the CD players included work and I can find no
sound configuration GUI or explanations.

I'm fairly certain that my CDRom drive is fine and I can use
headphones through it. I have an audio cable installed.

I've never understood the working of sound, and at this stage
need it only to play CD's.

I've all the postings relative to sound, but have seen nothing
to help me.
Back to top
View user's profile Send private message 
Rich

Joined: 04 May 2005
Posts: 278
Location: Middlesbrough - UK

PostPosted: Sun 05 Jun 2005, 16:52    Post subject:  

I'm assuming you have sound working on your system..........
try playing an mp3 through Gxine to confirm this.
If it's working then there's no problem with the sound configuration.

As far as CD's go, the quick test is to put one in the drive, open a terminal window and type ' cdplay '.

Let us know the results.
Back to top
View user's profile Send private message 
danleff


Joined: 08 May 2005
Posts: 294
Location: Albany, NY

PostPosted: Sun 05 Jun 2005, 19:14    Post subject:  

...and make sure that the sound is turned up. If sound is working, you should have the mixer microphone icon on the bottom right of the task bar (like that other OS). Click on this and make sure the first graphic bar, and that for cd playing are turned up, almost all the way.
_________________
I love it when a plan comes together

--Hannibal Smith
Back to top
View user's profile Send private message Visit poster's website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Sun 05 Jun 2005, 20:40    Post subject:  

danleff wrote:
...and make sure that the sound is turned up. If sound is working, you should have the mixer microphone icon on the bottom right of the task bar (like that other OS). Click on this and make sure the first graphic bar, and that for cd playing are turned up, almost all the way.


Double-click on the sound icon.

Another quick way to test sound is to use Rox, go to /usr/share/audio/, then just click on the sound files -- they should play.
Back to top
View user's profile Send private message Visit poster's website 
achilles

Joined: 16 May 2005
Posts: 5

PostPosted: Mon 06 Jun 2005, 04:05    Post subject:  

Thanks everyone, but none of the suggestions work.

#cdplay in a terminal starts the drive, but no sound
issues. A small 'audio control panel' icon appears in
the task bar, but I can do nothing with it.

Clicking on sound files in /usr/share/audio produce
no sound.

I do not see the 'mixer microphone' icon in the task bar
so sound is not working (per danleff).

Maybe I phrased my question badly. I knew I had no
sound, but cannot understand why. How do the various
playback programs know my CDdrive is /dev/hdc?
I thought that might be the problem and that I should
create a link to /dev/audio0 or some other device.

Any other suggestions please?. Googling has a mass
of info on sound, but nothing I've seen so far on the
full setup requirements.
Back to top
View user's profile Send private message 
Jesse

Joined: 08 May 2005
Posts: 465
Location: Auckland, NZ

PostPosted: Mon 06 Jun 2005, 09:46    Post subject:  

Hi achilles,

Sometimes sound cards are working but not obviously, because some volume control is set to a low value and linux does not have easy access to set it.

Look next to the clock in the bottom right courner for a yellow speaker icon, double click brings up a program called "xmixer" set ALL the volume levels up to max, and check the volume dial on the right is twisted clock wise to maximum setting. Check that you're speakers are pluged into the sound output, and that they have power & switched on etc... Put in an audio CD and use Start->Multimedia->gplaycd then click the play icon.
Does the cdrom drive spin up? Do you hear anything?
If it still fails, see if your motherboard has a sound card on it, and plug speakers in there and try playing cd, even if you disabled it in BIOS.

Jesse
Back to top
View user's profile Send private message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 10662
Location: Arizona USA

PostPosted: Mon 06 Jun 2005, 10:16    Post subject:  

Here's another suggestion Wink :

Do you have any other OS you can use? For instance, does the sound work in Windows? If you don't have Windows, how about a Knoppix CD or some other version of Linux?
Back to top
View user's profile Send private message 
achilles

Joined: 16 May 2005
Posts: 5

PostPosted: Mon 06 Jun 2005, 11:40    Post subject:  

I've managed to move things forward somewhat, but
the perceived basic problem seems to me to still obtain.

This box I built from 'bits and pieces', so I've looked
to see what else I have. I changed the sound card from
PC128 to a SB Live and added a DVD drive as hdd,
putting the cable (from hdc) onto hdd.

Now, I can get good sound by using rxvt and typing
#cdp -c /dev/hdd (thanks to Rich - I'd never heard of
that program before). I can't navigate, however, as I'm
unable to activate numlock.

#cdp -c /dev/hdc sets the drive, which is a CDR one,
working but without sound. Someone on another list
advised me that it is not necessary to have a cable
connected (for reasons above my powers of understanding)
and certainly that is the case on another box with another OS.

Now, none of the progams under 'multimedia' give me
any sound on either drive and double clicking the
speaker icon (Jesse) does absolutely nothing. So, what
is still wrong? Slightly off topic, why cannot I enable
numlock (my keyboard is gb and set up as such - all
the left-side keys respond correctly)?

Speakers are definitely OK - I have spares and have
tried three sets.

By the way, when I rebooted after the hardware changes
Puppy (without any action from me) created a soft link
/dev/dvd to /dev/hdd

Thank you for your patience and attempts to solve my
problem - you've no doubt realised I'm very old, but
'dead keen' and persistent.

Regards.
Back to top
View user's profile Send private message 
GuestToo
Puppy Master

Joined: 04 May 2005
Posts: 4078

PostPosted: Mon 06 Jun 2005, 14:17    Post subject:  

about numlock, see this post:
http://www.murga.org/~puppy/viewtopic.php?t=51
Back to top
View user's profile Send private message 
Jesse

Joined: 08 May 2005
Posts: 465
Location: Auckland, NZ

PostPosted: Mon 06 Jun 2005, 21:45    Post subject:  

Hi,

The xtmix program cam also be started from Start->Multimedia->Xtmix
Hope that helps.

Jesse
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [10 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0686s ][ Queries: 12 (0.0050s) ][ GZIP on ]