Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 27 Aug 2014, 11:27
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking » Dialup
Globetrotter HSDPA USB modem not working
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 2 [24 Posts]   Goto page: Previous 1, 2
Author Message
tempestuous

Joined: 10 Jun 2005
Posts: 5238
Location: Australia

PostPosted: Wed 05 Mar 2008, 23:25    Post subject:  

kattami wrote:
Code:
--> Cannot open /dev/usb/ttyUSB0: No such device or address

Yes, wescht reported this same problem, but in his 4th post he solved it by having the modem plugged in while booting up ... which is contrary to the process he explained in his 1st post.
wescht also reports in his 4th post the importance of creating the file /etc/ppp/peers/wvdial

kattami wrote:
I am right now in the wvdial.conf file and put in phonenumber and also PIN code in dialer default and dialer pin ...

Just checking; the pin code should go under the "[Dialer pin]" section, to replace the default pin code "1234".
If this continues to be an issue, you could consider deactivating the pin under Windows, as wescht suggested.
Back to top
View user's profile Send private message 
kattami

Joined: 17 Jan 2008
Posts: 109
Location: Norway

PostPosted: Thu 06 Mar 2008, 16:19    Post subject:  

tempestuous wrote:
kattami wrote:
Code:
--> Cannot open /dev/usb/ttyUSB0: No such device or address

Yes, wescht reported this same problem, but in his 4th post he solved it by having the modem plugged in while booting up ... which is contrary to the process he explained in his 1st post.
wescht also reports in his 4th post the importance of creating the file /etc/ppp/peers/wvdial

kattami wrote:
I am right now in the wvdial.conf file and put in phonenumber and also PIN code in dialer default and dialer pin ...

Just checking; the pin code should go under the "[Dialer pin]" section, to replace the default pin code "1234".
If this continues to be an issue, you could consider deactivating the pin under Windows, as wescht suggested.


But the thing is that I did boot up with the usb device plugged in the next morning, and got the same message.

I will look in Vista (ugh) if that program that comes up has any disable pin function. Didnt see that when I tried with XP on another laptop my father uses.

I could not figure out how to do this with the modem dialup programs.
Back to top
View user's profile Send private message 
kattami

Joined: 17 Jan 2008
Posts: 109
Location: Norway

PostPosted: Sun 09 Mar 2008, 09:49    Post subject:  

You know, I had the feeling that the Vista would be a big problem, and heck, I got right, again!

I went to Vista to get up that program and get the modem to work there and then disable the pin (saw that the program did have the disable pin function, very cool).

But Vista didnt show the usb modem as it should do. Its showing it as a DVD drive????

So the program cant find the usb modem it in Vista. And Puppylinux, as good as it is, did find the same DVD drive Vista is telling me the usb modem is.

Thats just too funny, lol.
Back to top
View user's profile Send private message 
kattami

Joined: 17 Jan 2008
Posts: 109
Location: Norway

PostPosted: Tue 18 Mar 2008, 01:30    Post subject:  

A small update:

I removed Vista to try to install XP, but XP is saying it cant find any harddisk on this computer.

I lost motivation to keep on messing with this for the time being, but I at least found out something when doing over again what wescht did.

At the code
Code:
modprobe usbserial vendor=05c6 product=0x1000


the log says:
Code:
Mar 18 04:29:26 (none) kern.info kernel: usbcore: deregistering interface driver usb-storage
Mar 18 04:30:04 (none) kern.info kernel: usb 2-1: new full speed USB device using uhci_hcd and address 4
Mar 18 04:30:05 (none) kern.info kernel: usb 2-1: configuration #1 chosen from 1 choice
Mar 18 04:45:01 (none) kern.info kernel: usbcore: registered new interface driver usbserial
Mar 18 04:45:01 (none) kern.info kernel: drivers/usb/serial/usb-serial.c: USB Serial support registered for generic
Mar 18 04:45:01 (none) kern.info kernel: usbcore: registered new interface driver usbserial_generic
Mar 18 04:45:01 (none) kern.info kernel: drivers/usb/serial/usb-serial.c: USB Serial Driver core

So it is obviously not doing anything with the ttyUSB0. Thats why its not finding the ttyUSB0 when I do the next step, using the wvdial.

I went to the site that has with this device to do and they recommend this site when its about getting the Option HSDPA Usb modems to work in Linux.

From what I can see I have either GT MAX 3.6 (7.2 Ready) or GlobeTrotter Express 7.2. I am not sure which of them I have because when it was working on the other laptop in winXP, it says speed 7.2 Mbps in the program for the mobile internet.

Anyway, they obviously use USB_modeswitch to get many of those devices to work.

GT Max 3.6 forum

and

http://www.draisberghof.de/usb_modeswitch/

Tried to search here if there is any USB_modeswitch compiled for puppylinux but havent found anything so far.
Back to top
View user's profile Send private message 
kattami

Joined: 17 Jan 2008
Posts: 109
Location: Norway

PostPosted: Wed 05 Nov 2008, 01:19    Post subject: Just a small update  

Hi again.

I gave up trying to figure out this after several tries where I couldnt get the compiling to work in the puppylinux (puppylinux frugal installation plus devx sfs file and also full installation on the laptop). Didnt go further than that.

Now I am somewhere where I have only the cellphone modem to get online with (only with windows) and will not have a chance to get any other ways of internet access for some weeks. So no possibility to get puppylinux online in meantime.

But anyway I found that the cellphone modem I have is a GlobeSurfer Icon 7.2 and that the driver for it has no .inf file so I cant use Ndiswrapper either to get this to work. It has only one .sys file and Ndiswrapper didnt take it.

Steps for the Globesurfer Icon 7.2. is here

Note: the icon_switch.c is updated with usb_modeswitch where they have the information how to get this to work on different linux versions.

"download icon_switch.c http://www.frederick-reid.com/files/icon_switch.c
change the product id in the file from 6600 to 6901
Compile (note that you need to have libusb installed):

Code:

cc -l usb -o icon_switch icon_switch.c


Move the file to /usr/sbin/

Edit /etc/udev/rules.d/10-local.rules (add it if it doesn't exists) and add the following two rules:

Code:

BUS=="usb", SYSFS{idProduct}=="1000", SYSFS{idVendor}=="05c6", RUN+="/usr/sbin/icon_switch"
BUS=="usb", SYSFS{idProduct}=="6901", SYSFS{idVendor}=="0af0", RUN+="/sbin/modprobe usbserial vendor=0x0af0 produc
t=0x6901"


The simplest way is to reboot your computer (or reload the rules into udev and restart it). Do not have the iCON plugged in while booting,

When you computer is up and running again, plugg the iCON in.
Now list you USB devices:

Code:

# lsusb

Within 30 seconds you should have a device presenting it self as "Option"
Code:

Bus xxx Device xxx: ID 0af0:6901 Option


Now you should have three new nodes in /dev/

Code:

 ls /dev/ttyUSB*
/dev/ttyUSB0  /dev/ttyUSB1  /dev/ttyUSB2


Now your iCON should be working. I use kppp to connect. the only important things in kppp is the following:
The modem pointing at /dev/ttyUSB0 (could perhaps be 1 or 2 as well don't know the difference)
I use RTS/CTS as flowcontrol.
Deselect "wait for dial tone"
Add the connection, dial *99# and use PAP as authentication
Username and password should not matter."

************

So I am per today stuck at being not able to compile the icon_switch.c and therefore cant try this setup.

I dont have motivation or energy to start again with different installation of puppylinux to try to figure out how to get compiling to work after failing so many times last time.

So I post this just in case someone is looking for information how to get Globesurfer Icon 7.2 to work with puppylinux. First step would be to compile the icon_switch.c, or even better, usb_modeswitch.

Thanks
Back to top
View user's profile Send private message 
kattami

Joined: 17 Jan 2008
Posts: 109
Location: Norway

PostPosted: Tue 11 Nov 2008, 01:58    Post subject: Globesurfer Icon 7.2 is working with puppylinux 4.1.1  

Well, well, see what the cat dragged in.....

I finally got the usb modem to work.

After seeing that it begins to be more people asking about how to get puppylinux to work with the new usb-dongles, I decided to do a new try with the newest versions that I could find. I asked another one who had got his to work and he was so kind to reply to me. But unfortunately his setup didnt work for me. Thanks alot for the quick reply anyway Smile

I also found a good guide in a norwegian forum and it was from that norwegian guide that I finally found the combination that works for my globesurfer in puppylinux.

So, in puppylinux version 4.1.1 with devx_411.sfs, and for Globesurfer Icon 7.2, this is what worked:

1. Save a frugal installation on the harddisk.

2. Add the devx.sfs in bootmanager

3. Reboot

4. Download usb_modeswitch-0.9.5.tar.bz2

5. Extract the usb_modeswitch package.

6. go to terminal and type
Code:
gcc -l usb -o usb_modeswitch usb_modeswitch.c


7. Here I got unsure about what is what of the files so I put both the usb_modeswitch.c and usb_modeswitch file in /sbin and /urs/sbin. I just didnt bother figuring out which file it was about and where it should be. Up to the experts to point out this one.

8. Put the file usb_modeswitch.conf into /etc and edit with geany to the number your usb dongle uses. In my case with globesurfer icon 7.2, I changed to the text for globesurfer icon 7.2 (adding the ; where the first globesurfer model lines is and removing the ; where my globesurfer model is).

Code:

DefaultVendor=  0x05c6
DefaultProduct= 0x1000

TargetVendor=   0x0af0
TargetProduct=  0x6901

MessageEndpoint=0x05
MessageContent="55534243123456780000000000000601000000000000000000000000000000"


9. Then I installed the nozomi-2.21alpha-k2.6.21.7.pet. They said it was for puppylinux 3.x versions and I was nervous that it wouldnt work for puppylinux 4.1.1. Fortunately it did.

10. Installing gnome-ppp-0.3.23-1.pet

11. Reboot

12. Typed in terminal the word usb_modeswitch - it found one productdevice.

13. Typed dmesg - I saw there it had switched the modem from usb-storage to ttyUSB0, ttyUSB1 and ttyUSB2

14. Then I went to gnome-ppp and added the phonenumber for my usb dongle in username and password and then

*99#

where it says phonenumber

15. I hit connect just to test it, expecting that I would have to edit the wvdial.conf file. To my big surprise it connected.

The end.

PS: I dont know how to change title of thread to "Solved"??
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5238
Location: Australia

PostPosted: Wed 12 Nov 2008, 08:08    Post subject:  

kattami wrote:
Then I installed the nozomi-2.21alpha-k2.6.21.7.pet. They said it was for puppylinux 3.x versions

"They" is me. You're referring to the nozomi driver dotpet package from here
http://www.murga-linux.com/puppy/viewtopic.php?p=163587#163587
The "k2.6.21.7" in the name of the dotpet tells you what kernel version the driver package is compatible with - so it's compatible with Puppy 3.x and 4.0 which both have the 2.6.21.7 kernel.
Sure it will install in Puppy 4.1.1, but it will be completely ineffectual, so clearly the "nozomi" driver is not necessary at all ... and this is confirmed by the nozomi compatibility list here -
http://www.pharscape.org/content/view/40/53/

kattami wrote:
expecting that I would have to edit the wvdial.conf

wvdial.conf is the configuration file for wvdial. But you're using gnome-ppp as your dialler application, not wvdial.
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5238
Location: Australia

PostPosted: Wed 12 Nov 2008, 08:26    Post subject:  

EDIT: usb_modeswitch utility now available here -
http://www.murga-linux.com/puppy/viewtopic.php?p=254448#254448

Last edited by tempestuous on Thu 18 Dec 2008, 08:46; edited 1 time in total
Back to top
View user's profile Send private message 
kattami

Joined: 17 Jan 2008
Posts: 109
Location: Norway

PostPosted: Wed 12 Nov 2008, 14:18    Post subject:  

tempestuous wrote:
kattami wrote:
Then I installed the nozomi-2.21alpha-k2.6.21.7.pet. They said it was for puppylinux 3.x versions

"They" is me. You're referring to the nozomi driver dotpet package from here
http://www.murga-linux.com/puppy/viewtopic.php?p=163587#163587
The "k2.6.21.7" in the name of the dotpet tells you what kernel version the driver package is compatible with - so it's compatible with Puppy 3.x and 4.0 which both have the 2.6.21.7 kernel.
Sure it will install in Puppy 4.1.1, but it will be completely ineffectual, so clearly the "nozomi" driver is not necessary at all ... and this is confirmed by the nozomi compatibility list here -
http://www.pharscape.org/content/view/40/53/

kattami wrote:
expecting that I would have to edit the wvdial.conf

wvdial.conf is the configuration file for wvdial. But you're using gnome-ppp as your dialler application, not wvdial.


Yeah, I know it was you. I just didnt want to say something about a person, if you get me. Kinda anonymizing things, just to be respectful.

So you are telling me that it was not necessary to install the nozomi drivers?

Thats interesing. I didnt try the usb_modeswitch and gnome-ppp alone, because I tried to install once before only usb_modeswitch and then trying to modify the wvdial. That didnt work.

Next time I need to install this on new savefile I will remember to just use usb_modeswitch and gnome-ppp.

When its about gnome-ppp it says that it needs wvdial version 1.5 I think, and I saw in that norwegian guide that he had modified the wvdial.conf to point to telenor and other things that had with my country to do, hence I said I expected having to modify that file.

But in my case it connected with pppd after waiting abit so I didnt need to modify it at all.

Thanks alot for the pet file Smile
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 2 [24 Posts]   Goto page: Previous 1, 2
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Networking » Dialup
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0956s ][ Queries: 12 (0.0037s) ][ GZIP on ]