Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 02 Sep 2014, 19:49
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Audio
m1330 No Sound. Fixes?
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [6 Posts]  
Author Message
kcin1204

Joined: 12 Nov 2008
Posts: 3

PostPosted: Wed 12 Nov 2008, 21:57    Post subject:  m1330 No Sound. Fixes?
Subject description: Dell M1330 w/ Intel High Definition Audio
 

I just installed Puppy 4 (newest version, using unetbootin) and everything is working perfectly (vpnc, wifi, video, etc.) except sound. Now i did the audio config and set it up with what it auto detected (same as in ubuntu) and it wont play any sounds. I tried going into the alsa mixer and turning up all of the volumes but to no avail.

Any tips? ideas? fixes?

Thanks in advance!
Back to top
View user's profile Send private message 
cthisbear

Joined: 29 Jan 2006
Posts: 3404
Location: Sydney Australia

PostPosted: Wed 12 Nov 2008, 22:17    Post subject:  

" Any tips? ideas? fixes? "

Yes there are.

Any tips on model of hardware....ram.....etc

Puppy version....you say the latest...so do we assume Puppy 4.1.1
retro or standard.

" 2.6.25.16, 2.6.21.7 kernels. The 'standard' Puppy has been built with the 2.6.25.16 kernel. The 'retro', which may work better on some older hardware, has been built with the 2.6.21.7 kernel and with a more conservative configuration. The older kernel is configured with the old IDE drivers (instead of PATA)*. "

http://puppylinux.com/download/release-4.1.1.htm

/////////////
Can someone get back to me on this similar issue.

Thanks.................Chris

http://www.murga-linux.com/puppy/viewtopic.php?t=35480
Back to top
View user's profile Send private message 
technosaurus


Joined: 18 May 2008
Posts: 4348

PostPosted: Wed 12 Nov 2008, 22:39    Post subject:  

what sound card did it detect?

did it bark at you during setup?
Back to top
View user's profile Send private message 
kcin1204

Joined: 12 Nov 2008
Posts: 3

PostPosted: Thu 13 Nov 2008, 01:07    Post subject: oops sorry....  

I just automatically assumed everyone knew what an m1330 was.... my mistake. The machine that i am referring to is the Dell XPS M1330 laptop.
Intel(R) Core(TM)2 Duo CPU T7250 @ 2.00GHz
The sound hardware is:
Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)
Ram: 2GB
The kernel version is: 2.6.21.7

It detected the HDA driver correctly but for whatever reason it still wont function....

Thanks guys!
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5246
Location: Australia

PostPosted: Thu 13 Nov 2008, 06:20    Post subject:  

Try this - open /etc/modprobe.conf in geany, and add this line
Code:
options snd-hda-intel model=5stack

Save. Reboot.

The theory is explained here
http://www.murga-linux.com/puppy/viewtopic.php?t=22383
Back to top
View user's profile Send private message 
kcin1204

Joined: 12 Nov 2008
Posts: 3

PostPosted: Thu 13 Nov 2008, 16:47    Post subject:  

thanks guys, i appreciate the help! I remember having to do something like this with ubuntu 7.10(gutsy)
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [6 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Audio
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0490s ][ Queries: 12 (0.0055s) ][ GZIP on ]