Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 17 Sep 2014, 23:51
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Audio
Alsa volume go to zero after reboot
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [8 Posts]  
Author Message
alejobar

Joined: 05 Sep 2008
Posts: 27

PostPosted: Fri 14 Nov 2008, 13:21    Post subject:  Alsa volume go to zero after reboot  

Hi there,

I just tried puppy 4.1 in two old Pemtium 2 pcs, one I used Puppy 4.1 regular and I had to use Puppy 4.1 retro for the other one because it didn't start after installation. The one that I used Puppy retro have a Creative Sound blaster sound card, when I used puppy 4 I had to change manually the Modprobe file to snd -sbawe to get the sound working, now with the new puppy I just run alsaconf and puppy found the correct card, then I set up the volume in Alsa mixer, Master 90% PCM 90%, close and reboot.
After reboot I can see now the the speaker in the tray, but its marked with a red X, so click it turn up the volume, no sound! Confused , run alsamixer again master was up, PCM was in zero, again I change it manually, this time I type alsactl store to save the settings, reboot and again the red X and no sound Mad , so I run alsactla restore and settings are back but why they don't stay after reboot? how can I fix this? I hope someone can help me
Back to top
View user's profile Send private message 
alienjeff


Joined: 08 Jul 2006
Posts: 2291
Location: Winsted, CT - USA

PostPosted: Fri 14 Nov 2008, 14:03    Post subject:  

Once your levels are set to your liking, ESC alsamixer. Then type: alsactl store

See if that works.

_________________
hangout: ##b0rked on irc.freenode.net
diversion: http://alienjeff.net - visit The Fringe
quote: "The foundation of authority is based upon the consent of the people." - Thomas Hooker

Back to top
View user's profile Send private message 
alejobar

Joined: 05 Sep 2008
Posts: 27

PostPosted: Fri 14 Nov 2008, 16:43    Post subject:  

alienjeff wrote:
Once your levels are set to your liking, ESC alsamixer. Then type: alsactl store

See if that works.


Hi Jeff, I tried that after change alsa mixer, I pressed esc the open terminal and used alsactl store command, reboot, but no joy Sad , If I open terminal and type alsactl restore I can see the changes in Alsamixer, but I have to load them manually Shocked
Back to top
View user's profile Send private message 
`f00


Joined: 06 Nov 2008
Posts: 809
Location: the Western Reserve

PostPosted: Sat 15 Nov 2008, 13:30    Post subject: pesky absvolume?  

Sometimes the tray applet (usually absvolume) plays nice with alsamixer, sometimes not - sometimes absvolume disappears - it'd be wonderful if all hwr worked oob, but then how would the user ever learn cli Wink

Thanks for the tip to 'lock in' alsamixer settings, AJ - yep, sometimes they get deprecated if the pup 'finds' etwas anders 1st (like an old usb headset that's still plugged in, lol) hint that something's off - 1 setting vs the many sliders and mutes on an emu10k
Back to top
View user's profile Send private message 
alejobar

Joined: 05 Sep 2008
Posts: 27

PostPosted: Mon 17 Nov 2008, 11:46    Post subject:  

Still no luck! I tried all the commands and Alsa don't seem to keep the settings after boot, even they are stored Evil or Very Mad , everything seems to wor fine with puppy 4.0 but know I have this problem with puppy 4.1 retro, I guess this will q be a bug or something. I hope someone else could give me a possible solution
Back to top
View user's profile Send private message 
Pizzasgood


Joined: 04 May 2005
Posts: 6270
Location: Knoxville, TN, USA

PostPosted: Tue 18 Nov 2008, 00:00    Post subject:  

Hmm... Looks like the script /etc/rc.d/rc.alsa is set up to save and restore the settings on shutdown and bootup. But it has some if statements. It won't even attempt to restore the sound unless these conditions are met:
the sound driver was started successfully
alsactl is located at /usr/sbin/alsactl specifically and is executable
the directory /proc/asound exists
the file /etc/asound.state exists and is readable

My guess is one of those isn't being satisfied properly, causing Puppy to not even try restoring the sound settings.

If you can't track down what exactly the problem is, you should be able to workaround it by adding the command alsactl restore to /etc/rc.d/rc.local.

_________________
Between depriving a man of one hour from his life and depriving him of his life there exists only a difference of degree. --Muad'Dib

Back to top
View user's profile Send private message Visit poster's website 
alejobar

Joined: 05 Sep 2008
Posts: 27

PostPosted: Tue 18 Nov 2008, 12:43    Post subject:  

thanks Pizzasgood, I'm going to check all that and see what could be the problem.
Yesterday I installed a cheap PCI audio card and puppy recognized at boot up and everything seems to work, but the sound is not as great as the old HUGE creative Awe card, I took it off the computer and its really a HUGE card hahahaha, so I will try to install it again and see what happen.

I really think its a bug, because I tried in another computer, an old Compaq Armada M700, I remember I had to edit modprobe manually with Puppy 4.00 to make the sound work, now Puppy 4.1 seems to find the card after alsaconf, but again I have trouble with the volume settings and with absvolume in the taskbar.
Back to top
View user's profile Send private message 
smagin

Joined: 20 May 2011
Posts: 1

PostPosted: Fri 20 May 2011, 08:40    Post subject:  

Hi.
That's what I did to overcome muting volume every reboot. i have Crystal CS3247B ISA, Puppy 4.3

1. Switch off PNP OS in bios
2. add pnpbios=off to /boot/grub/menu.lst to the end of linux kernel boot string
3. Install sound with alsaconf (run "alsaconf" in terminal)
4. Run alsamixer, unmute all channels and maximize them. Check if sound works.
5. Exit alsamixer and run "alsactl store"
6. Add "alsactl restore" to the end of /etc/init.d/rc.local
7. Reboot

By the way, the zmixer's icon in tray stays X-ed after reboot but sound works actually.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [8 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Audio
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0611s ][ Queries: 12 (0.0039s) ][ GZIP on ]