Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 22 Oct 2014, 12:11
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
How to connect to MYSQL with Puppy?
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [3 Posts]  
Author Message
evil

Joined: 19 Nov 2005
Posts: 55

PostPosted: Thu 24 Nov 2005, 11:01    Post subject:  How to connect to MYSQL with Puppy?  

Hi all,

I am relatively new to puppy and have recently been trying to connect to my mysql databae on another PC.

The code works under RedHat and Slackware (as tested) but not under puppy. I thought that puppy was therefore not able to connect to mysql databases.

My alternative is to use quisp instead of mysql but i'd prefer mysql if possible.

The code is executing and then fails when trying to call a library file (libmysqlclient.so.....) and brings up the error: 'SEGMENTATION FAULT'.
The exe is in root/my-applications/bin and the 4 required lib files are in root/my-applications/lib.

Is this compatability issues between puppy and mysql.

Any clues???

Thanks all[/b]
Back to top
View user's profile Send private message 
Ian
Official Dog Handler


Joined: 04 May 2005
Posts: 1237
Location: Queensland

PostPosted: Thu 24 Nov 2005, 21:58    Post subject:  

You may have to place the exe in /usr/bin or /usr/local/bin and the libs in /usr/lib or /usr/local/lib.

Have a look and see where they are installed in RedHat & Slackware and do the same with Puppy.

Check to make sure ou have all the required files & libs.

If you go to RedHat and type ldd /the name of your exe, at a command line it should show you the libs required and where the loader finds them.
Back to top
View user's profile Send private message 
evil

Joined: 19 Nov 2005
Posts: 55

PostPosted: Fri 25 Nov 2005, 07:48    Post subject:  

Yes I have tried the ldd... and all the necessary libraries are there.

I cannot put the libraries and exe in the locations you suggested because I am booting puppy from a compact flash and its mounted as read-only even with full priveleges under root.

The libmysqlclient libraries are precompiled files and therefore I can't get the c code from here to debug and see exactly where it is failling.
However I think the problem is one of 2:
1). The library files are not seen/accessed for some reason
2). Puppy cannot handle mysql. Has anyone else tried??

Thanks
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [3 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0413s ][ Queries: 12 (0.0055s) ][ GZIP on ]