Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 30 Jul 2014, 17:42
All times are UTC - 4
 Forum index » House Training » HOWTO ( Solutions )
HOW TO Fix resolution / refresh rate on Intel 815
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [11 Posts]  
Author Message
Glitchman
Guest


PostPosted: Tue 22 Nov 2005, 05:03    Post subject:  HOW TO Fix resolution / refresh rate on Intel 815  

If you have been struggling to get decent colors, resolution, and refresh rate in Puppy, you are not alone. I have an Intel 815 chipset with an integrated video card. To put it nicely, the video card is a POS. With the right drivers, I can go as high as 1280*1024 in 24-bit color in several versions of Windows, but Puppy's default Xvesa driver only allows 800*600 in 16-bit color at best. Thanks to several others on this message board, here is what has recently worked for me:

First, you will want a fresh pup001 file to avoid any potential conflicts. Back up any pup001 files you have and boot to the live CD, creating a new pup001 file in the process.

Second, set up your Internet connection as usual. (I personally use xeznet with chat=no option since nothing else works for me.) Download your favorite window manager with PupGet and switch to it to prevent problems later (I use fvwm95, the default window manager in previous versions of Puppy.)

Now the fun begins. Download xorg682c.pup to a safe place, like ~/my-documents. When that finishes, you can launch it from ROX. It will then ask for your confirmation to overwrite files, so just let it install. Once that finishes, you will not be able to change your resolution the old way anymore (via Xvesa Video Wizard.) You will be using the new video driver the next time you restart X, so we will need to set it up first:

Exit to a prompt and type xorgconfig in order to set up your video and mouse. Follow through the questions, answering as conservatively as possible if you are unsure of the answers. Since I know that I can get 1280*1024 with 24-bit color and 85 Hz refresh rate in Windows, I answer the prompts accordingly. I also select "** Intel 810 (generic)" even though mine is actually an Intel 815. The video memory question is the tough one. In my case, answering 4096K is too much, since it was generating extra lines on the screen. Answering 2048K is safe for an Intel 815, although I have been successful answering with 3072K. Once you find out how much memory works best, you can always lower it later on to lower your resolution. Finally answer the default color depth that you prefer (e.g. 24-bit) and allow it to write the config file.

Now start X by typing xwin and (hopefully) everything should look better. If there is any indication of extra lines on the screen, flashing, or distortion, then hit Control-Alt-Backspace to get back to a prompt and go through the setup again, this time picking more conservative values (i.e. lower refresh rate range or less RAM.) With trial and error, you should be able to find the right settings.

One of the first things you may notice is that your fonts are suddenly very small, even in 800*600 resolution. It is most noticeable on menus in most programs, as well as any text that you type in leafpad. In order to fix this problem, I followed MU's suggestion on this forum to add the following line to /etc/.Xdefaults:

Code:

Xft.dpi: 108


However, I find a value of 76 (or so) to be closer to what the fonts used to be under the old video driver (Xvesa.) Adjust this as you see fit and restart X to see the new settings.

Now when you have everything the way you like it, you might notice that your mouse wheel no longer scrolls, but still functions as the middle mouse button. If you are also affected by this, there is a simple fix. First, browse to /etc/X11/ and backup the xorg.conf file. You will be making a simple change to this file. Look for part of the file that looks something like the following:

Code:

# **********************************************************************
# Core Pointer's InputDevice section
# **********************************************************************

Section "InputDevice"

# Identifier and driver

    Identifier   "Mouse1"
    Driver   "mouse"
    Option "Protocol"    "Auto"
    Option "Device"      "/dev/mouse"


Obviously, yours may vary depending on your type of mouse. I copied the following line from pakt's config file on this message board:

Code:

    Option "ZAxisMapping" "4 5"           # Enable the scroll wheel


If all goes well, adding that line should fix the mouse wheel after you have exited and re-entered X.

Final notes:

You might notice that Puppy may not properly shutdown the first time you use the new driver. I am not sure why, but it appeared to clear itself for me. I also noticed that this new video driver fixed the Caps Lock / Num Lock bug that has been plaguing Puppy since version 1.04. That is, you had to press each key FOUR times to toggle on/off rather than two. This is especially noticeable in fvwm95, where the Alt-Tab key sequence only works when the Num Lock is off. This has also repaired the right Alt key as well, which did not appear to do anything previously. I tried to fix all these things by trying out other PupGet packages, DotPups, and custom-made iso's, but to no avail. In a nutshell, Xorg682c has fixed almost all these problems for me.

I hope this helps anyone else who has been fighting video options. Good luck with the new video driver!
Back to top
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 10948
Location: Arizona USA

PostPosted: Tue 22 Nov 2005, 09:02    Post subject:  

Excellent, and thanks! Smile
Back to top
View user's profile Send private message 
gliezl


Joined: 06 Aug 2005
Posts: 322
Location: Manila

PostPosted: Tue 22 Nov 2005, 18:43    Post subject:  

Very nice! Thanks Smile
_________________
"If you have knowledge, let others light their candles in it."
~Margaret Fuller

Back to top
View user's profile Send private message 
mayakovski


Joined: 19 Nov 2005
Posts: 124
Location: Comox, BC, CANADA

PostPosted: Thu 24 Nov 2005, 14:01    Post subject: Glitchman is my hero.  

Very Happy
Finally instructions I can follow and that work for me.

These worked great, the only difference was that after following the instructions and rebooting from the Live CD to the HD Install I had to rerun the Xorg install and rerun the xorgconfig as it did not seem to be there from the Live CD install. That was probably just my lack of Linux savvy. But hey, I'm learning.

Only other thing is where the heck is the pup001 file you mention to backup? I searched all of the directories and could not find it so I just skipped that step, though I would like to know where it is for future issues.

One question though, is there a way to manuallu force a refresh rate? Currently it defaults 1024x768 to 72 Hz, I would like to boost this to 85 as that is easier on my eyes. But I cannot figure out where to set this.

Thanks

And again, Many thanks for the instructions. I owe you a Big Beer Glitchman.

Mayakovski
Back to top
View user's profile Send private message 
mayakovski


Joined: 19 Nov 2005
Posts: 124
Location: Comox, BC, CANADA

PostPosted: Fri 25 Nov 2005, 14:41    Post subject: Re: HOW TO Fix resolution / refresh rate on Intel 815  

I find that the scroll wheel code works, but since I have a wireless mouse and keyboard if I leave this as is when I exit to prompt I loose the mouse and keyboard completely. I have to comment out this line, exit to prompt and then re enable the scroll code when I am back in the Puppy GUI.

Just a note for anyone else experiencing this.

Glitchman wrote:

Code:

    Option "ZAxisMapping" "4 5"           # Enable the scroll wheel


_________________
Mayakovski
**********************
Puppy Linux | Barking Up The Right Tree

Compaq Armada 1580DMT | P150, 49MB RAM - 3.2 GB HD, Puppy 1.0.6
Compaq Deskpro EN | P3-733, 384 MB RAM - 80GB HD, Puppy 1.0.7
Back to top
View user's profile Send private message 
kethd

Joined: 20 Oct 2005
Posts: 451
Location: Boston MA USA

PostPosted: Sat 26 Nov 2005, 16:06    Post subject: FrameBuffer NeoMagic  

I have been struggling to get a FrameBuffer enabled Puppy for my Dell Latitude NeoMagic video chipset. Wonder if your xorgconfig dot-pup install instructions will work for that?
Back to top
View user's profile Send private message 
Zonkle

Joined: 28 Sep 2005
Posts: 16
Location: Damascus, Syria

PostPosted: Tue 29 Nov 2005, 04:27    Post subject:  

Thanks.

But before I try it, can you please tell me if it would solve my Tv-out problem?

I have nVidia MX420 with Tv-out, and it has the output as NTSC by default .... is there anyway to change that under Puppy?

Thanks.
Back to top
View user's profile Send private message Visit poster's website 
JTjtJT
Guest


PostPosted: Mon 19 Dec 2005, 18:38    Post subject: Re: FrameBuffer NeoMagic  

kethd wrote:
I have been struggling to get a FrameBuffer enabled Puppy for my Dell Latitude NeoMagic video chipset. Wonder if your xorgconfig dot-pup install instructions will work for that?


This is something I also would like to know...
Anyone?
JT
Back to top
kethd

Joined: 20 Oct 2005
Posts: 451
Location: Boston MA USA

PostPosted: Mon 19 Dec 2005, 19:00    Post subject:  

JT,
Try the new Puppy 1.0.7alpha -- it comes with Xorg framebuffer built-in, works for me (with patience).
Back to top
View user's profile Send private message 
Guest
Guest


PostPosted: Sun 25 Dec 2005, 18:17    Post subject:  

kethd wrote:
JT,
Try the new Puppy 1.0.7alpha -- it comes with Xorg framebuffer built-in, works for me (with patience).


Forgot to thank you, so... Thank You! X works now nicely with my ancient Dell Latitude CPi. Airo wireless missing, so I am trying that now.

And your hint was there in 22 minutes... impressive!
JT
Back to top
tempestuous

Joined: 10 Jun 2005
Posts: 5218
Location: Australia

PostPosted: Sun 25 Dec 2005, 19:55    Post subject:  

The aironet modules have been trimmed from Puppy in the interests of size.
Get them as an add-on package here http://mymirrors.homelinux.org/puppy/wireless/

Another forum member, jimj, reported that Aironet pcmcia cards may need to be reset to work like this -
cardctl eject
cardctl insert
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [11 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » HOWTO ( Solutions )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0786s ][ Queries: 12 (0.0037s) ][ GZIP on ]