Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 20 Dec 2014, 19:12
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects » Next Puppy Development » 4.x
Puppy 4.2 Alpha4 Seamonkey Bugs & Fixes
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 17 [252 Posts]   Goto page: Previous 1, 2, 3, 4, 5, ..., 15, 16, 17 Next
Author Message
Pizzasgood


Joined: 04 May 2005
Posts: 6270
Location: Knoxville, TN, USA

PostPosted: Mon 09 Feb 2009, 03:01    Post subject:  

@WhoDo: Shouldn't it have replaced that with the one from packages/ after you ran createpuppy?

@ttuuxxx: I'm sorry, I was mistaken. It wasn't the default theme, it was Odelite. Elegance and Bluemat also could benefit from this.

I have a floating box too. Gotta go to bed though so I can't test it. This is gonna be another crazy week...

The thing tom4jesus mentions about freememapplet is something I've seen in JWM too, so that makes sense. Maybe freememapplet is getting launched before the icewmtray is loaded properly. I think I saw something like that before, back when I was a regular IceWM user.
blocky.png
 Description   
 Filesize   24.78 KB
 Viewed   1289 Time(s)

blocky.png

theme.png
 Description   
 Filesize   7.44 KB
 Viewed   1224 Time(s)

theme.png

flat.png
 Description   
 Filesize   18.16 KB
 Viewed   1274 Time(s)

flat.png


_________________
Between depriving a man of one hour from his life and depriving him of his life there exists only a difference of degree. --Muad'Dib

Back to top
View user's profile Send private message Visit poster's website 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15122
Location: Paradox Realm

PostPosted: Mon 09 Feb 2009, 03:10    Post subject:  

Quote:
STOP PRESS: Zigbert, trio and 01micko have worked hard on Pwidgets and version 0.7 is now available for download. I strongly recommend updating to this before testing. It will be in the next release, no question, and it works like a charm.


Downloading seems OK - got the ISO easily

Pwidgets 0.7 is much improved but I eventually had several widgets open but only the clock displaying. Maybe I need to do an x restart . . . Nope - not that. It seems something to do with the refreshing of the program . . .

'Hotpup' with the exclamation marks would seem to be a good priority for fixing in the beta Smile
The swapping between jwm and icewm is easier and both window mangers were working Smile

Thanks guys for all your efforts and passionate (at times) team work. Very Happy
I was working on a database (see cutting edge) and we might swap to C programming - not sure if it will be in Deep Thought - early pre-alpha days for that Cool

I would urge going for Beta (you get more testers and feedback) if possible on the next release - the feature set is there?

I believe the 100MB is a good idea and I feel we will get a 4.2 Barebones provided (maybe from Wolfpup) usually within a few days - this would enable two official versions?

_________________
Puppy WIKI

Last edited by Lobster on Mon 09 Feb 2009, 03:14; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
WhoDo


Joined: 11 Jul 2006
Posts: 4441
Location: Lake Macquarie NSW Australia

PostPosted: Mon 09 Feb 2009, 03:11    Post subject: Re: jwm menu format  

Tom Raft wrote:
I miss the hacked fixmenus script from zigberts DeepThougt theme.

Yeah, not deliberate ... just an oversight. I'll add it to my list. Thanks. Embarassed

_________________
Actions speak louder than words ... and they usually work when words don't!
SIP:whodo@proxy01.sipphone.com; whodo@realsip.com
Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 10847
Location: Ontario Canada,Sydney Australia

PostPosted: Mon 09 Feb 2009, 03:22    Post subject:  

Hey WhoDo

your puppy pin fix, cleaned up my desktop extra icons:)
Butttttttt pmount is still broken for my sata2 and also when I click preferences it crashes. (I like the single row, not the tab version Wink )
also that damn 'insert key' problem is back!!! Funny when I compiled seamonkey it was fine and now its back, I read somewhere it was a gdk issue
ttuuxxx

Ps anyone tried the Cups package on page 1 I made?
and

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send private message Visit poster's website 
ttuuxxx


Joined: 05 May 2007
Posts: 10847
Location: Ontario Canada,Sydney Australia

PostPosted: Mon 09 Feb 2009, 03:24    Post subject:  

a free memory applet goes, I've never seen it leave the IceWm taskbar, I compiled it on series 4 and its been stable ever since, I've seen it fly off jwm tons of times but never icewm, I guess we could put a long delay, and have it tested.
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send private message Visit poster's website 
trio


Joined: 21 Dec 2008
Posts: 1950
Location: अनुमोदना

PostPosted: Mon 09 Feb 2009, 03:25    Post subject:  

Lobster:

I found few bugs in pwidgets 0.7 and I was telling zigbert about it:

Quote:
Very Happy ZIGBERT:

Teacher, nevermind the test, I found the problem, pwidgets-exec (pwidgets 0.7):
#Pwidgets
$HOME/.pwidgets/pwidgets-exec_xonclock &
$HOME/.pwidgets/pwidgets-exec_xli &
$HOME/.pwidgets/pwidgets-exec_conky &

should be:

#Pwidgets
$HOME/.pwidgets/pwidgets-exec_xli &
$HOME/.pwidgets/pwidgets-exec_xonclock
$HOME/.pwidgets/pwidgets-exec_conky

right? Thanks
Back to top
View user's profile Send private message Send e-mail
trio


Joined: 21 Dec 2008
Posts: 162
Location: Jakarta, Indonesia


PostPosted: Today, at 01:56 Post subject: Reply with quote Edit/Delete this post
Zigbert:

two more issues regarding pwidgets 0.7:

1. slideshow config:

I have to change from:

#### BASIC SETTINGS #####
#IMAGE_DIRECTORY="/usr/share/backgrounds"
IMAGE_DIRECTORY="/root/my-images"
DELAY=15 #in seconds

to

#### BASIC SETTINGS #####
IMAGE_DIRECTORY=/usr/share/backgrounds
#IMAGE_DIRECTORY="/root/my-images"
DELAY=15 #in seconds

in order to work

2. Weather/Weather_BG

Both using pweather as the font, but with my computer after mkfontdir & mkfontscale the font is listed as pweather1.ttfand it cannot be read by conky, I renamed the font to pweather.ttf and did mkfontdir & mkfontscale again, and it worked. Can you just change rename to pweather.ttf in the package?

Thanks

Last edited by trio on Mon 09 Feb 2009, 03:30; edited 1 time in total
Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 10847
Location: Ontario Canada,Sydney Australia

PostPosted: Mon 09 Feb 2009, 03:27    Post subject:  

this is all the info pmount gives me when I run it via command line
/pmount: line 290: 19889 Terminated yaf-splash -font "8x16" -outline 0 -margin 4 -bg orange -text "Puppy Drive Mounter

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send private message Visit poster's website 
WhoDo


Joined: 11 Jul 2006
Posts: 4441
Location: Lake Macquarie NSW Australia

PostPosted: Mon 09 Feb 2009, 03:27    Post subject:  

Pizzasgood wrote:
I attached a patch. Assuming it is downloaded to the puppy-unleashed/boot/ directory, it would be applied like this:
Code:
gunzip init-rem_auto_cp_to_hd.patch.gz
patch initrd-tree0/init init-rem_auto_cp_to_hd.patch

Thanks, PG. Patch applied as directed. Next version should lose that particular problem. Cool

Cheers

_________________
Actions speak louder than words ... and they usually work when words don't!
SIP:whodo@proxy01.sipphone.com; whodo@realsip.com
Back to top
View user's profile Send private message 
WhoDo


Joined: 11 Jul 2006
Posts: 4441
Location: Lake Macquarie NSW Australia

PostPosted: Mon 09 Feb 2009, 03:42    Post subject:  

pa_mcclamrock wrote:
I won't say anything about printing except that I didn't try it and, when I see an announcement that it works again at last, I'll try it.

You'd have had a hard time trying it in Alpha4 ... I removed CUPS so ttuuxxx and the guys could install and test on a clean build. Razz

pa_mcclamrock wrote:
Calendar is back in Claws Mail, I see. This is not an improvement...[snip]... The Calendar feature in Claws Mail is embarrassingly bad and should be trashed, "IMHO."

If it is as ordinary as you say, I'll remove it. ttuuxxx gave me two versions to choose from and this time I included the version with the calendar. I haven't even looked myself, yet.

pa_mcclamrock wrote:
I checked my e-mail with Claws and got the mail, but I also got an error message saying "The Bogofilter plugin couldn't filter a message. The command `bogofilter -T -b` couldn't be run."

I'll check it out. It may be as simple as a missing library dependency.

pa_mcclamrock wrote:
When I type text in my Tcl/Tk text/HTML editor (WISH Supernotepad) while running JWM, the titlebar blinks periodically. This doesn't happen while running IceWM.

Confused

pa_mcclamrock wrote:
Could you possibly bring yourself to squeeze in the very good-looking DejaVu Serif and DejaVu Sans Mono fonts in addition to DejaVu Sans, which Puppy already has?

"We'll see..." Wink

pa_mcclamrock wrote:
Tcl/Tk 8.5.6 now works correctly--almost. I no longer get the "no ttk" error message when I run Tk apps, and most of mine work right. The exceptions are two that use the Tcl "clock" command. Here's the error message I get when I try to run these from the command line. (Should I PM rarsa about this?)

If you want it fixed then rarsa is your man.

pa_mcclamrock wrote:
Also, when I ran WISH CD-Writer, I got a message saying cdrdao isn't in my PATH. Is there a successor to cdrdao for audio CD-writing from the command line? If so, what is it?

cdrkit replaced cdrdao early in the Dingo 4.xx series.

pa_mcclamrock wrote:
And now for something really bizarre. ..[snip]...I wonder what's going on here!

I don't know but it could be the reason Barry didn't move up the 2.8 version of Rox filer that I have just included. If we get any more bizarre behaviour I'll roll it back out in favour of the 2.6.1 version previously installed.

pa_mcclamrock wrote:
Oh, and one more little thing: What if I don't want an analog clock and a calendar on my desktop? How do I get rid of them? Rolling Eyes

Menu>Desktop>Pwidgets and remove any offending widget by clicking on the widget in the right panel and then clicking the blue minus sign above the panel before hitting "apply".

Hope that helps

_________________
Actions speak louder than words ... and they usually work when words don't!
SIP:whodo@proxy01.sipphone.com; whodo@realsip.com
Back to top
View user's profile Send private message 
WhoDo


Joined: 11 Jul 2006
Posts: 4441
Location: Lake Macquarie NSW Australia

PostPosted: Mon 09 Feb 2009, 03:54    Post subject:
Subject description: the little fix maybe
 

`f00 wrote:
imo, this should be user-set and not a default startup on initial boot. Also if it's like it was in a1 and I believe a3, it has a script in /root/Startup dir that may still run fixwidgets ..

The trouble is that most users wouldn't even know it was there if you didn't have it running at first boot. The average refugee certainly wouldn't go looking for it. This way they find out it's there and can use the right hand panel to disable it if they don't like it. JMHO. Wink

_________________
Actions speak louder than words ... and they usually work when words don't!
SIP:whodo@proxy01.sipphone.com; whodo@realsip.com
Back to top
View user's profile Send private message 
WhoDo


Joined: 11 Jul 2006
Posts: 4441
Location: Lake Macquarie NSW Australia

PostPosted: Mon 09 Feb 2009, 03:57    Post subject:  

ttuuxxx wrote:
Hey WhoDO did you remove the shutdown menu again?? it was part of the /etc/xdg/templates/_root_.icewm_menu in the latest icewm package

Again? Confused I didn't remove it the first time! Razz I got quite a surprise that it wasn't there too. It may be a clash of menu templates in the packages directory of Unleashed - something else is overwriting the one from Icewm-4.20v5 because that is installed first with createpuppy. I thought you might have disabled it or something with v5. I'll look into it. Rolling Eyes

_________________
Actions speak louder than words ... and they usually work when words don't!
SIP:whodo@proxy01.sipphone.com; whodo@realsip.com
Back to top
View user's profile Send private message 
WhoDo


Joined: 11 Jul 2006
Posts: 4441
Location: Lake Macquarie NSW Australia

PostPosted: Mon 09 Feb 2009, 04:00    Post subject:  

ttuuxxx wrote:
pmount isn't working properly, its not letting me mount my sata2 hard drive, this is a first for puppy Confused
also I thought the reason why we have tcl/tk was to get mut working, well the gui doesn't work either for mut, the command line does, ummmmm maybe I can see a alpha 5 emerging, lol

Confused This hasn't been changed at all in any 4.2 Alpha. Please check out the included new packages list on p1 - maybe one of the newer packs broke it. Idea

_________________
Actions speak louder than words ... and they usually work when words don't!
SIP:whodo@proxy01.sipphone.com; whodo@realsip.com
Back to top
View user's profile Send private message 
WhoDo


Joined: 11 Jul 2006
Posts: 4441
Location: Lake Macquarie NSW Australia

PostPosted: Mon 09 Feb 2009, 04:03    Post subject:  

jrb wrote:
I have reconfigured the load_sfs.pet for 420. It now puts a link to load_sfs in /root/.config/rox.sourceforge.net/SendTo/.application_x-squashfs-image making it work in Rox right-clicks.

Ok but I'll hang on to this before implementing. Hairywill may patch the later version of Rox filer or I may revert to the earlier version 2.6.1 which uses OpenWith rather than SendTo.

_________________
Actions speak louder than words ... and they usually work when words don't!
SIP:whodo@proxy01.sipphone.com; whodo@realsip.com
Back to top
View user's profile Send private message 
WhoDo


Joined: 11 Jul 2006
Posts: 4441
Location: Lake Macquarie NSW Australia

PostPosted: Mon 09 Feb 2009, 04:08    Post subject:  

Pizzasgood wrote:
@WhoDo: Maybe you should set up Qemu and give the isos a quick test-run with it before uploading them, so you can verify for sure whether or not your partitions were included before it's uploaded.

Just a bit of overkill in response to a dose of Oldtimer's disease Razz , but I take your point. I uploaded Alpha4 at the last possible minute because I want to impose an immediate feature freeze prior to going beta. I was getting pretty tired when the last file uploaded around 4.30am local time. Mea culpa. Embarassed

_________________
Actions speak louder than words ... and they usually work when words don't!
SIP:whodo@proxy01.sipphone.com; whodo@realsip.com
Back to top
View user's profile Send private message 
WhoDo


Joined: 11 Jul 2006
Posts: 4441
Location: Lake Macquarie NSW Australia

PostPosted: Mon 09 Feb 2009, 04:12    Post subject:  

Pizzasgood wrote:
@WhoDo: Shouldn't it have replaced that with the one from packages/ after you ran createpuppy?

It would have if I had run createpuppy again after updating the packages directory instead of opting for the shortcut complete2sfs! Embarassed

_________________
Actions speak louder than words ... and they usually work when words don't!
SIP:whodo@proxy01.sipphone.com; whodo@realsip.com
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 3 of 17 [252 Posts]   Goto page: Previous 1, 2, 3, 4, 5, ..., 15, 16, 17 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects » Next Puppy Development » 4.x
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1094s ][ Queries: 13 (0.0075s) ][ GZIP on ]